none
insufficient access rights error when doing backup

    질문

  • Im using dbo schema for ABC SQL Server 2005 Enterprise database on my laptop.  I would like to deploy the ABC into a server running on SQL Server 2005 Standard database.  The server database is using abcuser schema.  I can do attach/detach and backup/restore on the server. 

    I got error so I generated sql script and install into the server.  So now I see all the tables are created with abcuser schema.  Once I tried to generate a backup from the server I got the following error.  what is the problem guys?

    Property BackupDirectory is not available for Settings 'Microsoft.SqlServer.Management.Smo.Settings'. This property may not exist for this object, or may not be retrievable due to insufficient access rights.  (Microsoft.SqlServer.Smo)

    I have no idea what it means by insufficient access rights.  How do I solve it?

    2006년 3월 10일 금요일 오전 8:03

답변

  • All you have to do is add a string value to the registry pointing to the default backup directory for the given SQL Instance.

     

    For instance, if you are in the default SQL instance, create the "BackupDirectory" string value under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQLServer and in the value itself put the complete path for the default backup directory you want.

     

    If you are unconfortable working in the registry, paste the text between # to a file and rename it DB_Bck.REG.

    Just run it and you should be good to go:

     

    #

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQLServer]
    "BackupDirectory"="C:\MyBckDir"
    #

     

    After running this, your default backup directory for the default instance of your SQL Server points to C:\MyBckDir (make sure you create the folder).

     

     

    If you have a named instance of a SQL Server, just add the name of instance before "\MSSQLSERVER". If you have an instance named FAXSERVER, you must use the following key:

     

    #

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\FAXSERVER\MSSQLServer]
    "BackupDirectory"="C:\MyBckDir"
    #

     

     

    Hope this helps.

     

    • 답변으로 제안됨 daniel-at 2009년 1월 14일 수요일 오후 2:48
    • 답변으로 표시됨 Papy NormandModerator 2009년 2월 7일 토요일 오전 11:59
    2007년 3월 28일 수요일 오후 1:40

모든 응답

  • You can backup database without any GUI. Just execute the command: "backup database ABC to disk='c:\fa.bak'"

    2006년 4월 21일 금요일 오전 8:21
  • All you have to do is add a string value to the registry pointing to the default backup directory for the given SQL Instance.

     

    For instance, if you are in the default SQL instance, create the "BackupDirectory" string value under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQLServer and in the value itself put the complete path for the default backup directory you want.

     

    If you are unconfortable working in the registry, paste the text between # to a file and rename it DB_Bck.REG.

    Just run it and you should be good to go:

     

    #

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQLServer]
    "BackupDirectory"="C:\MyBckDir"
    #

     

    After running this, your default backup directory for the default instance of your SQL Server points to C:\MyBckDir (make sure you create the folder).

     

     

    If you have a named instance of a SQL Server, just add the name of instance before "\MSSQLSERVER". If you have an instance named FAXSERVER, you must use the following key:

     

    #

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\FAXSERVER\MSSQLServer]
    "BackupDirectory"="C:\MyBckDir"
    #

     

     

    Hope this helps.

     

    • 답변으로 제안됨 daniel-at 2009년 1월 14일 수요일 오후 2:48
    • 답변으로 표시됨 Papy NormandModerator 2009년 2월 7일 토요일 오전 11:59
    2007년 3월 28일 수요일 오후 1:40
  • Thanks a lot. It fixed my problem.
    2007년 6월 1일 금요일 오전 8:02
  • i have followed the same methods ..registry updates and restarted the system ..using windows xp prof. sp2 with sql server 2005..

    i can take backup from query analyzer..i want take backup from GUI...

    still error shows

    "property backup directory not available for settings microsoft.sqlserver.management.smo.settings this property may not exist for this object or may not be retrievable due to insufficient access rights "..pl.

     

    2007년 7월 2일 월요일 오전 8:08
  • That didn't work for me either. I got it to work though by putting the BackupDirectory string value under the  [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQLServer] key. Note this was for SQL Server 8.0.760 MSDE.
    • 답변으로 제안됨 Pepoš 2010년 3월 29일 월요일 오전 7:46
    2008년 3월 6일 목요일 오후 6:39
  • You might want to check the permissions for the service account running SQL Server.  It needs full access rights to the directory where you're putting the backup.  Remember, it's not your user account performing the backup, it's the account you've designated to run SQL Server that's creating the file.

     

    2008년 3월 7일 금요일 오후 12:38
  •  BlueLeviathan wrote:

    All you have to do is add a string value to the registry pointing to the default backup directory for the given SQL Instance.

    ...

    If you have a named instance of a SQL Server, just add the name of instance before "\MSSQLSERVER". If you have an instance named FAXSERVER, you must use the following key:

     

    #

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\FAXSERVER\MSSQLServer]
    "BackupDirectory"="C:\MyBckDir"
    #

     

    This worked perfectly for me running SQL Server 2005 on Windows Server.  The BackupDirectory string did not exist for the server running for my Sharepoint functions.  So adding in the string in regedit did the trick. 

     

    Thank you.

     

    2008년 3월 27일 목요일 오후 6:14
  • Thats above solution worked for me. That was great, thanks a lot.

    2008년 8월 9일 토요일 오전 7:16
  • I have a similar issue and thought you may be able to help me. I installed SharePoint and used the standard database. I could not get the the SQL Management Studio database back up to perform and it was suggested that I upgrade to SQL Server 2005 Express. When I tried to run the backup I received the message 'Backup property is not available' 'Microsoft.SQLServer.Management.SMO.Settings. After install I still cannot perform a backup of the SharePoint database.

    Is this due to a registry issue as mentioned in this thread? If, so I never edited or created a change in the registry can you explain this to me?

    The path in my registry is different than the one in this thread.
    HKEY_Local_Machine/Software/Micorsoft/MicrosoftSQLServer/MSSQL.2005/MSSQLServer



    thanks,
    2009년 1월 12일 월요일 오후 8:08
  •  

    The path to the Backup directory in my registery is HKEY_LOCAL_MACHINE>Software>Microsoft SQL Server>
    BackupDirectory Type: REG SZ Data: C:\WINNT|SYSMSI\SSEE\MSSQL.2005\MSSQL\BACKUP

    Also under the Microsoft SQL Server key is MICROSOFT##SSEE which as a key MSSQL Server with the only value of ad(default Type: REG_SZ and Data: (value not set)

    'C:\WINNT|SYSMSI\SSEE\MSSQL.2005\MSSQL\BACKUP'
     does not come up in when I use the backup function Task>Backup.
    Are you still suggesting that I change the 'Data:' to a new destination such as 'C:\SharePointBAKs?

    Is the named instance found inside the Object Explorer of SQL Management Studio.
    In my case the name is 'serverName\SharePoint (SQL Server 8.0.2039- ServerName)'.
    Do I include (SQL Server 8.0.2039- ServerName) as part of the named instance?

    I never peformed an edit inside the registry. Is it as simple as hitting the add button and following the prompts. 


    The following example you provide, how is it peformed.
    Do I just click on the pane in the registry hit the add button and paste
    this '[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\FAXSERVER\MSSQLServer]
    "BackupDirectory"="C:\MyBckDir"' for the data?

    #
    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\FAXSERVER\MSSQLServer]
    "BackupDirectory"="C:\MyBckDir"
    #

    2009년 1월 14일 수요일 오후 3:31
  • Yuriy privet, u menya analogichnaya problema chto i u neosamz , mojesh mne po pochte na russkom obyasnit' kak sdelat' backup? moya pochta 2622316@mail.ru
    2009년 9월 16일 수요일 오전 5:40
  • Thank you, this worked perfectly.
    2013년 12월 11일 수요일 오전 11:38
  • I got the same error while restoring my local database copy.You need to add string value key pair in the registry at HKEY_LOCAL_MACHINE>SOFTWARE>Microsoft>Microsoft SQL Server>MSSQLServer .In the name write BackupDirectory and in the value field the path of your backup directory.You can find details and screenshots at

     http://www.superpctricks.com/2014/04/property-backupdirectory-is-not-available-for-settings.html

    2014년 4월 29일 화요일 오후 12:04