none
Error when i try to Deploy my reports to Reporting services - PLEASE HELP i'm also NEW at this

    Domanda

  •  

    Hi

    I'm running a SQL 2000 DB with reporting Services 2005 and Visual Studio 2005, I can connect and browse to Reporting Services through any management console and even to my site through //ServerName/Reports but when i try to deploy any of my reports to the Reporting Services through my VS2005 solution i get this error

     

    A connection could not be made to the report server http://Forge/Reports.

    Additional Information:

    The Attempt to connect to the report server failed. Check your connection information and that the report server is a compatible version. (Microsoft.ReportingServices.Designer)

    The status of all of my things in Reporting Services Configuration is Green and i can see my site in the IIS, i can also browse my site, it just doesn't want2 deploy.

     

    Please HELP!!!

    venerdì 29 settembre 2006 11:03

Risposte

  • Try deploying to http://forge/reportserver instead.
    lunedì 2 ottobre 2006 23:57
    Moderatore
  • Hi

    I traced down my problem, but i'll post my solution here just incase some else might battle with the same problem.

    When i installed the RS i changed the Virtual Directory Name to Forge too, so when i deployed them i had to deploy them to Forge/Forge instead of Forge/ReportServer which it suppose to be by default.                                                                                                                                 ---->PC Name / ReportServer Virtual Directory<--------

    martedì 28 novembre 2006 10:09

Tutte le risposte

  • I suspect the problem lies here:

    >I'm running a SQL 2000 DB with reporting Services 2005 and Visual Studio 2005

    and, considering the error:

    >that the report server is a compatible version

    I am thinking there is a problem with your deploying RS 2005 reports to a 2000 RS database.  I wasn't aware you could deploy 2005 reports to a 2000 RS database.  Maybe you can do it if you don't convert (existing 2000) reports, I am not sure; but I doubt you'll be able to deploy them if you have converted them from 2000 to 2005.  I especially think and new reports will bomb out since they would be native 2005. 

    There are threads in this forum that talk about this subject.

    venerdì 29 settembre 2006 14:41
  • Try deploying to http://forge/reportserver instead.
    lunedì 2 ottobre 2006 23:57
    Moderatore
  • wow.  good eye!
    martedì 3 ottobre 2006 00:39
  • Thanks for th information but it still gives me the same error, but don't worry too much about it, i'm just going to reinstall SQL 2000 RS with Visual Studio 2003. apparently there is some incompatibility issue between .Net Framework 2.0 and 1.1 that prevent my solutions from working properly, so until i figure out the exact problem and link the Frameworks manually in my solution i doubt that it will work.

    Thanks a lot for your effort guys!

    martedì 3 ottobre 2006 09:35
  • Hi

    I traced down my problem, but i'll post my solution here just incase some else might battle with the same problem.

    When i installed the RS i changed the Virtual Directory Name to Forge too, so when i deployed them i had to deploy them to Forge/Forge instead of Forge/ReportServer which it suppose to be by default.                                                                                                                                 ---->PC Name / ReportServer Virtual Directory<--------

    martedì 28 novembre 2006 10:09