none
Can I use BIDS 2008 with VS2005?

    Pertanyaan

  • Hello, 

    At our workplace, we're currently using VS2005 with reporting services 2005 (SSRS 2005) to deploy reports online from a couple of Oracle databases. I'd like to upgrade to SSRS 2008 R2/2010 to particularly take advantage of maps functionality in the later versions of SSRS. 

    Do I need to request an upgrade to BOTH VS 2008 and BIDS 2008 or can I just request an upgrade to BIDS 2008 to plug into my existing installation of VS 2005?  Also, can BIDS 2008 use SQL Server 2005? I appreciate 2005 can't use 2008. 

    Thanks All!


    07 Maret 2012 5:52

Jawaban

  • Hi MrZeroPercent,

    You could upgrade to BIDS 2008 with existing installation of VS2005.
    In addition, BIDS is a component of SQL. BIDS 2008 could use SQL Server 2005.


    Thanks,
    Maggie


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. This can be beneficial to other community members reading the thread.

    • Ditandai sebagai Jawaban oleh MrZeroPercent 11 Maret 2012 15:32
    08 Maret 2012 9:11

Semua Balasan

  • Do you want to upgrade SSRS 2005 to SSRS2008 but SQL Server 2005 you cannot? Why? I would suggest you not to mess up all things and upgrade all products

    Best Regards, Uri Dimant SQL Server MVP http://dimantdatabasesolutions.blogspot.com/ http://sqlblog.com/blogs/uri_dimant/

    07 Maret 2012 6:23
  • Hi Uri, 

    Thanks for your reply. Yes, I want to upgrade SSRS 2005 to SSRS 2008. It shouldn't be a problem to have VS 2005 upgraded to 2008, but I just wasn't sure if it was necessary as we do most of our reporting from two Oracle databases and the SQL Server I have access to isn't administered by me so I have no control over its version. But I do want to take advantage of SSRS 2008's enhanced reporting options (particularly maps). I guess I can connect to a 2005 sql database using a 2008 reporting tool though - it's just the other way around that would be a problem?

    Thanks! :)

    07 Maret 2012 18:13
  • Hi MrZeroPercent,

    You could upgrade to BIDS 2008 with existing installation of VS2005.
    In addition, BIDS is a component of SQL. BIDS 2008 could use SQL Server 2005.


    Thanks,
    Maggie


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. This can be beneficial to other community members reading the thread.

    • Ditandai sebagai Jawaban oleh MrZeroPercent 11 Maret 2012 15:32
    08 Maret 2012 9:11