none
database is read only

    Pertanyaan

  • My database becomes read only whenever i take the database from from my machine and use it on other machine.......i m using sql server management studio 2008 and using sql express service
    17 Februari 2012 17:27

Jawaban

  • Hi Shailesh Yedge,

    Could you please elaborate a bit on how you move and attach the database?

    To change the database status, you can either execute the following statements or right-click on the database in SQL Server Management Studio, select Properties -> Options and set "Database Read-Only" to False.

    USE [master]
    GO
    ALTER DATABASE [DatabaseName] SET READ_WRITE WITH NO_WAIT
    GO


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Get or Request Code Sample from Microsoft
    If you have any feedback, please tell us.

    • Disarankan sebagai Jawaban oleh skc_chat 25 Februari 2012 10:05
    • Ditandai sebagai Jawaban oleh KJian_ 27 Februari 2012 2:28
    24 Februari 2012 6:45

Semua Balasan

  • Hello,

    Would you please walk us through the steps you are taking to move a copy of the database?

    -Sean

    18 Februari 2012 15:54
  • Hi Shailesh Yedge,

    Could you please elaborate a bit on how you move and attach the database?

    To change the database status, you can either execute the following statements or right-click on the database in SQL Server Management Studio, select Properties -> Options and set "Database Read-Only" to False.

    USE [master]
    GO
    ALTER DATABASE [DatabaseName] SET READ_WRITE WITH NO_WAIT
    GO


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Get or Request Code Sample from Microsoft
    If you have any feedback, please tell us.

    • Disarankan sebagai Jawaban oleh skc_chat 25 Februari 2012 10:05
    • Ditandai sebagai Jawaban oleh KJian_ 27 Februari 2012 2:28
    24 Februari 2012 6:45
  • Moving a database between machines can also 'disconnect' your permissions.  While a SQL Username can appear identical the id's in the background no longer match, meaning you have to grant access for that user again to the database. 

    Best Wishes, The Redman; If something helps, please help show it by voting, if it solves, bonus!

    26 Februari 2012 23:02