none
AdventureWorks2008 Database Sample

    שאלה

  • I have the same issue as has been discussed regarding the installation of the AdventureWorks2008 database.I am working through the self-study kit for certification in SQL 2008 BIDS (70-448). My problem is that I can install the AdventureWorksdw2008 database but the only other database that is available is AdventureWorks, not AdventureWorks2008. I presume there is a difference between AdventureWorks and AdventureWorks2008. I tried the exercises in the book with AdventureWorks but it does not work.

    I read some of the other comments posted. Since I have already installed the sample SQL 2008 database, I tried to reinstall it to make sure the Full-Text Search is checked. When I get to the page that shows the installation options I can see that Full-Text-Search is already checked. If I try to proceed through the screen I get an error saying that I need to choose the options, but they are grayed out and I can't check any of them. Do I need to uninstall the SQL 2008 database and then re-install from scratch?

    I did install a second instance of SQL 2008 and I made sure that Full-Text Search was checked. If I install the sample databases using the second instance, I still see no AdventureWorks2008 on the list of databases.

    Thanks,

    Carlos_En

    PS - OK, I got it figured out. There is a bug in Vista that shows the Full-Text-Search checkbox checked even though Full-Text-Search is not enabled. There is a solution found at-

    http://msftdbprodsamples.codeplex.com/wikipage?title=Database%20Installer%20Help

    Here are the steps.

    To confirm that filestream is actually enabled as a running value (instead of a configured value), you can run this query:

    SELECT SERVERPROPERTY ('FilestreamConfiguredLevel'),SERVERPROPERTY ('FilestreamEffectiveLevel');


    If the values return are 0, filestream is not enabled.

    Here's how to fix this.

    1. Log on to the machine with an administrator account.
    2. Run SQL Server Configuration Manager as administrator. (Right-click Configuration Manager and select Run as administrator).
    3. From Configuration Manager, right-click the SQLServer(SQLExpress) instance (or the name of your Express instance if you didn't use the default name) and selected Properties.
    4. Click the Filestream tab and check the box for Enable Filestream For Transact-SQL access. You can check or skip the other check boxes, they're not required.
    5. Run SQL Server Management Studio as administrator (Right-click SQL Server Management Studio and select Run as administrator).
    6. Click New Query and in the query editor run the following code:

    EXEC sp_configure filestream_access_level, 1

    RECONFIGURE

    It will prompt you to run RECONFIGURE again. Select the RECONFIGURE statement and click Execute.
    Run the SELECT SERVERPROPTY statement again. It should return the value 1 in both columns.

     

    I FEEL A LOT BETTER NOW!



    • נערך על-ידי CARLOS_EN יום שני 30 ינואר 2012 10:20
    יום שני 30 ינואר 2012 03:31

תשובות

כל התגובות