none
SQL Server 2008 R2 PowerPivot Rules Check Failure

    Question

  • Does anyone know why I am getting this Installation Rule Check Failures?  I checked the server and it does not have .NET Framework 4.0 installated.  It has .NET Framework 3.5 SP1 installed.

     

    Issue 1:

    ASSPISharePointPlatformSupportedCheck Checks whether SharePoint supports current .Net Framework version. Failed SharePoint configuration does not support .Net Framework 4.0. To ensure that SQL Server Setup uses .Net Framework 3.5, go to Control Panel, select Programs and Features, select Microsoft SQL Server 2008 R2 Setup, and click Repair. Re-run Setup to install PowerPivot for SharePoint.

     

     

    vendredi 8 avril 2011 15:46

Toutes les réponses

  •  

     

    Hello Steve,

    Can you post the details.txt (the setup log) of when this happend? This rule checkes what version of .Net is SharePoint running on. SharePoint 2010 does not support .Net 4, and so we don't either. Is SharePoint already installed in this server? You cannot install PowerPivot if SharePoint is not already present in the box...

     

    Thanks,

    Mariano


    Mariano Teixeira Neto Analysis Services SQL Server BI Microsoft Corp.
    vendredi 8 avril 2011 22:20
  • Mariano,

    Thank you for getting back to me.  I have not installed SharePoint 2010 yet on my SQL Server.  I will try that first.

    Thank you

    Stephen

    vendredi 8 avril 2011 23:05
  • Hi, steve, I have the same problem, Were you able to solve it?

    Thanks.

    lundi 23 janvier 2012 23:09
  • Hi

    I resolve this problem Installing the Sharepoint 2010 in the Sql Server.

    Regards

    Ademri

    mercredi 10 avril 2013 21:34