none
Deploying new db to remote server without loss of data?

    Pregunta

  • Hello all...

    I'm (needless to say) wet behind the ears so I hope you'll be patient with me.  I'm working on a project in which I had to make a small change to the datatype in one table.  I made the change locally without too much fuss and now I need to deploy the changed db to the remote host.  When I deployed the original I did it by means of uploading a backup to the server and then restoring it as trying to script it turned into a horror show for reasons I believe were related to the host.  The change only affects a table in which there is presently no data, but I'd like to not overwrite the small amount of beta testing data in other tables...  hopefully I'm expressing myself correctly.

    Sooooooooooo... my question of course is... how do I do?

    Thanks in advance for any help!

    martes, 06 de marzo de 2012 19:11

Respuestas

  • Since the table has no data in it, it sounds like scripting the column datatype change is the easiest/best approach. So backup the target database first and then run the column datatype change script. If you are having difficulties with the script please provide the before/after column schema and your script and we can help further.

    Thanks


    /Neil Moorthy - Senior SQL Server DBA/Developer (MCITP (2005/2008), MCAD, ITILv3, OCA 11g) Please click the Mark as Answer button if a post solves your problem

    • Marcado como respuesta PaulBinCT miércoles, 07 de marzo de 2012 1:25
    miércoles, 07 de marzo de 2012 1:13

Todas las respuestas

  • Since the table has no data in it, it sounds like scripting the column datatype change is the easiest/best approach. So backup the target database first and then run the column datatype change script. If you are having difficulties with the script please provide the before/after column schema and your script and we can help further.

    Thanks


    /Neil Moorthy - Senior SQL Server DBA/Developer (MCITP (2005/2008), MCAD, ITILv3, OCA 11g) Please click the Mark as Answer button if a post solves your problem

    • Marcado como respuesta PaulBinCT miércoles, 07 de marzo de 2012 1:25
    miércoles, 07 de marzo de 2012 1:13
  • Thank you very much for that Neil... I'll read up on it so I'm prepared to give it a shot.  I tried to do the original db from a script as part of Web Deploy and it just didn't work.  It would throw an error regarding an author column already existing, which I theorized was part of the host's existing schema somewhere so I gave up on the script route.  But I'll do some homework and report back...

    Thank you!


    • Editado PaulBinCT miércoles, 07 de marzo de 2012 1:23
    miércoles, 07 de marzo de 2012 1:22