none
Cannot connect to Sql Server on another machine

    Question

  • We managed to get Sql Server installed on a VM (not really sure what we did differently so it worked - but it's installed).

    So of course - we can't acces it from a remote machine. I have Sql Server Configuration Manager up and the Client Protocols Shared Memory, TCP/IP, and Named Pipes are all enabled. Local access is fine. But remote - doesn't see it.

    What else do we need to do?

    thanks - dave
    Windward Reports - World's Greatest SharePoint Reporting & DocGen
    Tuesday, December 29, 2009 10:21 PM

All replies

  • Got it - had to turn off the Windows firewall. Anyone know what to set in the firewall to allow connections to Sql Server? If not, it's a test VM for this only so we can just leave it open.

    thanks - dave
    Windward Reports - World's Greatest SharePoint Reporting & DocGen
    Tuesday, December 29, 2009 10:24 PM
  • Hello,

    The following article will guide you to configure the Windows Firewall to allow access to SQL Server.

    http://msdn.microsoft.com/en-us/library/ms175043.aspx

    Hope this helps.

    Regards,

    Alberto Morillo
    SQLCoffee.com

    Wednesday, December 30, 2009 1:21 AM
  • Hello David,

    1. In Control Panel, open Network Connections , right-click the active connection, and then click Properties .

    2. Click the Advanced tab, and then click Windows Firewall Settings .

    3. In the Windows Firewall dialog box, click the Exceptions tab, and then click Add Port .

    4. In the Add a Port dialog box, in the Name text box, type SQL Server < instance name > .

    5. In the Port number text box, type the port number of the instance of the Database Engine, such as 1433 for the default instance.

    6. Verify that TCP is selected, and then click OK .

    7. To open the port to expose the SQL Server Browser service, click Add Port , type SQL Server Browser in the Name text box, type 1434 in the Port Number text box, select UDP , and then click OK .

    8. Close the Windows Firewall and the Properties dialog boxes.

    Thanks

    Regards,
    RM Thirunavukkarasu MCP, MCITP

    Wednesday, December 30, 2009 2:33 PM
  • Tried this but I am on Windows 2008 and so the UI is a lot different from what is shown there. I created a new rule to allow it both by ports and the application - but it still fails when I have the firewall on.

    Is there instructions anywhere on how to do this on Windows 2008?

    thanks - dave
    Windward Reports - World's Greatest SharePoint Reporting & DocGen
    Wednesday, December 30, 2009 5:29 PM
  • Hello,

    The following article explains how to open Windows Firewall ports for SQL Server on Windows Server 2008:

    http://support.microsoft.com/default.aspx/kb/968872

    Hope this helps.

    Regards,

    Alberto Morillo
    SQLCoffee.com

    Wednesday, December 30, 2009 6:49 PM
  • Hello,

    The following article explains how to open Windows Firewall ports for SQL Server on Windows Server 2008:

    http://support.microsoft.com/default.aspx/kb/968872

    Yep, tried that - didn't work. We're just turning the firewall off on that server - it's internal and for testing only so no big deal.

    thanks - dave

    ps - What was weird is we told the firewall to notify us of any app being blocked and got no messages.

    Windward Reports - World's Greatest SharePoint Reporting & DocGen
    Wednesday, December 30, 2009 7:21 PM