none
Report Manager could not detect .NET Framework 3.5

    Question

  • Hi.

    I am running VS2008 enterprise evalution version on XP SP3 with reporting and analysis services running fine.

    The problem I am facing is when I click the Report Builder Option from Report Manage . I get the error message stating "To use the report builder you must install .NET framework 3.5"

    I have .NET framework 3.5 installed on my system and running as implied from the below test

    This machine has the correct version of the .NET Framework 3.5.

    This machine's userAgent string is: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; SIMBAR={9A33F5AB-FB0B-4036-9CED-E5E16D795253}; Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1) ; .NET CLR 1.1.4322; .NET CLR 2.0.50727; InfoPath.2; OfficeLiveConnector.1.4; OfficeLivePatch.1.3; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022).

    Please let me know what I am missing.

    Also, I am running IE 8.0.6001

    thanks
    vineet
    Tuesday, July 07, 2009 2:28 PM

Answers

  • If you install SSRS 2008 R2 with #IE9, make sure to set Compatibility View of #IE9. Coz, #IE9 does NOT detect the installed .NET Framework 3.5.


    Chandana N. Athauda - MVP
    http://www.yeschandana.com
    Friday, September 17, 2010 1:56 PM

All replies

  • SQL 2008 is released with .NET framework 3.5 SP1. Could you have a try after 3.5 SP1 is patched? Or perhaps you have .NET 3.5 SP1 installed, but register value is broken.
    Tuesday, July 07, 2009 2:45 PM
  • Hi qxg--

    Windows last night automatically detected the avaiable update as .NET 3.5 SP1 and patched it. It is not working even after the SP1. How could I check whether register value is broken? I suspect this to be the case.

    Thanks.

    Tuesday, July 07, 2009 3:41 PM
  • Check this

    The .NET Framework 3.5 installer writes registry keys when installation has finished successfully. You can test whether.NET Framework 3.5 is installed by checking the registry keys listed in the following table.

    Registry key name

    Value

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.5

    Name: Install

    Type: DWORD

    Data: 1

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\User Agent\Post Platform

    Name: Version

    Type: REG_SZ

    Data:  .NET CLR 3.5.build number




    http://msdn.microsoft.com/en-us/library/cc160716.aspx

    ~~ Mark it as Answer if you find it correct~~
    Tuesday, July 07, 2009 10:56 PM
  • I have the very same problem. I just did a repair installation of SQL Server 2008, and a repair installation of the .Net Framework 3.5. This error did not go away (using IE 7).
    Interestingly enough, I can start the report Builder from Firefox (!). I looked at the

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\User Agent\Post Platform

    registry key as suggested earlier, but could not figure out how this post would apply. There are currently 3 values at this key, one for each version of .Net. There is no value called "Version".

    Any suggestions?

    Monday, August 24, 2009 4:06 PM
  • I was having same problem

    I just uninstalled .Net Compact Framework 3.5 with SP1 installed on my system and re-installed from MS site.

    http://www.microsoft.com/downloads/details.aspx?FamilyId=333325FD-AE52-4E35-B531-508D977D32A6&displaylang=en
    http://www.microsoft.com/downloads/details.aspx?FamilyID=AB99342F-5D1A-413D-8319-81DA479AB0D7&displaylang=en

    It works!!!

    Try it, hope it works in your case also.
    MSDeveloper
    Monday, October 05, 2009 9:20 AM
  • If you install SSRS 2008 R2 with #IE9, make sure to set Compatibility View of #IE9. Coz, #IE9 does NOT detect the installed .NET Framework 3.5.


    Chandana N. Athauda - MVP
    http://www.yeschandana.com
    Friday, September 17, 2010 1:56 PM
  • That worked for me, thanks a lot, I tried to mark your reply as answers, but the "Propose As Answer" doesn't show up.
    Tareq Ali ITWorx Arabia Technical Consultant
    Sunday, November 07, 2010 10:47 AM
  • Thanks for posting this. Much obliged. FYI, you can bring up the developer tools using F12 to bring up the compatibility mode change menu. 
    Sunday, March 13, 2011 2:07 AM
  • THANK YOU, THANK YOU, THANK YOU!  I had no idea IE9 was the culprit.  I was about to blast the whole computer and start over.

    Wednesday, June 08, 2011 7:23 PM
  • I am not sure whether this is related or not, but your question has indirectly solved a similar problem so I post what I found in case it helps someone else.

    I had the same problem when clicking on the Report Builder button in Report Manager on a Windows 7 PC with SQL 2008 R2 Enterprise installed. This had previously worked but when I went to demonstrate it I found it was broken with the same error message.

    THE CAUSE: Internet Explorer 9!!!!! I had recently installed it.

    The FIX: run the page in compatibility mode--fixed!


    Monday, June 27, 2011 5:01 AM
  • Thank you. You saved me a few hours. I was about to do all sorts of re-installs.

     

    Thanks,

    Vamsi.

    Thursday, July 07, 2011 3:57 AM
  • Still got issues... even when running IE9 in compatibility mode, no joy.  

    Just to confirm I have .NET 3.5 installed. The interesting thing is that the standalone installation of Report Builder 3.0 works fine.  But if I try to invoke it through the browser reporting services site I get the dreaded .NET 3.5 SP1 not installed message.

    Any ideas what else I need to check or do?

     

    Thanks in advance.


    Mo
    Monday, July 18, 2011 12:06 PM
  • I got it working by going to Control Panel | Programs | Features.  I turned off .Net 3.5 and turned it back on. IE 9 now works with Report Builder 3 in compatibility mode.
    Thursday, November 03, 2011 1:54 PM
  • Hi,

    Here is a blog post that explains how to solve this problem with screen-shots.

    http://www.soheib.com/technical-knowledge/error-report-manager-to-use-report-builder-you-must-install-net-framework-3-5-on-this-computer/

    Thanks

    Soheib

    Friday, June 01, 2012 9:14 AM
  • If you install SSRS 2008 R2 with #IE9, make sure to set Compatibility View of #IE9. Coz, #IE9 does NOT detect the installed .NET Framework 3.5.


    Chandana N. Athauda - MVP
    http://www.yeschandana.com
    Thanks Chandana!!!

    Martin Drenth | MCP www.flores.nl

    Tuesday, July 17, 2012 8:35 AM
  • This worked - in IE9 menu .... Tools .... compatibility view settings .... clicked add to add my company domain to the list (which was what was auto filled into the text box) and then the error went away. Thank you Chandana
    • Proposed as answer by wheresjeannine Tuesday, September 17, 2013 8:33 PM
    Tuesday, September 17, 2013 8:32 PM