none
Cant find and delete Analysis Services database in sql server management studio

    Question

  • Hi all
    I'm new to analysis services and have a problem that should be simple to solve (but not for me).

    I create and deploy a analysis services database from vs2008 to a local instance of sql server 2008. I can connect and browse the cube from vs2008 and from other external olap browsers.

    Now I want to delete the analysis services database from the sql server but the database (and other analysis service databases) is not visible in sql server management studio. Other database like adventureworksdw2008 is visible.

    Any suggestions on how I can find and delete the analysis services database?

    Sincerely
    Ole Dan Jørgensen

    Sunday, May 17, 2009 10:18 AM

Answers

  • First in Registered Servers, Click on the GOLD CUBE, and register the server (instance).

    Then in Object Explorer click on Connect select the GOLD CUBE again, and enter the necessary info on the Connect to Server panel (usually default).

    At that point you should be seeing all the AS databases and the Cubes withing the DB-s. 
    Kalman Toth, SQL Server 2008 Training, SSAS, SSIS, SSRS, BI: www.SQLUSA.com
    • Marked as answer by ole dan Monday, May 18, 2009 8:21 AM
    Monday, May 18, 2009 1:15 AM
  • Thanks Kalman

    Based on your answer I believe that my installation must be corupt. I still dont see no gold cube in registered servers. A repair of the installation did not help (repair ends in failure). I guess the long installation history of various editions of sql server is to must of a challenge.

    I did a fresh install of SQL Server 2008 Enterprise trial on another computer and here I see the Golden Cube along with the symbols for database engine, integration services and reporting services. So now I understand what you are talking about.

    For now I will continue to work with the new installation.

    Thanks again for your time

    Ole

    • Marked as answer by ole dan Monday, May 18, 2009 8:21 AM
    Monday, May 18, 2009 8:21 AM

All replies

  • You may just have to refresh the DB list in Object Explorer (connect to SSAS first).
    Kalman Toth, SQL Server 2008 Training, SSAS, SSIS, SSRS, BI: www.SQLUSA.com
    Sunday, May 17, 2009 11:05 AM
  • From the sounds of it you are simply connecting to the Database Engine and not Analysis Services.  Connect to Analysis Services through Management Studio first and then you should see all of the databases as long as you have the necessary permissions.  If you check the deployment options in the project properties of your SSAS project in BIDS the default name would have been something along the lines of 'Adventure Works DW 2008 ...' and then it would depend on if you deployed the standard or enterprise edition version.  The data source for this project references the AdventureWorkdsDW2008 database that you are mentioning, but that is not the SSAS database.


    Dan English's BI Blog
    _____________________________________________________
    Please mark posts as answer or helpful when they are.
    Sunday, May 17, 2009 12:59 PM
  • Hello Ole,

    I think you are connecting to Database Engine but you will not get Analysis Databases there.
    Connect to Analysis Services and if you are having rights of analysis database which you want to delete
    then you will be able to delete.

    Ani
    Sunday, May 17, 2009 4:06 PM
  • Thank you Ani, Dan and Kalman

    I realize now that I have connected to the database engine and not to Analysis Services. But I can not find any signs of Analysis Services in management studio!

    I am doing the following:

    1. I open SQL Server Management Studio.

    2. On the File menu, I click Connect Object Explorer.

    3. In the Connect to Server dialog box I look for the Analysis Services server type but only find Database Engine and SQL Server Compact Edition. No Analysis Services in the drop down.

    And i'm sure that analysis services is installed and running since I can connect to and browse the two databases I have deployed to analysis services.

    Any suggestions?

    Sincerely

    Ole

    Sunday, May 17, 2009 9:03 PM
  • First in Registered Servers, Click on the GOLD CUBE, and register the server (instance).

    Then in Object Explorer click on Connect select the GOLD CUBE again, and enter the necessary info on the Connect to Server panel (usually default).

    At that point you should be seeing all the AS databases and the Cubes withing the DB-s. 
    Kalman Toth, SQL Server 2008 Training, SSAS, SSIS, SSRS, BI: www.SQLUSA.com
    • Marked as answer by ole dan Monday, May 18, 2009 8:21 AM
    Monday, May 18, 2009 1:15 AM
  • Thanks Kalman

    Based on your answer I believe that my installation must be corupt. I still dont see no gold cube in registered servers. A repair of the installation did not help (repair ends in failure). I guess the long installation history of various editions of sql server is to must of a challenge.

    I did a fresh install of SQL Server 2008 Enterprise trial on another computer and here I see the Golden Cube along with the symbols for database engine, integration services and reporting services. So now I understand what you are talking about.

    For now I will continue to work with the new installation.

    Thanks again for your time

    Ole

    • Marked as answer by ole dan Monday, May 18, 2009 8:21 AM
    Monday, May 18, 2009 8:21 AM
  • Hi,

    Did you find an answer for this. I am getting the same issue that I cannot see Analysis Services in the drop down list to connect to. I am using SQL Server 2008 SP2.

    Thanks for your help

    Hamid
    Thursday, March 18, 2010 4:50 PM
  • Hi,

    I was able to fix it. Turns out that i did not have the feature installed on my machine. When you install SQL Server 2008, you have option for "Management Tools Basic" and "Management Tools Complete". I had Management Tools Basic installed on mine. Installed Management Tools Complete and I was able to see all options.

    Friday, March 19, 2010 11:07 AM