none
SQL SERVER database DIAGRAMS problem...

    Question

  • Hi all,
     i m trying to create database diagram but as soon as i click on DATABASE diagrams it gives me the following error:
    TITLE: Microsoft SQL Server Management Studio
    ------------------------------

    Database diagram support objects cannot be installed because this database does not have a valid owner.  To continue, first use the Files page of the Database Properties dialog box or the ALTER AUTHORIZATION statement to set the database owner to a valid login, then add the database diagram support objects.

    ------------------------------
    BUTTONS:

    OK
    ------------------------------

    what should i do??since i m new to sql server....so,i cant understand what exactly i have to do?can someone explain me in simple words....
    thnks in advance.

    Friday, October 14, 2005 3:10 PM

Answers

  • I just spent 3 hours farting around with Permissions and all sorts of other options in SQL Server 2005. (oodles of fun... looks like all these damn settings and whatnot are gonna be just as convoluted as they were in 2000... oh well... makes life interesting ;-))

    I finally, I think, figured out what the problem is.

    In SQL Server Management Studio do the following:

    1. Right Click on your database, choose properties
    2. Goto the Options Page
    3. In the Dropdown at right labeled "Compatibility Level" choose "SQL Server 2005(90)"
    4. Goto the Files Page
    5. Enter "sa" in the owner textbox.
    6. Hit OK

    after doing this, I am now able to access the Database Diagrams.

    It would be nice to know the reasons behind the error (or maybe even a more descriptive error message.....)

    but this seems to have done the trick for me. Your mileage may vary

    -Max Schilling
    Monday, October 31, 2005 6:36 AM

All replies

  • I just spent 3 hours farting around with Permissions and all sorts of other options in SQL Server 2005. (oodles of fun... looks like all these damn settings and whatnot are gonna be just as convoluted as they were in 2000... oh well... makes life interesting ;-))

    I finally, I think, figured out what the problem is.

    In SQL Server Management Studio do the following:

    1. Right Click on your database, choose properties
    2. Goto the Options Page
    3. In the Dropdown at right labeled "Compatibility Level" choose "SQL Server 2005(90)"
    4. Goto the Files Page
    5. Enter "sa" in the owner textbox.
    6. Hit OK

    after doing this, I am now able to access the Database Diagrams.

    It would be nice to know the reasons behind the error (or maybe even a more descriptive error message.....)

    but this seems to have done the trick for me. Your mileage may vary

    -Max Schilling
    Monday, October 31, 2005 6:36 AM
  • WOWWWWWWWWWWWWW.....It really worked...i cant believe this.....compatibility level was already the same....but just by writtin sa...it solved my problem...
    Thanks a ton....
    Regards,
    Shuch..
    Monday, October 31, 2005 8:09 AM
  • Excellent!  Beer's on Me!  Big Smile
    Tuesday, November 15, 2005 6:19 PM
  • Schilmon ----- you are the best, was driving me crazy ok yeah so your message was posted ages ago but still your the best
    Tuesday, November 22, 2005 12:17 AM
  •  Schilm wrote:
    I just spent 3 hours farting around with Permissions and all sorts of other options in SQL Server 2005. (oodles of fun... looks like all these damn settings and whatnot are gonna be just as convoluted as they were in 2000... oh well... makes life interesting ;-))

    I finally, I think, figured out what the problem is.

    In SQL Server Management Studio do the following:

    1. Right Click on your database, choose properties
    2. Goto the Options Page
    3. In the Dropdown at right labeled "Compatibility Level" choose "SQL Server 2005(90)"
    4. Goto the Files Page
    5. Enter "sa" in the owner textbox.
    6. Hit OK

    after doing this, I am now able to access the Database Diagrams.

    It would be nice to know the reasons behind the error (or maybe even a more descriptive error message.....)

    but this seems to have done the trick for me. Your mileage may vary

    -Max Schilling
    Tuesday, November 22, 2005 10:24 PM
  • Hi Max, am George, i have been trying to use database diagrams with sql server 2005 standar edition i have visual studio .net 2005 standar edition too, i have read your post but i dont have the option in the Dropdown from the Compatibily level from the option page the label with the option "SQL Server 2005(90)", it only appears "SQl Server 2000" and "SQL Server 7.0"....please help, what can i do!....


    thx for your time. 

    Wednesday, December 07, 2005 5:36 AM
  • This was the same for me until I installed the 2005 Server components.  My first run through installing SQL Sever 2005 I only installed the client tools and the Integration Services.

    Make sure you have the Server components installed which will upgrade your SQL Server 2000 services to 2005.
    Tuesday, December 13, 2005 4:10 PM
  • Thanks men!!!
    Friday, November 25, 2011 4:42 AM