none
Another Max Request Length Exceeded error - SSRS 2008

    Question

  • Hi All,

    I am currently not able to deploy large reports to the the report server, with the error  "Error 2 There was an exception running the extensions specified in the config file. ---> Maximum request length exceeded."

    I have searched online, and found that the machine.config & web.config files need some code changes to allow larger files.

    I have inserted the following code where necessary:

    <httpRuntime executionTimeout="9000" maxRequestLength="40960"/>

    There was a couple of different versions of both files on the server, the changes were made to all files. I've also restarted IIS, reporting services, and the whole server. I'm still facing the same problem, and am running short on time to find an answer.

    Can anyone suggest anything else to check?

    Best regards,

    Tuesday, April 13, 2010 2:28 PM

Answers

  • Where exactly have you changed the settings?
    The .net framework web.config has to changed to allow large files. In your case it is the 64 bit version.

    The folder for SQL 2005 is c:\WINDOWS\microsoft.net\Framework64\v2.0.50727\CONFIG. I don't think it is different for SQL 2008.

    • Marked as answer by Humate Tuesday, April 13, 2010 3:49 PM
    • Marked as answer by Humate Tuesday, April 13, 2010 3:50 PM
    Tuesday, April 13, 2010 3:09 PM

All replies

  • What is the size of your report file? 40 MB?
    Tuesday, April 13, 2010 2:40 PM
  • size of the report is 13MB.  I'm running Windows server 2003 with IIS 6 on a 64 bit machine
    Tuesday, April 13, 2010 2:57 PM
  • Where exactly have you changed the settings?
    The .net framework web.config has to changed to allow large files. In your case it is the 64 bit version.

    The folder for SQL 2005 is c:\WINDOWS\microsoft.net\Framework64\v2.0.50727\CONFIG. I don't think it is different for SQL 2008.

    • Marked as answer by Humate Tuesday, April 13, 2010 3:49 PM
    • Marked as answer by Humate Tuesday, April 13, 2010 3:50 PM
    Tuesday, April 13, 2010 3:09 PM
  • Found yet another version of the file through the search! Amended again and now all is well. thanks!
    Tuesday, April 13, 2010 3:52 PM
  • Since SSRS 2008 doesnt use IIS, Set the maxRequestLength attribute to desired value in the web.config file in the "Report Server" Directory.
    DM
    Thursday, February 17, 2011 9:16 AM