none
2012 Dev installation passes .NET framework check then fails because .NET Framework doesn't exist.

    Question

  • On a newly imaged Win & enterprise x64 with SP1 machine I am trying to install SQL 2012 Developer. The prerequisite check works fine and it sees that I have 3.5.1 installed as well as 4.5 but during installation I get failures like

    "CLR Types requires the .NET Framework version 2.0 or 3.0 or 3.5 or 4.0. Ensure this requirement is fulfilled before installing Micorsoft SQL Sever System CLR types"

    I've done this a half dozen times and downloaded a new ISO with no joy.

    What logs should I dig into? When I look at detail.txt I get information overload.

    Thanks

    Thursday, February 14, 2013 8:27 PM

Answers

All replies

  • Hello,

    Please repair .NET Framework using the resolution steps on the following post:

    http://blogs.msdn.com/b/sqlserverfaq/archive/2010/04/30/unable-to-install-service-pack-1-for-sql-server-2008.aspx

    Hope this helps.

    Regards,

    Alberto Morillo
    SQLCoffee.com

    Friday, February 15, 2013 2:56 AM
  • Hi

    You need to Repair the .NET Framework from Add Remove Program >Highlight .Net Framework 3.5 Sp1 >Select Change >Repair .

    Now run the setup.



    Please help and appreciate others by using these features: "Propose As Answer", "Vote As Helpful" and "Mark As Answer"

    Waqas

    MS(SPM), MS(E&F),M.Engg, MCP, MCT, MCTS, MCITP, MCSE, MCPD, MCSD, MCDBA , Author
    Twitter: @Waqas_m1
    Linked In: http://www.linkedin.com/in/waqasm1

    • Proposed as answer by Waqas M Wednesday, February 20, 2013 12:10 PM
    Friday, February 15, 2013 6:17 AM
  • Hello all,

    1. The issue could be because of corrupt .Net.

    <> Repair .NET 3.5 SP1, Reboot the box and run the setup again.

    2. It could be because of an error in Windows installer 4.5 engine: http://support.microsoft.com/kb/958655

    To check the version of windows installer:  

    C:\Windows\System32\msiexec.exe

    <> If the file version is below than 4.5.6001.22303 then apply the following hotfix for Windows Installer : http://support.microsoft.com/kb/958655

    Hope this helps

    Don 

     

    Friday, February 15, 2013 10:42 AM
  • This was not due to a corrupt .NET installation. It was a fresh install and I ran the NETFX setup verifier.

    I did a couple of things and I'm not sure which one solved the problem. I copied the installation media to the hard drive and then edited the setup.exe.config and changed the values for the following entries to accurately reflect my specific .NET versions. 

     <supportedRuntime version="v2.0.50727"/>
      <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0"/>

    I also installed the shared management Objects from the feature pack here:

    http://www.microsoft.com/en-us/download/details.aspx?id=35580

    Then I installed just SSMS because having that installed was more urgent than getting the entire intallation done. It worked, then I installed everything else.

    • Marked as answer by Labry Monday, February 25, 2013 2:40 PM
    Monday, February 25, 2013 2:39 PM