none
F8 in SSMS 2008 R2 - doesn't open object explorer

    Question

  • I've just installed SS 2008 R2 on my local PC and note the following issues.

    1. When starting SSMS and connecting to a server the object explorer doesn't open that server, I've found I need to connect to the server in there as well.  This didn't happen in SS 2008.
    2.  F8 doesn't open object explorer

    I've seen a few other posts in here about F8, and answers indicate that it does open object explorer.  Do I need to install the latest CU?

    Thanks

    Monday, December 06, 2010 11:47 PM

Answers

  • Hi,

    Thanks for your post!

    SSMS 2008 R2 functions similarly with SSMS 2008. Have you changed any default settings after installation?

    >>1. When starting SSMS and connecting to a server the object explorer doesn't open that server, I've found I need to connect to the server in there as well.  This didn't happen in SS 2008.

    Please make sure that you have select startup option to Open Object Explorer. To change the startup option of SSMS, please open Tools menu and select Options, select Environment node of Option dialog box, choose startup option in the At startup dropdown list.

    >>2.  F8 doesn't open object explorer

    The default shortcut of Object Explorer view window is F8. You can open Tools -> Customize to open Customize dialog box, switch to Command tab, click Rearrange Commands to open Rearrange Commands dialog box, choose Toolbar and select Menubar option, click View under Controls, click Modify Selection and click Reset to reset View menu. For more information, you can refer to Customizing Menus and Shortcut Keys (http://msdn.microsoft.com/en-us/library/ms174178.aspx).

    If it still does not work via above operations, you can try reinstall SSMS or repair SSMS which should be able to fix this issue.

    Hope this helps.

    Thanks,
    Chunsong


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, December 07, 2010 1:58 AM
  • This is something I posted a long time ago. You migt want to try it, in case it still applies.

    http://sqlblog.com/blogs/tibor_karaszi/archive/2008/08/26/missing-f8-or-ctrl-n-in-ssms-2008.aspx


    Tibor Karaszi, SQL Server MVP | web | blog
    • Marked as answer by _JMG_ Tuesday, December 07, 2010 12:04 PM
    Tuesday, December 07, 2010 9:53 AM

All replies

  • Hi,

    Thanks for your post!

    SSMS 2008 R2 functions similarly with SSMS 2008. Have you changed any default settings after installation?

    >>1. When starting SSMS and connecting to a server the object explorer doesn't open that server, I've found I need to connect to the server in there as well.  This didn't happen in SS 2008.

    Please make sure that you have select startup option to Open Object Explorer. To change the startup option of SSMS, please open Tools menu and select Options, select Environment node of Option dialog box, choose startup option in the At startup dropdown list.

    >>2.  F8 doesn't open object explorer

    The default shortcut of Object Explorer view window is F8. You can open Tools -> Customize to open Customize dialog box, switch to Command tab, click Rearrange Commands to open Rearrange Commands dialog box, choose Toolbar and select Menubar option, click View under Controls, click Modify Selection and click Reset to reset View menu. For more information, you can refer to Customizing Menus and Shortcut Keys (http://msdn.microsoft.com/en-us/library/ms174178.aspx).

    If it still does not work via above operations, you can try reinstall SSMS or repair SSMS which should be able to fix this issue.

    Hope this helps.

    Thanks,
    Chunsong


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, December 07, 2010 1:58 AM
  • Thanks for your response Chunsong.

    Your solution to #1 worked, thanks I had forgotten about that setting. 
    I've reset the view menu as per your instructions but F8 still doesn't open the Object Explorer.  When I click on the view menu, next to Object Explorer there is no shortcut key, the F7 shortcut key is still listed next to Object Explorer details.

    If the shortcut has been removed from the SSMS 2008 R2 app then thats fine, I'm just concerned the upgrade to R2 didn't work correctly.  My PC is Win 7 64 bit. 

    Tuesday, December 07, 2010 2:05 AM
  • Hi,

    >>If the shortcut has been removed from the SSMS 2008 R2 app then thats fine, I'm just concerned the upgrade to R2 didn't work correctly.  My PC is Win 7 64 bit. 

    No, the default shortcut of Object Explorer in SSMS 2008 R2 is still F8 as I can see "Object Explorer    F8" menuitem under View menu. I am afraid that you may need to reinstall SSMS 2008 R2 if you want to use F8 shortcut for Object Explorer.

    Thanks,
    Chunsong


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, December 07, 2010 2:16 AM
  • Hi Chunsong,

    I've uninstalled and re-installed everything and STILL F8 isn't a shortcut for Object Explorer.  This is the ISO that I've used for the installation.

    SW_DVD9_SQL_Svr_Developer_Edtn_2008_R2_English_MLF_X16-29684.ISO

     

    Tuesday, December 07, 2010 3:23 AM
  • Ok, I've just installed the developer edition on the development server (same version as I installed on my desktop) and F8 = Object Explorer.

    Must be something weird happening either Win 7 or the installation on my desktop.

    Tuesday, December 07, 2010 3:50 AM
  • Hi,

    The cause I can think of is that some files (such as configuration) are left on the system after uninstall SSMS; and they are not replaced during the reinstall SSMS. You may trying the folowing setps to resove this issue:

    1. Uninstall all client tools by running setup.exe of SQL Server 2008 R2;
    2. Backup folder C:\Program Files (x86)\Microsoft SQL Server\100\Tools in case any error happens;
    3. Delete folder C:\Program Files (x86)\Microsoft SQL Server\100\Tools;
    4. Reinstall all client tools by running setup.exe of SQL Server 2008 R2.

    If the above does not help, you may need to uninstall SQL Server and delete both C:\Program Files (x86)\Microsoft SQL Server and C:\Program Files\Microsoft SQL Server folders and then perform a new reinstall.

    Thanks,
    Chunsong


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, December 07, 2010 4:24 AM
  • I've done both of these suggestions.  After uninstalling the application...

    1. remove the tools folder and re-install
    2. remove the entire SQL Server folders from both program files directories and re-install

    Neither has worked after reinstalling SQL Server, F8 still doesn't open object explorer :\

    Tuesday, December 07, 2010 5:31 AM
  • Hi,

    Thanks for your effort and update!

    It's a bit strange, I think you may open a support case with Microsoft CSS (http://support.microsoft.com) to resolve this issue.

    Thanks,
    Chunsong


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by _JMG_ Tuesday, December 07, 2010 6:28 AM
    • Unmarked as answer by _JMG_ Tuesday, December 07, 2010 12:04 PM
    Tuesday, December 07, 2010 6:13 AM
  • This is something I posted a long time ago. You migt want to try it, in case it still applies.

    http://sqlblog.com/blogs/tibor_karaszi/archive/2008/08/26/missing-f8-or-ctrl-n-in-ssms-2008.aspx


    Tibor Karaszi, SQL Server MVP | web | blog
    • Marked as answer by _JMG_ Tuesday, December 07, 2010 12:04 PM
    Tuesday, December 07, 2010 9:53 AM
  • This is something I posted a long time ago. You migt want to try it, in case it still applies.

    http://sqlblog.com/blogs/tibor_karaszi/archive/2008/08/26/missing-f8-or-ctrl-n-in-ssms-2008.aspx


    Tibor Karaszi, SQL Server MVP | web | blog


    Brilliant!!  Tibor, thank you. 

    This has worked.  Under TOOLS -> OPTIONS, in Environment tree and keyboard I selected SQL Server 2000 as keyboard scheme and the shortcuts are back.

    Thank you very much.

    JMG 

    edit: I note that on the fresh install of SS 2008 R2 Dev on the clean dev win 2008 R2 server it was not necessary to select this option, it is set to Standard, yet the F8 shortcut is enabled..... doesn't matter though, my shortcut is back :) 

    Tuesday, December 07, 2010 12:04 PM
  • Glad it helped, JMG.

    I have a feeling that this happens of you have had SQL Server 2005 tools installed on the machine, at some point in time. Not 100% certain, though.


    Tibor Karaszi, SQL Server MVP | web | blog
    Tuesday, December 07, 2010 2:02 PM
  • Ref: #2: F8 doesn't open Object Explorer

    Same thing happened to me.  I tried doing the Tools / Modify ... Modify Selection / Reset thing and that didn't fix it.  Also, on the drop-down View menu, even though it showed Object Explorer, there was no "F8" next to it (even though the next one down - Object Explorer Details - did have an "F7" next to it.)  After reading other posts in this thread, I reset the Keyboard / Keyboard Scheme to "SQL Server 2000".  That put the "F8" back on the View menu.  I then reset the Keyboard Scheme back to "Standard" and - lo and behold - the "F8" is still next to "Object Explorer" on the View menu.  No need for a re-install!

    Thanks to previous posters for suggestions.

    Colin Shaw.

    • Proposed as answer by Seashore42 Monday, July 09, 2012 5:41 PM
    Monday, July 09, 2012 5:40 PM
  • I had the same issue and the way I was able to fix it was by going to window => floating and it appeared.

    I then went to window => dockable and I was able to re-dock.

    Monday, October 21, 2013 11:16 PM