none
The report server installation is not initialized. (rsReportServerNotActivated) - Windows Sharepoint - SQL server 2008

    Question

  • We have web site uses Windows SharePoint Services 3.0, SQL server 2008 and ASP.NET 2.0

     

    SQL System Configuration (Machine A)

             

              Windows 2008 64 bit

              SQL Server 2008 64 bit

              SSRS 2008

     

    Web Server (Machine b)

              Windows 2008 64 bit

              Windows SharePoint Services 3.0

              IIS

     

    We rebuilt our SQL server machine from scratch due to an unfortunate h/w failure.  We restored all the back up’s into newly built machine.  Web server is connecting to application and SharePoint databases normally and everything is working. 

     

    But we realized later Reports are not working.  Then I have used to Report Services Configuration Manager, configured the following items

     

              Service Account,

    Web Service URL,

    Database (to existing database),

    Report Service Manager URL. 

     

    Restart SSRS, now Report Server Mode in SharePoint Integrated and status is started.

     

    When I browse Report Service Manager URL I am getting the following error.

    Reporting Services Error


    ·         The report server installation is not initialized. (rsReportServerNotActivated) Get Online Help


    SQL Server Reporting Services

     

     

    When I browse report (.rdl) from browser which is working previously now I am receiving the following error

     

     

    The report server installation is not initialized. ---> Microsoft.ReportingServices.Diagnostics.Utilities.ReportServerNotActivatedException: The report server installation is not initialized.   at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
       at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
       at Microsoft.SqlServer.ReportingServices2006.ReportingService2006.GetPermissions(String Item)
       at Microsoft.SqlServer.ReportingServices2006.RSConnection2006.GetPermissions(String Item)
       at Microsoft.ReportingServices.SharePoint.UI.ItemPermissions.GetPermissionFromServer()
       at Microsoft.ReportingServices.SharePoint.UI.ItemPermissions.GetPermissions(String itemPath)
       at Microsoft.ReportingServices.SharePoint.UI.RSViewerPage.OnInit(EventArgs e)
       at System.Web.UI.Control.InitRecursive(Control namingContainer)
       at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

     

     

                       

    I tried rskeymgmt with the following command  but no luck,

     

    rskeymgmt -e -f C:\my.txt -p password01!

     

    It is also throwing same error

              The report server installation is not initialized. (rsReportServerNotActivated)

     

    On the EventViewer i have the following error logs,

     

    Report Server (MSSQLSERVER) cannot connect to the report server database.

    Report Server (MSSQLSERVER) has not been granted access to the catalog content.

     

     

     

    Using ReportServer database, I Queried at the Catalog and Datasource tables they have one and zero row(s) respectively.  But it should have few rows my (assumption)

     

    Please let me know any resolution or suggestion for this issue?

     

    Tuesday, January 12, 2010 5:30 PM

Answers

  • Hi,

    From the error message you have posted, I am sure the issue is caused by the account used to connect catalog database does not have permissions to access the catalog content.

    Report Server (MSSQLSERVER) cannot connect to the report server database.
    Report Server (MSSQLSERVER) has not been granted access to the catalog content.



    Please follow these steps to reset the connection:
    1.Open Reporting Services Configuration Manager.
    2.Go to "Encryption Keys" to backup the key.
    3.Go to "Database" tab.
    4.Click "Change Credentials" to reset the connections.

    If you have any more questions, please feel free to ask.

    Thanks,
    Jin Chen


    Jin Chen - MSFT
    Thursday, January 14, 2010 9:05 AM
  • This article may help you
    http://prologika.com/CS/blogs/blog/archive/2006/07/18/Swapping-the-RS-Catalog.aspx

    ~~ Mark it as Answer if you find it correct~~
    Tuesday, January 12, 2010 6:52 PM

All replies

  • This article may help you
    http://prologika.com/CS/blogs/blog/archive/2006/07/18/Swapping-the-RS-Catalog.aspx

    ~~ Mark it as Answer if you find it correct~~
    Tuesday, January 12, 2010 6:52 PM
  • Hi,

    From the error message you have posted, I am sure the issue is caused by the account used to connect catalog database does not have permissions to access the catalog content.

    Report Server (MSSQLSERVER) cannot connect to the report server database.
    Report Server (MSSQLSERVER) has not been granted access to the catalog content.



    Please follow these steps to reset the connection:
    1.Open Reporting Services Configuration Manager.
    2.Go to "Encryption Keys" to backup the key.
    3.Go to "Database" tab.
    4.Click "Change Credentials" to reset the connections.

    If you have any more questions, please feel free to ask.

    Thanks,
    Jin Chen


    Jin Chen - MSFT
    Thursday, January 14, 2010 9:05 AM
  • Thanks Sandeep and Jin!

    As a final option (because I am exhausted for last two days) I have chosen to create a new database instead of using existing database.  Now I don’t see activation error and then I spent few more hours reconfiguring the existing data source and report definition files.  Now all the reports are back once.

     

    I can also see catelog table and datasource table in the new database filled with rows of data unlike my old database? 

     

    I took backup of key from encryption tab to avoid same situation.



    Jin,

    I dont think Backup button enabled for my case, i dont why ? May be you could shed some light on this.
    Thursday, January 14, 2010 2:47 PM
  • I have developed crystal report but its not working on web server 1and 1 ...so i have used Microsoft report viewer so..now it is also not working....please tell me what to do now?giving same problem what i was facing for crystal report
    Thursday, May 26, 2011 10:22 AM