none
Tablix headers not repeating in SSRS 2008

    Question

  • I have created a new report & add a table to it. When I select "Tablix Properties" and check on Columns Headers -> "Repeat Cheader columns on each page" the header columns do not repeat on each page. I also tried "Repeat header rows on each page". "Add page break before" seems to work ok. I am using VS 2008 9.0.30729.1 SP

    I also tried deploying but it still does not work on the deployed version.

     

    Interestingly, reports migrated from 2005 & unchanged seem to be ok.

     

    Any ideas? Am I not setting soemthign up properly?

     

    Monday, November 03, 2008 2:07 AM

Answers

  • 1.    In the grouping pane, make sure to turn on advanced mode (click on the small black down arrow on the far right of the grouping pane)  

    2.  Select the corresponding (Static) item in the row group hierarchy

    3.  In the properties grid, set RepeatOnNewPage to true 
    4. KeepwithGroup to After


    karthik-chennai
    Wednesday, October 21, 2009 4:01 PM
  • Hi, Dexter,

     

    The issue stems from the fact that there are elements in the tablix structure in a report definition that do not have a corresponding visual representation on the design surface. When you delete the column that was automatically added when you defined a row group, you are deleting the part of the tablix definition in the report that controls the rows that are associated with the row group, including the row that contains the column headings.

     

    There's a new BOL topic to help you understand how to help control repeating and freezing headers.

    Controlling Row and Column Headings: http://msdn.microsoft.com/en-us/library/cc281227.aspx

     

    HTH,

    Mary

    Tuesday, November 11, 2008 6:05 PM
    Answerer

All replies

  • Found it. It is a Tablix Member property rather than a property of the tablix itself.

    Steps:

    1.       In the grouping pane, make sure to turn on advanced mode (click on the small black down arrow on the far right of the grouping pane)

    2.       Select the corresponding (Static) item in the row group hierarchy

    3.       In the properties grid, set RepeatOnNewPage to true

     

    Monday, November 03, 2008 3:03 AM
  • mmm... Still having some problems. I want to be able to merge the row cells across the report for each of 2 groups in the report. But with the default group setup, this is not allowed. So I tried deleting the colums (without deleting the groups), added new columns with the filds & then merged them right. This works fine, but I lose the

    RepeatOnNewPage. And when I go thru all the static tablix members & add it, it still does not repeat the headings.

    Any advice? Thanks.

    Monday, November 03, 2008 3:11 AM
  • On the data region as a whole, did you go to the tablix properties and set "repeat header rows on each page"?`

     

    -- Robert

     

    Monday, November 03, 2008 5:18 PM
    Owner
  • Hi Robert,

     

    Thanks for the feedback.

     

    Yes I also tried setting this on. What seems to stop the column headers repeating is when I delete the first column on the report, even if I select the "Delete colmns only" option as I delete it. At the moment I am working around it by making this colmn invisible. But if you have any other ideas, I would appreciate hearing them. Thanks.

     

    Monday, November 03, 2008 9:48 PM
  • Hi, Dexter,

     

    The issue stems from the fact that there are elements in the tablix structure in a report definition that do not have a corresponding visual representation on the design surface. When you delete the column that was automatically added when you defined a row group, you are deleting the part of the tablix definition in the report that controls the rows that are associated with the row group, including the row that contains the column headings.

     

    There's a new BOL topic to help you understand how to help control repeating and freezing headers.

    Controlling Row and Column Headings: http://msdn.microsoft.com/en-us/library/cc281227.aspx

     

    HTH,

    Mary

    Tuesday, November 11, 2008 6:05 PM
    Answerer
  • Hi Mary,

     

    Thanks. From this article it seems possible to get the effect I am looking for without having to hide the group cols.  I plan to work thru the steps on my next group report to see if I can avoid having to hide the group cols to get the head. I like the feature which imports the "freeze panes" effect to excel- nice.

     

    regards,

    Dexter

     

    Tuesday, November 11, 2008 9:57 PM
  • Hi Mary,

    I know it's been a while since this post, but I am having the same issue.  I have read the MSDN Article you have referenced.  I would like to do just as the article mentions in Table with row groups and no row group area, however I need to repeat the full row of the current category if there would be a page break and all of the categories' orders did not fit on one page.  In the article, this would be the Category "Accessories" and its Sales Total.

    When I set what the article suggests for the hierarchy item "(static)" below "(Category)" the data does not repeat.  The article does it with the (static) above Category.  This works.  I would like the one below it to repeat too.  I found a blog article that mentioned having to also set FixedData to True to include the group body in the repeat.  When I do that, I get a rsInvalidFixedDataInHierarchy Error.  This is the BLOG article:  http://blogs.msdn.com/robertbruckner/archive/2008/10/13/Repeat-Header-And-Visible-Fixed-Header-Table.aspx which got me to try setting FixedData to True.

    I used to do this type of thing with MSRS 2005 day in and day out.  I'm interested to hear if anybody can do it with MSRS 2008.
    Wednesday, February 25, 2009 9:55 PM
  • The FixedData property has nothing to do with repeating rows on a new page.  You only want to set the RepeatOnNewPage property.  

    Assuming you already installed the latest cumulative update (CU#3 or SP1 CTP - see links here) for RS 2008, and if you still don't have it working, I'd encourage you to create a bug via http://connect.microsoft.com and attach a report that runs preferably on AdventureWorks data, and reproduces the problem you are describing.  We'll then take a look and get back to you via connect.

    HTH,
    Robert
    Robert Bruckner   http://blogs.msdn.com/robertbruckner

    This posting is provided "AS IS" with no warranties, and confers no rights.

    Saturday, February 28, 2009 9:51 PM
    Owner
  • Emmanuel Vigneault (Thursday, May 07, 2009 11:22 PM)  method is working for me.

    Steps:

    1.        In the grouping pane, make sure to turn on advanced mode (click on the small black down arrow on the far right of the grouping pane)

     

    2.        Select the corresponding (Static) item in the row group hierarchy

    3.        In the properties grid, set RepeatOnNewPage to true

    Thanks for the contribution!


    • Proposed as answer by Sharke Tuesday, July 12, 2011 8:05 AM
    Monday, July 13, 2009 3:56 AM
  • 1.    In the grouping pane, make sure to turn on advanced mode (click on the small black down arrow on the far right of the grouping pane)  

    2.  Select the corresponding (Static) item in the row group hierarchy

    3.  In the properties grid, set RepeatOnNewPage to true 
    4. KeepwithGroup to After


    karthik-chennai
    Wednesday, October 21, 2009 4:01 PM
  • Yep, that's it!!
    Thanks mrleokarthik !!
    Thursday, October 29, 2009 10:48 AM
  • Regarding the KeepWithGroup=After setting:  by default Report Builder / BIDS Report Designer would automatically and explicitly set the table header KeepWithGroup property to After when you create a table with the table wizard, or simply create a new table on the design surface.

    I'm curious to hear from mrleokarthik and shiv179 how you got to the situation that the table header's tablix member KeepWithGroup was not automatically set for a table created in Report Builder.  Do you have steps to reproduce this consistently?

    Thanks,
    Robert
    Robert Bruckner   http://blogs.msdn.com/robertbruckner
    This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, October 30, 2009 5:47 PM
    Owner
  • Hi Robert

    My reports were converted from 2005 to 2008.
    All my 2005 reports were always set to repeat the table header while scrolling.
    In 2008, the table header is treated like a normal row.
    Even setting the repeat options in the Tablix properties has no effect.
    After using the tip posted by mrleokarthik, it is working now.

    Hope this helps

    PS:
    I understand and appreciate the SSRS team's efforts to make 2008 more BI friendly, but some of the redesigns are actually quite painful for a developer!!!
    Some tasks are still quicker and easier in 2005!!! (toggling the table header, details and footer is one of them)
    Tuesday, November 03, 2009 6:17 AM
  • Any update, SSRS team?
    Tuesday, January 05, 2010 3:12 PM
  • Hi All,

    fyi. I still have issues with this occasionally & I find it's easier just to create a new table & paste the col headings & expressions from the old table into it & then setup the repeat headers etc again according to what is above.

    Cheers

    Thursday, January 28, 2010 11:48 PM
  • Hi,

    I am having the same issue, I want to show the table headers on each page but I have two groups in my table, SO I am unable to set  
    KeepwithGroup to After property for both of them as it gives me an error.....but I did set  In the properties grid, set RepeatOnNewPage to true  for both the GROUPS.

    Still it is not showing me the headers on each page, It works If I use only one GROUP in my table, any idea what am I missing in this....???
    Thanks for your help.

    Thursday, March 04, 2010 9:19 PM
  • This seems to be one of the biggest annoyances with SSRS 2008!!
    SSRS Team, please comment.

    Thanks
    Friday, March 05, 2010 2:01 PM
  • I am having this issue as well.  I have followed all of the above mentioned guidelines and the rows will not repeat.  They just show on the first page.
    KeepwithGroup = After
    RepeatOnNewPage = True

    For each static row.

    Tuesday, March 09, 2010 8:24 PM
  • This is the BIGGEST pain in the posterior to date with SSRS 2008. WHY on Earth Microsoft insists on making what was once the SIMPLEST of tasks into one of the most painful and quite honestly hit or miss tasks is simply beyond me!!! I still can't get column headers to repeat. In SSRS 2005, no problem!!!

    I am really starting to hate SSRS 2008. Everything I try to do has now somehow been made "better"...!

    I would really like to gear from the SSRS team on this one...
    A. M. Robinson
    Wednesday, March 10, 2010 4:30 AM
  • SSRS Team???
    Thursday, March 11, 2010 6:53 AM
  • 1. I followed the detailed instructions concerning settings on the Static items in the RowGroup hierarchy, but it only worked for rendering to PDF and paging in the web, not rendering to Word.  Word rendering is why we upgraded to SSRS2008!!!!!   How can I get it to work in Word!!!

    2. How can you add or delete a group header or footer on a group short of deleting and re-adding the group.  I can't find any GUI or property settings for maintaining this.  This was so easy in SSRS 2005!!!!!

    Thursday, March 11, 2010 7:53 PM
  • I know i had the same issues with my report when we converted to SSRS 2008 last month.

    My reports would go to the next page and the header would disappear. So after doing some research on the boards, I found a post on the MS boards that UPDATE 5 to SP1 (update_5_SQL2008SP1_x86) fixed the issue in SSRS where the header was not repeating on certain reports.

    Once I had my IT Admin install this on the SSRS 2008 box, Bingo, the headers started to repeat on my reports.

    The BIG issue I had with SSRS 2008 was the Excel Margins where not keeping when exporting a report. That was huge because after we rolled out 2008, I had over 20 calls from users saying the page margins in the Excel export were wrong.

    MSConnect: Reporting Services 2008 Export To Excel Margins

    So after searching the boards and calling MS, they said its a known bug and will be fixed when R2 comes out..... Wish there was a hotfix for this!!!
    Thursday, March 11, 2010 8:55 PM
  • I know i had the same issues with my report when we converted to SSRS 2008 last month.

    My reports would go to the next page and the header would disappear. So after doing some research on the boards, I found a post on the MS boards that UPDATE 5 to SP1 (update_5_SQL2008SP1_x86) fixed the issue in SSRS where the header was not repeating on certain reports.

    Once I had my IT Admin install this on the SSRS 2008 box, Bingo, the headers started to repeat on my reports.

    I think SSRS_DEV was actually referring to Update Package 6 which fixes a slightly different Row header bug.

    You want Update Package 7 (released 2 days ago) which FINALLY fixes the Tablix Header Not Repeating bug!  

    Note that this is a CUMULATIVE update package which means it also contains all previous hotfixes since SP1.

    Hope this helps!
    • Proposed as answer by 619 Thursday, March 18, 2010 1:15 AM
    Thursday, March 18, 2010 1:10 AM
  • Hi 619

     

    I think the ONLY way to fix this is to go back to the way SSRS 2005 did things ;-)

     

    Regards,

    Shiv

    Monday, March 29, 2010 9:08 AM
  • 619, Mary, Robert,

    I installed update 7 but this still does not work for the export to Word.  I've followed all of the instructions as to Matrix Repeat Column Headers, and Tablix Row Groups Advanced Mode Fixed Data, Repeat on New Page, and Keep Together settings. 

    Could someone provide me with a sample RDL that works with the Word rendering.  This is an obstacle for our use of SSRS 2008 as we wanted the Word rendering.

     

     

    Tuesday, March 30, 2010 7:20 AM
  • Most of the issues with Repeating Table Headers in Word seems to be an issue with how SSRS renders to Word.  SSRS renders vitually all objects as Tables in Word including the text boxes, rectangles, tablixes, lists, and I think even the report body.  Any nested tables in Word will not repeat the table headers for the inner tables.  Since everything renders as a table in Word, nested tables are virtually impossible to avoid, and the table headers will not repeat no matter how well they have been defined in SSRS.
    Wednesday, April 07, 2010 10:33 PM
  • It doesn't work for me. I have multiple layers of grouping and my static header is at the very top of the tablix. I really regret switching over to SQL 2008. It's so unstable. 
    Tuesday, May 11, 2010 10:16 PM
  • It does not work for me either. I have done all of these settings, including creating a whole brand new report and I still cannot get the row header to repeat, nevermind have the row header freeze on excel export.
    Thursday, May 20, 2010 5:42 PM
  • No resolution here either.   Tablix Headers don't show on last page of PDF and TIFF output.   I've tried all things mentioned including installing SQL Server 2008 Cumulative Update# 7.   My issue is that I have a Tablix with some header rows that repeat fine until the last page.   On the last page they are hidden.  This appears to be true of PDF and TIFF output.  THere are other issues with Word output.   The standard HTML viewer works fine.   So its clearly a PDF renderer issue.  

    Microsoft, if you are listening, please help!!!

    Friday, May 21, 2010 5:30 PM
  • Yes, this is still a problem for me too.  I have a simple table and merely want to repeat the column headers and cannot.  I created the same report on a machine with SSRS2005 and it works perfectly and very easily.  I have tried all the things mentioned here and in other articles and NOTHING works.  I can't fathom the thought process that took place at MSFT to make something that had been working great in 2005 so much worse in 2008.  I suspect no thought at all and very little testing.  Seriously?  I thought the idea was to make report development easier, at least that was the marketing hype spewed out of Redmond when SSRS 2008 was released.
    will
    Monday, May 24, 2010 9:56 PM
  • Hey everyone, I opened a MS CONNECT dealing with this, I would hope you all would vote on this and offer your input

    "Excel Export create freeze pane on Tablix Header Row not page header Row"

    https://connect.microsoft.com/SQLServer/feedback/details/561128/excel-export-create-freeze-pane-on-tablix-header-row-not-page-header-row

     

     

    • Proposed as answer by JWHampton Wednesday, June 09, 2010 2:17 PM
    Thursday, May 27, 2010 3:19 PM
  • Hello SSRS Team..

    Please help, I am unable to repeat the columns in a table, I tried all this

    RepeatonNewpage =True / Keepwith Group = After.

    Actually I dont know which static to be changes, there are so many statics( I have 6 groups)

    Plss helpppppppppppppppppppppppppppp

     


    Thanks
    Wednesday, June 09, 2010 8:02 PM
  • Hi there,

    I know this is an old forum post however I am having the same problem and realise it is probably because I have deleted the column associated with the group as detailed by Mary in the answer.  Is there a way to recify my mistake without redoing the whole report layout?

    Many Thanks,
    Katie

    Wednesday, June 16, 2010 2:59 PM
  • I have now battled with this for a few days and just think it is not acceptable how Microsoft can take such a huge step back with something that is so fundamental and simple in reports!!!

    I have 2 row groups:

    StatusGroup (group 1), and

    ApplicationID (group 2)

    So the advance group properties looks like this:

    Static *
     Static *
      (Static) *
    [StatusGroupTo
     Static *
      (Static) *
    ApplicationID
     Static *

    * I have set the KeepWithGroup propery and the RepeatOnNewPage property on all of these areas to After and True respectively in all possible combinations, but NOTHING works!!

    I must just add that the columns created for the two groups are hidden.

    Monday, July 12, 2010 9:48 AM
  • I have a related problem.  I have a report with a details group; group3; group2; and, group1.  They are all nested.   The group headers have data that is useful for the report.  The details visibility is determined by an expression.  So, it is possible that details will not display for all groups.  When that happens the group3 header still displays --- good thing.  However, the group2 and group1 headers do not display --- bad thing.

    I checked the advanced mode properties for all groups and the RepeatOnNewPage and KeepWithGroup properties are as you recommend above.  I have tried various combinations on teh details_group with no change in the results.


    Leo
    Friday, October 29, 2010 3:55 PM
  • Table header repeat issue: instruction listed here works.

    this thing is, why SSRS makes such common report feature so 'mystic'. 

    Monday, December 06, 2010 3:48 PM
  • I, too, was bitten by this challenge but the instructions listed here helped solve the issue. I'm not pleased that the solution isn't intuitive but now I know.

    I'm now left to hunt to figure out how to make those column headers scroll when the user scrolls down the page. My other reports (which don't contain grouping) use this functionality and the clients are quite happy with it.

    Finally, I can't agree with the poster that responded they didn't like SSRS2008 because I think it is a major upgrade over SSRS2005. Try implementing a column group on a table in 2005 and you'll see what I mean. You can't -- you have to use the matrix. Now, try to have multiple row groups that correlate to that column group. One record per line that will have one-to-many items in the column group. Now tell me how you get your row groups to have their own column headers. You can't.

    I've had to hack a solution together involving a table with no data (just column headers) and superimpose that over the matrix where I needed the row column headers. And that still doesn't work because when you deploy it to the server and view it through a browser (IE 8 I might add!), the hacked column headers don't float correctly. It's a real visual treat that you can't fix. I spent hours and you just can't fix it. But go to SSRS2008 and the new tablix object allows you to handle this quite nicely. In fact, it's easy.

    Then there are the upgrades to the matrix object.

    Overall, I like SSRS2008 but these group column headers are a pain because they aren't intuitive and I'm not even sure if the scroll feature is available. Yet...

    Thursday, March 03, 2011 10:15 PM
  • Wednesday, March 23, 2011 7:34 PM
  • mrleokarthik

    If I do this why does it leave alternate pages blank?


    Regards
    Partha Mandayam
    IT Consultant
    Invacare
    http://weblogs.asp.net/pmandayam
    http://partha.tripod.com
    Tuesday, March 29, 2011 2:54 PM
  • I do not think this has to do with the settings used for repeating the page header. The blank page usally comes when there are blank spaces left between the header/footer and the body of the report. Try removing all the empty spaces and see if that works.
    Thanks, Gaurav
    http://gauravsqlserver.blogspot.com
    • Proposed as answer by mcp111 Tuesday, March 29, 2011 7:27 PM
    Tuesday, March 29, 2011 3:05 PM
  • Does anyone know how to read this Advanced mode? When I look at it I have under Row Groups

    Static

    Static

    grpProgram (first group level)

    Static

    Static

    grpTask (second group level)

    Static X 4

    grpItemtype (third group level)

    Details Group

    STatic

    Static

    so on ...

     

    How do I know which one is the row with the headings that I want to mark with the repeat.  Depending on the level where I try to find where to set these properties, I will get an error about them.  Man ... so much more confusing trying to work with these groups than in 2005 or even 2000!

    Any help would be appreciated.


    Sherry
    Monday, June 13, 2011 9:32 PM
  • Same problem here - tablix headers are missing on the last page (sometimes two pages) of PDF output.

    On SQL 2008 R2 CU7.

     

    Monday, June 20, 2011 6:17 PM
  • Found it. It is a Tablix Member property rather than a property of the tablix itself.

    Steps:

    1.       In the grouping pane, make sure to turn on advanced mode (click on the small black down arrow on the far right of the grouping pane)

     

    2.       Select the corresponding (Static) item in the row group hierarchy

    3.       In the properties grid, set RepeatOnNewPage to true

     

    Great. This worked for me too. Thanks for the tip/ solution.
    • Proposed as answer by Sharke Tuesday, July 12, 2011 7:59 AM
    Wednesday, June 29, 2011 5:17 PM
  • I have often used the "Advanced Mode" answer to address this issue, however I found one report that was very stubborn.  When selecting (Static) row groups, I noticed that one row group would cause the first column of my report to be selected, rather than a row header as in the other cases.

    The issue turned out to be an extra level in the hierarchy of the RDL code.

            <TablixRowHierarchy>
              <TablixMembers>
                <TablixMember>
                  <TablixMembers>
                    <TablixMember>
    ....
     
                    </TablixMember>
                  </TablixMembers>
                </TablixMember>
              </TablixMembers>
            </TablixRowHierarchy>

    I took out the first <TablixMembers/> and <TablixMember/> nodes, and the problem was solved!

    • Proposed as answer by Minnie.Shi Friday, February 03, 2012 2:22 AM
    Monday, August 22, 2011 5:51 PM
  • In my case the solution was KeepTogether=”True”, KeepWithGroup=”After”, RepeatOnNewPage=”True”. I opened one the reports, converted from SSRS 2005 and checked the static values in Advanced Mode.

     

    Thanks for the solution

    Friday, August 26, 2011 12:38 PM
  • I too was having the same issue and came across this helpful post. To enable Advanced mode, click the down arrow as seen on the image below.

    If what you are trying to repeat is just the detail header, the group to select should be the one right above the detail group. See image below.

    Thanks for the solutions suggested here I was able to solve my issue.

     

    Thursday, October 13, 2011 6:42 PM
  • I had the same problem except that even after doing the adv mode changes it would not display when exporting to PDF or printing(did display in rendering). My report had 2 groups but I was not displaying the 2nd group(from the top) and was just setting Hide Duplicates from nothing to the 2nd group level on the detail line. If I turn hide duplicates to nothing, the header would display in the PDF and print version. Set to any of the group levels it would take away the duplicates and the header on PDF/Printing. I ended up just moving the 3 columns I was trying to hide duplicates on to the group line instead of using the hide duplicates setting and then had no problems.  Just my 2 cents...
    • Edited by ShadowH Thursday, October 27, 2011 10:03 PM
    Thursday, October 27, 2011 10:01 PM
  • Thanks Robert.now i am able to reapeat the row header in all the pages.
    Friday, January 27, 2012 10:49 AM
  •  

    • Proposed as answer by Minnie Shi - Schurr Friday, February 03, 2012 2:59 AM
    • Edited by Minnie.Shi Friday, February 03, 2012 3:08 AM wrong account, want to delete repetitive answer
    • Unproposed as answer by Minnie Shi - Schurr Friday, February 03, 2012 3:12 AM
    Friday, February 03, 2012 2:24 AM
  • I have often used the "Advanced Mode" answer to address this issue, however I found one report that was very stubborn.  When selecting (Static) row groups, I noticed that one row group would cause the first column of my report to be selected, rather than a row header as in the other cases.

    The issue turned out to be an extra level in the hierarchy of the RDL code.

     

            <TablixRowHierarchy>
              <TablixMembers>
                <TablixMember>
                  <TablixMembers>
                    <TablixMember>
    ....
     
                    </TablixMember>
                  </TablixMembers>
                </TablixMember>
              </TablixMembers>
            </TablixRowHierarchy>

    I took out the first <TablixMembers/> and <TablixMember/> nodes, and the problem was solved!

     

    I found this is very helpful. although it may took you a while to identify the extra XML tag/layerto be deleted.

    one trick is what mentioned in the above ' When selecting (Static) row groups, I noticed that one row group would cause the first column of my report to be selected, rather than a row header as in the other cases'.

    I have found another trick which you could quickly identify the possible 'extra layer of XML tags': the trick is that you will see more than one (static)s in the group pane(advanced mode) above the group you want the row header to repeat. This is an indication that the 'extra layer' occurred, if in your data region design area you were only putting one row header.

    After you comment out/delete the extra layer, you would notice that the extra '(static)' disappeared from the group pane. (below is my example of commenting out the extra/problematic layer:

     

    <TablixRowHierarchy>

    <TablixMembers>

     <TablixMember>

      <KeepWithGroup>After</KeepWithGroup>

      <RepeatOnNewPage>true</RepeatOnNewPage>

      <KeepTogether>true</KeepTogether>

    </TablixMember>

    <TablixMember>

    <!-- <TablixMembers> -->

    <!-- <TablixMember> -->

    ..... your correct XML tags

    <!-- </TablixMember>-->

    <!-- </TablixMembers>-->

    </TablixMember>

    <TablixMember />

    </TablixMembers>

    </TablixRowHierarchy>

     

    )

    Regards,

    Min.Shi

    Friday, February 03, 2012 3:05 AM
  • I totally agree! <soapbox>I used to rant and rave about how awesome SSRS 2005 was and how fast I could build reports back in the day (2004-2006).  I've just returned to building custom reports in the past few months, and had the "joy" of using the "improved" SSRS 2008, which came out during my hiatus.  I will tell you unequivocally that SSRS 2008 has been the biggest pain in my rear and nearly killed my productivity.  I spend my days scouring the internet for answers on how to do simple things like make a header row repeat at the top of each page break.  Why in God's name is something so simple, made into something so complicated!!!???  It's things like this that make me question my loyalty to Microsoft.  Many of my friends have completely bailed and gone to the "dark-side", totally abandoning Microsoft development tools altogether.  What makes a man spend 10 years of his life which he has invested in learning Microsoft .NET development and then throw up his arms in disgust one day and completely turn his back on it?  That's what you call "cutting your losses" and starting over.  It's no wonder.  How long can someone be expected to beat their head against the wall?  How long will a company pay a developer $100k / year to eke a few system enhancements a month?  I spent four hours today just trying to get the header row to repeat.  Am I stupid because it took me that long to figure it out?</soapbox> Have a nice day.

    Dan

    Monday, March 26, 2012 7:38 PM
  • mrleokarthik's answer is perfect  to me. Please keep it up your help.............
    Monday, June 04, 2012 5:02 AM
  • This post seems to have found the answer.  It depends on how you created the report.  If you did it via the Wizard, then you are okay, however if you did it from an empty one then it is missing certain XML elements.

    http://www.sqlservercentral.com/Forums/Topic593245-1063-1.aspx


    • Edited by Peter Jenks Monday, June 04, 2012 6:18 AM
    • Proposed as answer by Adam Quark Tuesday, March 19, 2013 3:29 PM
    Monday, June 04, 2012 6:18 AM
  • Hey Dan, don't feel alone.  I have been working with computers for >30 years, MS for 10, and MS is actually getting worse.  Simple tasks that could be done in a day, 30 YEARS AGO, now take weeks/months, and are unstable when you DO get them working.  Shallow ideas and marketing gobblegook like "you don't have to write a line of code" are offset by realities like "configuring the system for the most trivial imaginable tasks will take a week".  Basic business concepts like batching reports are completely overlooked - but hey, it works great if you're using it to do finances for your bicycle repair shop.

    Have a nice day.

    Tuesday, July 17, 2012 1:46 PM
  • Why is such a basic function of report writers so difficult to accomplish (and many times impossible) with SSRS?  This is unacceptable and needs to be addressed by Microsoft.  Cudos to MS for giving us such a great tool, but for goodness sake, get this resolved by making a one stop shop setting with a checkbox to determine whether the header prints on every page or not and do whatever you have to do under the hood to get it done (without coming up with excuses that the tablix region has to blah blah blah this and that and you have to understand how the blah blah blah works).

    I mean unless you're going to open source SSRS (please please please open source it).

    Also, I have a simple report that I've got this working for (forget it if the report is complex, aint gonna happen).  But when I enable this, I lose page header on last page!?!?

    SSRS has bugs needing to be fixed...

    Thursday, July 26, 2012 2:31 PM
  • This works , Thank you bro!
    • Proposed as answer by Rajas12345 Friday, December 07, 2012 9:14 AM
    Wednesday, October 31, 2012 1:08 PM
  • Hi All,

    I am working in SSRS 2008, created report which has 2 groups Group1 and its parent group Group2 with toggle option enabled.

    For pagination i have added one parent group of Group2 as Group3 using "=Ceiling(Rownumber(Nothing)/Parameters!Items_Per_Page.Value)" expression, In Tablix of report i deleted this column Group3 (Delete columns only).

    I want row headers to be repeated in every page to do that:-

    1. Selected Advanced Mode option in column group section and now i see that there are static member in Row and Column Groups.

    2. To repeat the row headers in every page, I tried selecting all the (static), static which are above and below the groups Group1-3, "Details" one by one with properties KeepWithGroup as "After", RepeatOnNewPage as "True". But still row headers are not repeated in every page. Could someone please help me to resolve this issue?

    I have tried all options mentioned in this thread and links but still couldn't succeed.

    Raja

    Friday, December 07, 2012 9:33 AM
  • Hi Raja,

    As you have already followed the steps,

    Please make sure you did it this way:

    In the grouping pane, click on the small triangle and select "Advanced Mode" to show static members:

    1. verify that you have the properties grid turned on (in BI Development Studio use F4, in Report Builder go to the "View" tab and select "Properties")
    2. select the corresponding (static) item in the Row Groups hierarchy
    3. in the properties grid:
      - set KeepWithGroup to After
      - set RepeatOnNewPage to true for repeating headers

    I did the same , and it is working for me.

    Make sure you have not played with other settings-- try making a new report and apply these settings and see it should work

    • Proposed as answer by Adam Quark Tuesday, March 19, 2013 3:29 PM
    Friday, December 07, 2012 11:46 AM
  • I want to second  dknowlton75093s comment that the SSRS team really needs to improve how the repeat table header functionality works. It way too complicated for how simple a task it is.
    Monday, February 11, 2013 3:16 PM
  • OK, the answers given by Peter Jenks and CiphersCode worked for me.

    Sure, it works, but it is the epitome of unnecessarily complex for a task that worked by simply checking a box in 2005.

    Also, the answer seems - for someone not steeped in SSRS esoterica - rather arbitrary. To wit; why must those three settings be set exactly so to get a simple repeating header? Why not a simple "RepeatHeader" set to true and let SSRS do the work of setting whatever needs to be set to accomplish this?

    Why the Rube Goldberg solution?

    Maybe I'm old-fashioned, but I always thought the role of tools like SSRS was to make a task easier, not more difficult.

    Silly me...


    • Edited by Adam Quark Monday, April 01, 2013 9:06 PM "goven?"
    Tuesday, March 19, 2013 3:36 PM
  • Search your Report code by keyword 'TablixMembers' and Replace it by the following script.

    Hope Header will works!!!!!!!!!!

       <TablixRowHierarchy>

              <TablixMembers>

                <TablixMember>

                  <KeepWithGroup>After</KeepWithGroup>

                            <RepeatOnNewPage>true</RepeatOnNewPage>

                            <KeepTogether>true</KeepTogether>

                </TablixMember>

                <TablixMember>

                  <Group Name="Details" />

                </TablixMember>

                <TablixMember>

                            <KeepWithGroup>Before</KeepWithGroup>    

                 </TablixMember>

              </TablixMembers>

            </TablixRowHierarchy>

    It will works.!!!!!!!!


    Regards http:\\sqldbatask.blogspot.com MCTS Please mark answered if I've answered your question and vote for it as helpful to help other user's find a solution quicker

    Tuesday, March 26, 2013 1:41 PM
  • This method works for me with repeat column header but I have to apply this method to every single Static in my report.

    1) In the grouping pane, make sure to turn on advanced mode (click on the small black down arrow on the far right of the grouping pane) 

    2. Select the corresponding (Static) item in the row group hierarchy

    3. In the properties grid, set RepeatOnNewPage to true

    4. KeepwithGroup to After

    Thank you for this post.

    This post helps me solve my issue with repeat column header.

    Thanks!


    • Edited by Douang Wednesday, April 17, 2013 3:35 PM
    Monday, April 08, 2013 1:52 PM
  •   Hi  dexter, I am also having same problem, thanks to your technique it is working really!!

        Thanks again
    Friday, April 26, 2013 9:57 AM
  • I may have discerned why the accepted answer works in some cases but not others.

    When you drag a table onto the page from the toolbox and start adding parent groups to your details row, the designer adds columns on the left side of a double-dashed column divider line that it creates. If you have additional parent groups, the group headers get created over there as well, with merged rows below the group header label. The "advanced mode" approach doesn't seem to work on the static members defined to the left side of that double-dashed column divider.

    But I was able to add columns on the right side of the double-dashed column divider, copy the cell contents over from the "left side" to the "right side", then delete the columns that the designer had made originally on the left side of the double-dashed column divider. ONLY THEN was I able to make the "advanced mode" solution work.

    Interestingly, the table that I ended up with after doing all that had the same structure as the table that the Report Wizard creates if you go through its steps to add a table. Not sure why that gives something different than just adding parent groups to a table on the page does, but there it is. Hopefully this tip will help some other head-bangers out there.

    Thursday, March 06, 2014 6:54 PM