none
can not connect to Report server from SQL SERVER 2005 Management studio

    Question

  • Hi All,

    I have a brand new install of sql server 2005 on brand new WINDOWS SERVER2003 with latest versions. Every thing works fine excepting I get a 404 when I connect to report server from management studio..

    I am even able to publish reports and all the

    url://localhost/reportserver

    url://localhost/reports

    url://localhost/reportserver/reportbuilder/reportbuilder.application

    all work fine on local machine and with in the network behind the fire wall.

    But when I try to connect to report server using management studio on the local server or remote server, I get the following error.

    "

    TITLE: Microsoft SQL Server Management Studio
    ------------------------------

    The attempt to connect to the report server failed.  Check your connection information and that the report server is a compatible version. (Microsoft.SqlServer.Management.UI.RSClient)

    ------------------------------
    ADDITIONAL INFORMATION:

    The request failed with HTTP status 404: Not Found. (Microsoft.SqlServer.Management.UI.RSClient)

    "

    More techinal details

     

    "===================================

    Cannot connect to xxxxxxxxxxxx.

    ===================================

    The attempt to connect to the report server failed.  Check your connection information and that the report server is a compatible version. (Microsoft.SqlServer.Management.UI.RSClient)

    ------------------------------
    Program Location:

       at Microsoft.SqlServer.ReportingServices2005.RSConnection.MissingEndpointException.ThrowIfEndpointMissing(WebException e)
       at Microsoft.SqlServer.ReportingServices2005.RSConnection.ValidateConnection()
       at Microsoft.SqlServer.Management.UI.RSClient.RSClientConnection.CreateConnection(String connectionString)
       at Microsoft.SqlServer.Management.UI.RSClient.RSConnectionInfo.CreateConnectionObject()
       at Microsoft.SqlServer.Management.UI.RSClient.RSConnectionInfo.RSTypeImpl.GetConnectionObject(UIConnectionInfo ci)
       at Microsoft.SqlServer.Management.UI.ConnectionDlg.RSType.GetConnectionObject(UIConnectionInfo ci)
       at Microsoft.SqlServer.Management.UI.VSIntegration.ObjectExplorer.ObjectExplorer.ValidateConnection(UIConnectionInfo ci, IServerType server)
       at Microsoft.SqlServer.Management.UI.ConnectionDlg.Connector.ConnectionThreadUser()

    ===================================

    The request failed with HTTP status 404: Not Found. (Microsoft.SqlServer.Management.UI.RSClient)

    ------------------------------
    Program Location:

       at Microsoft.SqlServer.ReportingServices2005.RSConnection.GetSecureMethods()
       at Microsoft.SqlServer.ReportingServices2005.RSConnection.IsSecureMethod(String methodname)
       at Microsoft.SqlServer.ReportingServices2005.RSConnection.ValidateConnection()

    "

    Any help would be greatly appreciated.

    Bob

     

    Saturday, February 18, 2006 3:41 AM

Answers

  • I managed to solve this problem...

    If you want to use machine\instance to connect Management studio.

    You need to make sure in rsreportservice.config, element <UrlRoot>http://localhost/reportserver</UrlRoot> is correctly configured. (You can test this by visit this url)

    I guess, the machine\instance will eventurally be translated to the <UrlRoot>. If the <UrlRoot> is not correct, then you will not be able to use machine\instance to connect report service.

    Thursday, March 30, 2006 5:31 AM
  • Something to try:

     

    I had the same issue, what I did to fix is goto C:\Program Files\Microsoft SQL Server\MSSQL.1\Reporting Services and ensure that the ASPNET user has read,read&Execute and List Folder security permissions applied to all the subdirectories also ensure that you click the 'Advance' button when applying the permissions to ensure the security settings are applied to all child objects.  During my installation for some reason it did not assign the proper permissions to the ASPNET user (aspnet_wp account). It couldn't even read the config files.

     

    good luck

    Thursday, August 02, 2007 8:30 AM
  • All,
    For those still stuck on this one:

    I had this problem after changing the user's password for the domain. My symptoms were:

    SQL Enterprise manager:
    Connect to SQL Server: OK
    Connect to Integration Services: Bad Password
    Connect to Report Server: Not Found

    (For reference, we use local profiles, and Active directory login, and Windows integerated security to connect in all three cases.)

    Another computer, same domain user, all OK
    Same computer, another domain user, all OK

    Also, since we have password lockout security, it would keep locking the user account due to bad password when we tried the failed connects. This was also shown in the Active directory event log as coming from that station. Obviously a bad or old password was cached somewhere on that station.

    Turns out that the credentials had been saved in the User's managed passwords on that station, and still held the old values. Apparently, this overrides the domain users credentials, but strangely, not for SQL server connection.
    To fix: (XP Professional)
    - Click on Control Panel / User Accounts
    - Click on Advanced Tab
    - Click on Manage Passwords
    - Remove the entry or entries referring to the server in question
    - Logout and back in

    Thanks,
    Kirk Lanctot
    U-Haul International





    Friday, March 28, 2008 7:35 PM

All replies

  • What are you passing in as the server name to Management Studio?

    You can connect several ways

    http://localhost/reportserver

    servername

    servername\instance

    Monday, February 20, 2006 5:55 PM
  • I passed both the servername and the servername\instance  to the management studio.

    My IIS and uses port 80. I can access Reportserver, report manager and report bilder thru the Internet. I just can not connect to Report server from Management studio.

    I will try connecting to RS is Management studo using http://localhost/reportserver.

    Regards

    Bobba 

    Monday, February 20, 2006 6:08 PM
  • Hi Brad Syputa,

     

    Thank you for the suggestion. I worked. I was not able to try your suggestion immediatly as I was out of town.

    Now I have this big question:

    Why am I only able to connect to "report server" from "management studio" using

    1. http://localhost/reportserver

    and not using

    2. servername

    3. servername\instance.

    Your help would save me a lot of time

    Regards

    Bobba(Bob) 

    Wednesday, February 22, 2006 6:04 PM
  •  bobba wrote:

    Hi Brad Syputa,

    Thank you for the suggestion. I worked. I was not able to try your suggestion immediatly as I was out of town.

    Now I have this big question:

    Why am I only able to connect to "report server" from "management studio" using

    1. http://localhost/reportserver

    and not using

    2. servername

    3. servername\instance.

    Your help would save me a lot of time

    Regards

    Bobba(Bob) 

    Thursday, February 23, 2006 5:02 PM
  • Indeed, I am very interested in disvoering the answer.  We had a developer in our organization with the same problem and could only connect by enterting http://localhost/reportserver.  The DBA team is fine using servername\instance.

     

    Is this a bug that will be resolved?

    thanks in advance,

    Jason Wall

    Monday, March 20, 2006 7:38 PM
  • You should be able to connect using machine\instance.  This method uses WMI to get the url for SOAP calls.  Will you try opening the report server config tool?  Can this tool connect to the machine?  Are you specifying the same instance name listed in the config tool connection dialog?
    Tuesday, March 21, 2006 4:37 PM
  • I have the same problem.

    I can connect to the reporting service by using machine\instance in report server config tool.

    But I cannot connect to the reporting service through managment studio by providing machine\instance, instead, if I use http://localhost/reportserver, I can connect to the report server through management studio.

    I even tried to uninstall the report service, and reinstall it again. This problem still exists.

    But the same thing does not happen on my colleague's machine.

    I think it is better to look into this issue...

    Thursday, March 30, 2006 4:36 AM
  • I managed to solve this problem...

    If you want to use machine\instance to connect Management studio.

    You need to make sure in rsreportservice.config, element <UrlRoot>http://localhost/reportserver</UrlRoot> is correctly configured. (You can test this by visit this url)

    I guess, the machine\instance will eventurally be translated to the <UrlRoot>. If the <UrlRoot> is not correct, then you will not be able to use machine\instance to connect report service.

    Thursday, March 30, 2006 5:31 AM
  • the attempt to connect to the report server failed. check your connection information and that the report server is a compatible version(.Net 2003 version)
    Thursday, November 16, 2006 4:32 AM
  • I am try to solve this problem i give for this error"
    • The request failed with HTTP status 400: Bad Request. "
    • plz send me Slution
    Tuesday, April 10, 2007 12:02 PM
  • hi all,
    i have SQL 2205 with SP1 installed on my machine.
    and i m not bale to connect to Report Server using SQL management studio as well as from web.

    i have installed reporting server and database on same machine. i tried using

     "http://localhost/reportserver"
    "http://localhost/reports"
    "http://localhost/reportmanager"

    but i am not bale to connect i am getting "Service Unavailable" page.

    and when i try to connect using SQL Management Studio with "servername/instance" as well as "http://localhost/reportserver" i am getting a error saying.

    ===================================
    Cannot connect to http://localhost/reportserver.

    The request failed with HTTP status 503: Service Unavailable. (Microsoft.SqlServer.Management.UI.RSClient)

    ===================================

    but if i try and connect to other reporting server on other machine using web http://servername/reportserver i m able to connect it.
    but dont know whats the problem on my machine.

    do i need to start any services for this...

    so anybody knows how to troubleshoot this issue.

    Thanks in advance...

    Tuesday, April 10, 2007 5:24 PM
  • Hi,

     

    Any solution for the above mentioned problem?

     

     have SQL 2005 without SP1 installed on my machine.
    and i m not bale to connect to Report Server using SQL management studio as well as from web.

    i have installed reporting server and database on same machine. i tried using

     "http://localhost/reportserver"
    "http://localhost/reports"
    "http://localhost/reportmanager"

    but i am not bale to connect i am getting "Service Unavailable" page.

    and when i try to connect using SQL Management Studio with "servername/instance" it says, "No connection could not be made because the target machine actively refused it"


    ===================================
    Cannot connect to http://localhost/reportserver.

    The request failed with HTTP status 503: Service Unavailable. (Microsoft.SqlServer.Management.UI.RSClient)

    Please post your suggestion,  if you resolved it already.

     

    Regards,

    Bhuvana

    Wednesday, May 23, 2007 7:59 AM
  • i tried visiting this URL. it says 503, service un available error. Please give me the solution.
    Wednesday, May 23, 2007 8:52 AM
  • Something to try:

     

    I had the same issue, what I did to fix is goto C:\Program Files\Microsoft SQL Server\MSSQL.1\Reporting Services and ensure that the ASPNET user has read,read&Execute and List Folder security permissions applied to all the subdirectories also ensure that you click the 'Advance' button when applying the permissions to ensure the security settings are applied to all child objects.  During my installation for some reason it did not assign the proper permissions to the ASPNET user (aspnet_wp account). It couldn't even read the config files.

     

    good luck

    Thursday, August 02, 2007 8:30 AM
  • I got the same issue and got it resolved

     

    Uninstall IIS, ASP.NET from windows then uninstall sql server. reinstall in the same order it should work fine

    Monday, December 31, 2007 6:51 AM
  • All,
    For those still stuck on this one:

    I had this problem after changing the user's password for the domain. My symptoms were:

    SQL Enterprise manager:
    Connect to SQL Server: OK
    Connect to Integration Services: Bad Password
    Connect to Report Server: Not Found

    (For reference, we use local profiles, and Active directory login, and Windows integerated security to connect in all three cases.)

    Another computer, same domain user, all OK
    Same computer, another domain user, all OK

    Also, since we have password lockout security, it would keep locking the user account due to bad password when we tried the failed connects. This was also shown in the Active directory event log as coming from that station. Obviously a bad or old password was cached somewhere on that station.

    Turns out that the credentials had been saved in the User's managed passwords on that station, and still held the old values. Apparently, this overrides the domain users credentials, but strangely, not for SQL server connection.
    To fix: (XP Professional)
    - Click on Control Panel / User Accounts
    - Click on Advanced Tab
    - Click on Manage Passwords
    - Remove the entry or entries referring to the server in question
    - Logout and back in

    Thanks,
    Kirk Lanctot
    U-Haul International





    Friday, March 28, 2008 7:35 PM
  • THANK you 'kerrycas' for posting this fix!  It worked!  Users are now able to connect to report server via SSMS :-)

     

    Tuesday, April 15, 2008 5:42 PM
  • Hi,

     

    I´m having the same problem it connects when I try to connect to http://localhost/reportserver  in the same machine where Reporting is installed. But when I try to connect from other machine I could not connect! but the IIS is responding just if i try http://<server name>.

     

    And I still can not connect using MS SQL Server Management Studio 2005.

     

    thanks.

     

     

    Monday, June 09, 2008 3:00 PM
  • Hi Anonymousfff,

     

    If you have SQL Server 2005 SP1, and you try to connect to Management Studio using a non-admin account, it's not going to work. This functionality for non-admin accounts was added in SQL Server 2005 SP2.

    I would also suggest to read this old thread:

    http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=1291309&SiteID=1

     

    Thank you,

    Mihaela

    Thursday, June 12, 2008 3:56 AM
  • The problem I solved it configurating the IIS 

    It is that the IIS make in a virtaul server named "Report Server" and that is the we can use in setup

    One is not due to create the virtual directories on by default virtaul server but by the Report Server

    the management studio try connect to this virtual server

    I hope that it is of aid
    Saturday, April 18, 2009 12:47 AM
  • My problem was that I could not get to the Report Manager.
    Solution:
    Edit ..\Reporting Services\ReportManager\RSWebApplication.config

    Make sure that the element <ReportServerURL> has the correct computer name. 
    This will still point to ReportsServer, but the path is still required for Report Manager to run.
    <ReportServerUrl>http://{computername/ReportServer</ReportServerUrl>

    Further note that even though the report server web site uses SSL, this path still only uses http: and not https:.
    Sunday, August 16, 2009 8:15 PM
  •  

    Fix It

    Edit ..\Reporting Services\ReportServer\rsreportserver.config

      <UrlRoot>http:// your url  /Reports</UrlRoot>

    my path ( url ) http://reports.abc.org/Reports

      <UrlRoot>http://reports.abc.org/Reports</UrlRoot>

    work for me

     

     

    Friday, February 25, 2011 3:33 PM
  • Hey Folks!... I don't do ANYTHING without a GUI :)... Just try going into SSRS Configuration Manager... of course you set up your databases (reportserver and reportservertempdb) then go and configure the Web Service URL and Report Manager URL.  I just accepted the defaults and clicked 'Apply'... then I was able to connect using SSMS perfectly.

    Good Luck everyone...

    Mark Enloe

    Monday, November 21, 2011 10:48 PM
  • ALL of the suggestions here are great!

    For me,  SQL Server 2008R2

    I had 3 instances of Report Managers for load balancing attached to one Report Server Database called MadMax

    1. LiveWire
    2. Thunderbay
    3. Bladerunner

    Each instance had a “rsreportserver.config” file.  I removed the <DRepdortServerUrl>value</ReportServerUrl>

    and got them all working and each “Joined” on the “Scale-out Deployment” tab.

    Thanks everyone!

    Tuesday, March 20, 2012 8:27 PM