none
IIS detection on Vista: Where's my Windows Authentication option ?

    Question

  • I am trying to install RS on Vista. I notice that the list of IIS features to turn on, listed in the KB article and blog entries, mentions a "Windows Authentication" IIS feature to check under Security. I don't have that (although I have one labeled "Basic Authentication") -- I'm on a "workgroup" computer at home.
     
    Does this mean that you simply can't install RS on Vista unless you're joined to a domain? Thanks,
     
    -Doug
     
    Saturday, March 03, 2007 7:03 PM

Answers

  • The issue is not which options are supported by RS, but which options allow SQL Setup to detect the presence of IIS 7 successfully, as a pre-condition to installing RS.

    I have since discovered my answer, though it's an annoying and ironic one: IIS 7 does not support Windows Authentication in Windows Home Premium Edition. Therefore RS cannot be installed. Windows Authentication is one of the requirements for SQL Setup to detect IIS successfully.

    What's in IIS 7 by Vista edition: http://www.iis.net/default.aspx?tabid=2&subtabid=25&i=1100

    What SQL Setup needs to detect IIS: http://support.microsoft.com/kb/920201/en-us

    Rationale: "The IIS 7 role on the Windows Vista Home Premium Edition is to support the needs of the casual or hobbyist web developers; as such the majority of the IIS 7 Web Server features required for web site development are available. Features not normally associated with hobbyist web development such as FTP server, advanced Web authentication and authorization, and remote administration are not available on the Vista Home Premium Edition."

    -Doug

     

    Monday, March 05, 2007 5:29 PM

All replies

  • You an use Basic Authentication. Windows Auth is more secure and the suggested auth type. You do not need to be joined to a domain to install RS.
    Monday, March 05, 2007 4:58 PM
    Moderator
  • The issue is not which options are supported by RS, but which options allow SQL Setup to detect the presence of IIS 7 successfully, as a pre-condition to installing RS.

    I have since discovered my answer, though it's an annoying and ironic one: IIS 7 does not support Windows Authentication in Windows Home Premium Edition. Therefore RS cannot be installed. Windows Authentication is one of the requirements for SQL Setup to detect IIS successfully.

    What's in IIS 7 by Vista edition: http://www.iis.net/default.aspx?tabid=2&subtabid=25&i=1100

    What SQL Setup needs to detect IIS: http://support.microsoft.com/kb/920201/en-us

    Rationale: "The IIS 7 role on the Windows Vista Home Premium Edition is to support the needs of the casual or hobbyist web developers; as such the majority of the IIS 7 Web Server features required for web site development are available. Features not normally associated with hobbyist web development such as FTP server, advanced Web authentication and authorization, and remote administration are not available on the Vista Home Premium Edition."

    -Doug

     

    Monday, March 05, 2007 5:29 PM
  • I spent so much time on the internet trying to find a way round for enable Wndows Authentication on Windows Vista Home Premium Edition, but it seems that the solution doesn't exist.

    I am Microsoft based .NET developer and I just purchased a laptop with Windows Vista Home Premium Edition and I have installed Visual Studio .NET 2003 and 2005 and SQL Server 2005.

    Visual Studio 2005 works fine.

    Visual Studio 2003 is a problem. You are unable to run a project, a pop up message appears saying Integrated Windows Authentication is not enabled. But if you have other higher Vista version like Business, you will need to do a sequence of tasks in order to work, but eventually, will work.

    You find the procedure here:

    http://blogs.iis.net/brian-murphy-booth/archive/2007/03/09/how-to-setup-asp-net-v1-1-visual-studio-net-2003-projects-on-iis7-vista.aspx

     One more thing. You can run a project pressing CTRL+F5 (without debugging) and then you attach the debugger manually: Menu Debug -> Processes -> Attach the w3wp.exe type .NET, Win32 and then you can debug. But it is a pain to attach this process everytime you need to debug. But at least, you can do it.

    Resume. If you need to run Visual Studio 2003 on Vista Home Premium you have 3 options. Either you downgrade to XP or upgrade to Business or higher, or you attach the debugger every time you debug.

    Saturday, December 08, 2007 8:20 PM
  • I also was very disappointed to recently find out that you cannot run SQL Server 2005 Reporting Services on a machine running Vista Home Premium.  I certainly wish that this was more clear in the literature for the products.

     

    Is it true what I have read that SQL Server 2008 Reporting Services will not require IIS at all?  Does this then mean that you will be able to run the SQL Server 2008 Reporting Services on a machine running Vista Home Premium???

    Monday, December 10, 2007 12:57 AM
  • Did you guys find out how to install sql server 2005 on windows vista home premium edition as it also needs IIS7 windows authentication which is not there in this version of windows..

     

    Swamp55 did you get the solution of installing sql server 2005  on your laptop i am facing with the same problem...

    Sunday, March 09, 2008 6:01 AM
  • wahab,

     

    No, unfortunately, I do not have a solution to the problem we both face.  I had resigned myself to waiting until SQL Server 2008 came out (originally scheduled for February, 2008).  Now, I understand that SQL Server 2008 will been delayed until the 3rd quarter of this year.  So, I am still using my old laptop that runs Windows XP whenever I need to work with Reporting Services.

     

    Shame on Microsoft for making all of the Vista Home Premium machines into boat anchors when it comes to Reporting Services!

     

    Monday, March 10, 2008 2:19 AM
  • Dear,

            I just want to install the database, I dont want any reporting services..can i install that on vista...

    Monday, March 10, 2008 4:40 AM
  • How to Configure Windows Authentication on Windows Vista Premium


    Step 1: Turn ON All Windows Features at Programs and Features in Control Panel:
    ---------------------------------------------------------------------------------------

    Or at Least Those related with Internet Information Services,
    in alternative run the following command

    start /w pkgmgr
    /iu:IIS-WebServerRole;IIS-WebServer;IIS-CommonHttpFeatures;IIS-StaticContent;IIS-DefaultDocument;IIS-DirectoryBrowsing;IIS-HttpErrors;IIS-HttpRedirect;IIS-ApplicationDevelopment;IIS-ASPNET;IIS-NetFxExtensibility;IIS-ASP;IIS-CGI;IIS-ISAPIExtensions;IIS-ISAPIFilter;IIS-ServerSideIncludes;IIS-HealthAndDiagnostics;IIS-HttpLogging;IIS-LoggingLibraries;IIS-RequestMonitor;IIS-HttpTracing;IIS-CustomLogging;IIS-Security;IIS-BasicAuthentication;IIS-URLAuthorization;IIS-RequestFiltering;IIS-IPSecurity;IIS-Performance;IIS-HttpCompressionStatic;IIS-HttpCompressionDynamic;IIS-WebServerManagementTools;IIS-ManagementConsole;IIS-ManagementScriptingTools;IIS-ManagementService;IIS-IIS6ManagementCompatibility;IIS-Metabase;IIS-WMICompatibility;IIS-LegacyScripts;IIS-LegacySnapIn;WAS-WindowsActivationService;WAS-ProcessModel;WAS-NetFxEnvironment;WAS-ConfigurationAPI


    Step 2: Check for available files:
    ---------------------------------------------------------------------------------------

    (The Basic Authentication is available here to guidance,
     if file don't exist you must get it from another version of vista)

    - Basic Authentication  (needs C:\Windows\System32\inetsrv\authbas.dll)
    - Windows Authentication (needs C:\Windows\System32\inetsrv\authsspi.dll)
    - Digest Authentication (needs C:\Windows\System32\inetsrv\authmd5.dll)
    - IISCertificateMapping Authentication (needs C:\Windows\System32\inetsrv\authmap.dll)
    - CertificateMapping Authentication (needs C:\Windows\System32\inetsrv\authcert.dll)


    Step 3: Enable Registry Entries for:
    ---------------------------------------------------------------------------------------

    Check if exists and change or create the keys:

    (You must take ownership of this key as administrators group and give it full permissions,
     at the end restore the ownership to NT SERVICE\TrustedInstaller and the permissions changed)


    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\InetStp\Components]
    "BasicAuthenticationBinaries"=dword:00000001
    "BasicAuthentication"=dword:00000001
    "WindowsAuthenticationBinaries"=dword:00000001
    "WindowsAuthentication"=dword:00000001
    "DigestAuthentication"=dword:00000001
    "IISCertificateMappingAuthentication"=dword:00000001
    "ClientCertificateMappingAuthentication"=dword:00000001


    step 4: Change C:\Windows\System32\inetsrv\config\applicationHost.config
    --------------------------------------------------------------------------------------

    Check if exists and change or create the keys:


                <authentication>

                ...

                    <basicAuthentication enabled="false" />

                    <windowsAuthentication enabled="false">
                        <providers>
                            <add value="Negotiate" />
                            <add value="NTLM" />
                        </providers>
                    </windowsAuthentication>

                    <digestAuthentication enabled="false" />

                    <iisClientCertificateMappingAuthentication enabled="false">
                    </iisClientCertificateMappingAuthentication>

                    <clientCertificateMappingAuthentication enabled="false" />

                ...

                </authentication>

     

            <globalModules>

                ...

                <add name="BasicAuthenticationModule" image="%windir%\System32\inetsrv\authbas.dll" />
                <add name="WindowsAuthenticationModule" image="%windir%\System32\inetsrv\authsspi.dll" />
                <add name="DigestAuthenticationModule" image="%windir%\System32\inetsrv\authmd5.dll" />
                <add name="IISCertificateMappingAuthenticationModule" image="%windir%\System32\inetsrv\authmap.dll" />
                <add name="CertificateMappingAuthenticationModule" image="%windir%\System32\inetsrv\authcert.dll" />

                ...

            </globalModules>


    step 5: Change C:\Windows\System32\inetsrv\config\schema\IIS_schema.xml
    --------------------------------------------------------------------------------------

    Check if exists and change or create the keys:

    (You must take ownership of this key as administrators group and give it full permissions,
     at the end restore the ownership to NT SERVICE\TrustedInstaller and the permissions changed)

     

      <sectionSchema name="system.webServer/security/authentication/windowsAuthentication">
        <attribute name="enabled" type="bool" defaultValue="false" />
        <element name="providers">
          <collection addElement="add" clearElement="clear" removeElement="remove">
            <attribute name="value" type="string" isUniqueKey="true" />
          </collection>
        </element>
        <attribute name="authPersistSingleRequest" type="bool" defaultValue="false" />
        <attribute name="authPersistNonNTLM" type="bool" defaultValue="false" />
        <attribute name="useKernelMode" type="bool" defaultValue="true" />
        <attribute name="useAppPoolCredentials" type="bool" defaultValue="false" />
      </sectionSchema>

    • Proposed as answer by Kobojunkie Thursday, May 07, 2009 3:50 AM
    Wednesday, April 23, 2008 6:21 PM
  • Hi AntonioCosta,

     

    I had also problem , as discussed .i am not getting option of windows authentication.This means i not able to install reporting service on vista homr premium edition.

    I gone through the solution you had provided. How do i get those dll

    http://www.windll.com/library-a_1900.php

    through this site it is not freely available, i have to pay..for those dll.

    do u have such dll free of coast? 

     

     AntonioCosta wrote:

    How to Configure Windows Authentication on Windows Vista Premium


    Step 1: Turn ON All Windows Features at Programs and Features in Control Panel:
    ---------------------------------------------------------------------------------------

    Or at Least Those related with Internet Information Services,
    in alternative run the following command

    start /w pkgmgr
    /iu:IIS-WebServerRole;IIS-WebServer;IIS-CommonHttpFeatures;IIS-StaticContent;IIS-DefaultDocument;IIS-DirectoryBrowsing;IIS-HttpErrors;IIS-HttpRedirect;IIS-ApplicationDevelopment;IIS-ASPNET;IIS-NetFxExtensibility;IIS-ASP;IIS-CGI;IIS-ISAPIExtensions;IIS-ISAPIFilter;IIS-ServerSideIncludes;IIS-HealthAndDiagnostics;IIS-HttpLogging;IIS-LoggingLibraries;IIS-RequestMonitor;IIS-HttpTracing;IIS-CustomLogging;IIS-Security;IIS-BasicAuthentication;IIS-URLAuthorization;IIS-RequestFiltering;IIS-IPSecurity;IIS-Performance;IIS-HttpCompressionStatic;IIS-HttpCompressionDynamic;IIS-WebServerManagementTools;IIS-ManagementConsole;IIS-ManagementScriptingTools;IIS-ManagementService;IIS-IIS6ManagementCompatibility;IIS-Metabase;IIS-WMICompatibility;IIS-LegacyScripts;IIS-LegacySnapIn;WAS-WindowsActivationService;WAS-ProcessModel;WAS-NetFxEnvironment;WAS-ConfigurationAPI


    Step 2: Check for available files:
    ---------------------------------------------------------------------------------------

    (The Basic Authentication is available here to guidance,
     if file don't exist you must get it from another version of vista)

    - Basic Authentication  (needs C:\Windows\System32\inetsrv\authbas.dll)
    - Windows Authentication (needs C:\Windows\System32\inetsrv\authsspi.dll)
    - Digest Authentication (needs C:\Windows\System32\inetsrv\authmd5.dll)
    - IISCertificateMapping Authentication (needs C:\Windows\System32\inetsrv\authmap.dll)
    - CertificateMapping Authentication (needs C:\Windows\System32\inetsrv\authcert.dll)


    Step 3: Enable Registry Entries for:
    ---------------------------------------------------------------------------------------

    Check if exists and change or create the keys:

    (You must take ownership of this key as administrators group and give it full permissions,
     at the end restore the ownership to NT SERVICE\TrustedInstaller and the permissions changed)


    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\InetStp\Components]
    "BasicAuthenticationBinaries"=dword:00000001
    "BasicAuthentication"=dword:00000001
    "WindowsAuthenticationBinaries"=dword:00000001
    "WindowsAuthentication"=dword:00000001
    "DigestAuthentication"=dword:00000001
    "IISCertificateMappingAuthentication"=dword:00000001
    "ClientCertificateMappingAuthentication"=dword:00000001


    step 4: Change C:\Windows\System32\inetsrv\config\applicationHost.config
    --------------------------------------------------------------------------------------

    Check if exists and change or create the keys:


                <authentication>

                ...

                    <basicAuthentication enabled="false" />

                    <windowsAuthentication enabled="false">
                        <providers>
                            <add value="Negotiate" />
                            <add value="NTLM" />
                        </providers>
                    </windowsAuthentication>

                    <digestAuthentication enabled="false" />

                    <iisClientCertificateMappingAuthentication enabled="false">
                    </iisClientCertificateMappingAuthentication>

                    <clientCertificateMappingAuthentication enabled="false" />

                ...

                </authentication>

     

            <globalModules>

                ...

                <add name="BasicAuthenticationModule" image="%windir%\System32\inetsrv\authbas.dll" />
                <add name="WindowsAuthenticationModule" image="%windir%\System32\inetsrv\authsspi.dll" />
                <add name="DigestAuthenticationModule" image="%windir%\System32\inetsrv\authmd5.dll" />
                <add name="IISCertificateMappingAuthenticationModule" image="%windir%\System32\inetsrv\authmap.dll" />
                <add name="CertificateMappingAuthenticationModule" image="%windir%\System32\inetsrv\authcert.dll" />

                ...

            </globalModules>


    step 5: Change C:\Windows\System32\inetsrv\config\schema\IIS_schema.xml
    --------------------------------------------------------------------------------------

    Check if exists and change or create the keys:

    (You must take ownership of this key as administrators group and give it full permissions,
     at the end restore the ownership to NT SERVICE\TrustedInstaller and the permissions changed)

     

      <sectionSchema name="system.webServer/security/authentication/windowsAuthentication">
        <attribute name="enabled" type="bool" defaultValue="false" />
        <element name="providers">
          <collection addElement="add" clearElement="clear" removeElement="remove">
            <attribute name="value" type="string" isUniqueKey="true" />
          </collection>
        </element>
        <attribute name="authPersistSingleRequest" type="bool" defaultValue="false" />
        <attribute name="authPersistNonNTLM" type="bool" defaultValue="false" />
        <attribute name="useKernelMode" type="bool" defaultValue="true" />
        <attribute name="useAppPoolCredentials" type="bool" defaultValue="false" />
      </sectionSchema>

    Sunday, April 27, 2008 7:10 AM
  •  

    If u only need windows authentication then the authsspi.dll should be in the %windir%\System32\inetsrv directory, my solution is for activate all the authentications not suported by windows vista home premium, u must ignore the keys to other authentications if u don't need it, users can activate only the authentications needed, the basic authentication is the only one of these autentications supported, it is here only to permit find the place to insert the new keys.
    • Proposed as answer by Kobojunkie Thursday, May 07, 2009 3:49 AM
    Monday, April 28, 2008 9:50 AM
  •  

    Thanks Anonio. Your solution worked.

     

    Note if you wish to try this and cannot do step 2: On Vista Home, you need to unhide the Administrator user via a command prompt started as Administrator (Start - Accesories - Right-click on command prompt) in which you type "net user Administrator /active:yes". You must then log off and and log in as the Administrator (the account appears once you log off), start regedit, go to the key, right-click and change the permission - ownership to the Administrator, give it full rights and you can then create the subkeys required.

    Monday, May 12, 2008 4:31 PM
  • Antonio you are a genius and a life-saver!

     

    Kudos,

     

    Dave

    Sunday, October 05, 2008 5:43 PM
  • Hello,

    I just see your post and I had the same problem.
    In the Step 3, with the regedit command, I saw that I didn't have the "WindowsAuthentication"=dword:00000001.
    I tried to registry it (I checked I had
    C:\Windows\System32\inetsrv\authsspi.dll), and when I execute regsvr32 C:\Windows\System32\inetsrv\authsspi.dll, I had the message (I translate from french). The authsspi.dll has been downloaded but the point of entry DllRegisterServer is undiscoverable. Check that authsspi.dll is a vlaid DLL or OCX and try again.

    But it doesn't work. I am administrator of my computer but nothing change

    Thanks for yours answers
    Friday, October 16, 2009 11:24 AM
  • Antonio....YOU ROCK!!!! Thanks thanks thanks
    Wednesday, November 11, 2009 6:18 AM
  • I did all the steps and passed the IIS issue but when I continue to set up, there is no setup for reporting service.
    I already unhide advance setup.
    Please help.

    Thanks
    Wednesday, January 27, 2010 10:11 AM
  • Hi antonio,

                  I had same problem in my windows 7 home premium.I didn't find the windows authentication in my iis7.

                  Actually im trying to install microstrategy(datawarehousing tool) in my lp.

    but it shows the error like missing windows authentication in iis/worldwidewebservices/security/windows authentication.

    hope u help me.

    thanks &regards,

    ravipati.

    Monday, December 13, 2010 8:03 AM
  • Thanks a lot Antonio....you rock....it was kinda a bumpy ride to get IIS working on Windows Home 7 Premium but you finally made it working.....

     

    if after following Antonio's steps you still can't access http://localhost/reportserver then try playing around with it....search for the errors..you are almost there just a few modifications..at last i had one small pblm accessing reportserver and this post helped me:

    http://social.msdn.microsoft.com/forums/en-US/sqlreportingservices/thread/269ac8da-d3fe-4c2d-a586-272c39aaaa62/?prof=required -- go to Sandeep's post and follow that..

    Thanks Antonio again

    Friday, March 25, 2011 9:39 PM