none
Update Sql CE 3.5 db to 4.0

    Question

  • Hi all

        do you know if it is possible, and if yes how, to update a 3.5 db to ver 4.0

    regards


    GP
    Friday, March 11, 2011 8:37 PM

Answers

All replies

  • Yes, you can use the Visual Studio SQL Server Compact 4.0 Tools, the SqlCeEngine.Upgrade api, or my SQL Server Compact Toolbox add-in: http://sqlcetoolbox.codeplex.com
    Visit my SQL Server Compact blog - Please mark as answer, if this was it.
    Saturday, March 12, 2011 10:18 AM
    Moderator
  • Hi Erik

        do you mean using that tool to generate script for both table creation and data insert??

    regards

    gps...


    GP
    Saturday, March 12, 2011 11:20 AM
  • Yes, or use the "Add 4.0 connection" dialog, it will offer to Upgrade a 3.x database file.
    Visit my SQL Server Compact blog - Please mark as answer, if this was it.
    Saturday, March 12, 2011 1:10 PM
    Moderator
  • Hi,

    I tried using the SQLCEToolbox utility and Add 4.0 connection. If I choose a 3.5 database it gives me an error and asks me to use SQLCeEngine.Upgrade and does not offer to upgrade the database.

    Note: I do not have SQL CE 3.5 installed, only SQL CE 4.0...

    Rgds,

    Anand


    Regards, Anand Mukundan http://www.dotnetindia.com
    Tuesday, March 15, 2011 7:07 PM
  • Hi Anand,

    It sounds like you are not running the latest version of the SQL Compact Toolbox (2.0.0.4 or later) !?


    Visit my SQL Server Compact blog - Please mark as answer, if this was it.
    Tuesday, March 15, 2011 8:20 PM
    Moderator