none
Cannot connect to SQL Express Remotely

    Question

  • I have SQL Express April CTP (from VS Beta 2) installed on machineA, but I cannot connect to it from machineB using the command "sqlcmd -S machineA\sqlexpress -E".  This command works just fine from machineA.

    I have enabled the TCP/IP protocol for the SQLExpress instance through the configuration manager, and turned off the Windows Firewall on machineA.

    Any ideas on what I'm doing wrong?
    Wednesday, May 18, 2005 10:50 PM

Answers

All replies

  • Hi Michael,

    By default network protocols (TCP/IP, named pipe) are disabled for SQL Server Express Editions.

    You can use SQL Server configuration manager tool to Enable the server protocols on which the instance of SQL Server will listen.

    hope this is helpful...

    thanks..
    Rajesh
    Thursday, May 19, 2005 2:25 AM
  • Thanks Euan -- That did the trick!
    Thursday, May 19, 2005 2:08 PM
  • Hi,

    I have the same problem, I cannot connect remotely to sql server express

    I have done all the steps in that article http://blogs.msdn.com/sqlexpress/archive/2005/05/05/415084.aspx

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;914277

    but still not working remotely although locally is ok

    I have tried also on domain lan and on workgroup lan

    On domain, on different client computers with different domain users I received different error messages:

    ...login failed for user. the user is not asociated with a trusted sql server conenction...
    or
    ...When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections ... error locating server..
    or
    ...When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections ... login failed...

    I am connectiong to my_machine\SQLEXPRESS with windows authentication, same as on the server machine

    I cannot figure out what should be the problem, any help would be apreciated.

    Thank you for your time.
    Corina
    Thursday, October 19, 2006 8:19 AM