none
Reporting Server Denial of Service Warning

    Question

  • I'm getting the warning below on my SQL Reporting Server. The IP address is our F5 load balancer that sits in front of the server. Is there a way to change the value of what Report Server thinks is a denial of service attack or disable it all together?

    The report server has detected a possible denial of service attack. The report server is dropping requests for service from x.x.x.x

    Thanks,

    Scott

    Wednesday, May 11, 2011 7:35 PM

Answers

  • Hi Scott,

     

    Some one told me about that:

    If the number of connections from
    the same user exceeds the maximum allowed number of concurrent connections from one
    user, the SSRS will not handle new requests and it will wait until existing
    requests have terminated. This condition can be met easily if for example the
    RainbowPRD was using the same account to connect to the SSRS service or if one user
    would perform operations exceeding the maximum number permitted.

    To address this, we have the possibility to increase this value, mentioned above,
    for the maximum number of concurrent connections from one user. This parameter is
    called MaxActiveReqForOneUser and is configurable in the RSReportServer.config.

    So, open the RSReportServer.config file in D:\PROGRAM FILES\MICROSOFT SQL
    SERVER\MSSQL.2\REPORTING SERVICES\Report Server\ and locate the element
    <Add Key="MaxActiveReqForOneUser" Value="20"/>
    Change the value of this parameter from 20 (the default value ) to a number that
    corresponds to your requirements.

     

    Hope this helps.

     

    Regards,

    Albert Ye

    Thursday, May 12, 2011 6:47 AM