none
Subscription Error: "The e-mail address of one or more recipients is not valid."

    Question

  • I have subscriptions that fail because someone's email is no longer valid,
    where is this error information stored so I can fix the problem?
    I have a large list and it is hard to do manually.
    I will be using data driven solutions, but these are existing subscriptions that need to be ran.
    Wednesday, September 20, 2006 6:50 PM

Answers

  • Hello

     

    It appears i have just answered my own problem. All tested and worked just fine. After making the changes to the config file above, the SMTP server required permissions to be granted to allow the report server to relay through it. These settings were set on the "properties" of the Default SMTP Virtual Server under SMTP Protocols in the Exchange System Manager.

     

    Cheers

    Wednesday, April 02, 2008 2:03 AM
  • I have seen this error before, but I do not think it has anything to do with whether or not an email address is still valid.

    What I think is happening is that you have e-mail addresses that are incorrectly formatted or even NULL.  If you are pulling your e-mail addresses from a database, and the report comes across a NULL, I have seen in it break.

    As far as the error logs are concerned, it depends on what platform you are using.  On my server (RS 2005), the log files are here:  \\[SERVERNAME]\c$\program files\Microsoft SQL Server\MSSQL.2\Reporting Services\LogFiles.

    First, check your e-mail addresses for formatting.  Good luck.

    Wednesday, September 20, 2006 11:56 PM
  • I also ran into the same problem.  In addition to changing the <SendEmailToUserAlias> in the config file, I had to enable "email relay" on my SMTP server for my Reporting Services server
    Tuesday, June 26, 2007 7:22 PM
  • You open up Exchange Systems Manager client application on your mail server, you than locate SMTP node under the protocols section of the tree node then go to Defaullt SMTP Virtual Server  - right click ...Properties-----in the Properties dialog box go to the  Access tab then go to the Relay Section and supply sql report server IP address - and there you Go !!! Hope this helpfull ... it worked...
    Friday, March 12, 2010 1:37 PM
  • Fought this issue for a while, so wanted to report back the fix for my system.
    Mine ended up being an Exchange-Authentication problem.. here's the Exchange Powershell script to fix it:

    Get-ReceiveConnector "Local Relay" | Add-ADPermission -User "NT Authority\ANONYMOUS LOGON" -ExtendedRights "ms-Exch-SMTP-Accept-Any-Recipient"

    And then just Restart Service "Microsoft Exchange Transport" to seal the deal.
    After that SSRS could send emails to external users.

    Tuesday, September 06, 2011 7:20 PM

All replies

  • I have seen this error before, but I do not think it has anything to do with whether or not an email address is still valid.

    What I think is happening is that you have e-mail addresses that are incorrectly formatted or even NULL.  If you are pulling your e-mail addresses from a database, and the report comes across a NULL, I have seen in it break.

    As far as the error logs are concerned, it depends on what platform you are using.  On my server (RS 2005), the log files are here:  \\[SERVERNAME]\c$\program files\Microsoft SQL Server\MSSQL.2\Reporting Services\LogFiles.

    First, check your e-mail addresses for formatting.  Good luck.

    Wednesday, September 20, 2006 11:56 PM
  • I am facing the same problem. Do not know the workaround yet.

    The additional Observation I have done is:

    * It validates and send to all the Ids which are NOT a public mail domain. e.g. <Name>@<MyCompanyName.com>

    * If I try to send the report to <name>@rediffmail.com OR <name>@gmail.com, I get this error.

    Any workaround?

     

     

     

    Monday, October 16, 2006 8:18 AM
  • P Joshi,

     

    Did you ever find a work-around?  I am experiencing the exact symptoms as you.  Only my company's domain is permitted ... all others raise this error.  My problem is that my company has several subsidiaries with different domain names.

     

    Bobby

    Wednesday, April 25, 2007 1:52 PM
  • The PermittedHosts setting in the rsreportserver.config file that allows you to control to which host names you are allowed to send email.   Check to see if it is set (it is not set by default).  If it is not, then any host is allowed by the report server.  In this case, you should talk with your SMTP server admin about which addresses are allowed.

     

    Here are the docs for the config settings:

    http://msdn2.microsoft.com/en-us/library/ms157273.aspx

     

    -Lukasz

     

     

    Wednesday, April 25, 2007 4:03 PM
    Moderator
  • i changed the permittedHosts in rsreportserver.comfig to
    <PermittedHosts>
       <HostName>xxx.be</HostName>
       <HostName>hotmail.com</HostName>
    </PermittedHosts>

    but i still have the problem that i can only send email to my xxx.be company-mailadress, but to my hotmail.com address it keeps on saying "
    The e-mail address of one or more recipients is not valid."

    anyone found the solution meanwhile??????
    Tuesday, May 22, 2007 1:58 PM
  • Check the <SendEmailToUserAlias> element in the config file.  If it is set to True, you will need to set it to False.  This will allow your users to type a fully qualified email address when they create subscriptions.  The default prevents users of standard subscription from typing the domain name when specifying their email addresses. 

     

    Hope that helps,

    -Lukasz

    Tuesday, May 22, 2007 4:55 PM
    Moderator
  • I also ran into the same problem.  In addition to changing the <SendEmailToUserAlias> in the config file, I had to enable "email relay" on my SMTP server for my Reporting Services server
    Tuesday, June 26, 2007 7:22 PM
  • Where exactly did you enable "email relay"?  I have a 2007 Exchange Server and I can't find the relays like in Exchange 2003.  I have the same problem.  It only happens when I try to send outside of the organization.

    • Proposed as answer by Vuyo Soci Friday, March 12, 2010 1:26 PM
    Thursday, August 02, 2007 1:42 AM
  • Hi, has anyone had any further luck with this article? We are using Server 2003 with Exhange and I have the same issue and have adjusted the rsreportserver.config file as per below:

     

    <SendEmailToUserAlias>False</SendEmailToUserAlias>
    <DefaultHostName></DefaultHostName>
    <PermittedHosts>
    <HostName>hotmail.com</HostName>
    </PermittedHosts>

     

    I am still receiving the same error as the subject shows. Any further suggestions would be greatly appreciated.

     

    Cheers

    Thursday, March 27, 2008 1:58 AM
  • Hello

     

    It appears i have just answered my own problem. All tested and worked just fine. After making the changes to the config file above, the SMTP server required permissions to be granted to allow the report server to relay through it. These settings were set on the "properties" of the Default SMTP Virtual Server under SMTP Protocols in the Exchange System Manager.

     

    Cheers

    Wednesday, April 02, 2008 2:03 AM
  • Hi,

     

    Can you possibly expand on this?

     

    The Relay restrictions on the Exchange server has a box ticked to say, "Allow all computers which successfully authenticate ....."

     

    Shouldn't this allow Report Server to work anyway? My Report Server is part of the company domain.

     

    Cheers. 

     

    Tuesday, April 08, 2008 8:48 AM
  • ..... It might also be worth mentioning that I can successfully send external email directly from SQL Server Management Studio by right-clicking on Database Mail and sending a test. This is using the exact SMPT server as Report Services.

     

    Cheers.

     

    Tuesday, April 08, 2008 9:01 AM
  • Hi

     

    To answer your first question, I orginally had the domain entered in this field, ie; domain.local. one would would think this would allow servers on the domain to relay through the SMTP server but that wasn't the case. By entering the IP address of the report server, this did end up allowing the message to pass through. Hopefully that answers that one.

     

    Cheers

    Thursday, April 10, 2008 8:32 AM
  • Hi,

     

    My system manager has just pointed out that we are using DHCP instead of static IP addresses for all our servers. He has asked for this to be taken into consideration as there is no guarantee that the IP addresses will not be refreshed.

     

    The solution in the above post worked fine for me (thanks again) but unfortunately there doesn't appear to be any DHCP option in the Relay dialog on our SMTP server. Should there be a provision for this somewhere?

     

    Thanks,

    Elracorey.

     

    Monday, June 30, 2008 12:48 PM
  • Hi Elracorey

     

    Sorry for the late response. Unfortunately i no longer work for that organisation. i can however tell you that the network there was also DHCP. During my reasearch into that, i saw no consideration given to this and once I found that by entering the IP address actually fixed the issue I didn't look any further.

     

    Cheers

    Thursday, July 17, 2008 8:46 AM
  • Its working cool once We Setup this:

    Cheers ukboy

     

    Log into Exchange 2003 server (mailserverName) and start Exchange System Manager.

    Expand the organization_name object, and then expand the Servers node. Expand the server_name object of the server on which you want to control mail relay (mailserverName) , and then expand the Protocols node.

    Expand the SMTP node, right-click the virtual SMTP server on which you want to control mail relay (mailserverName), and then click Properties

    Click Relay.

    Click Add. Enter the IP address(111.111.1.80).

    In the Relay Restrictions dialog box, click OK.

    Click Apply, and then click OK in the Default SMTP Virtual Server Properties dialog box.

     

    <SendEmailToUserAlias>False</SendEmailToUserAlias>

    <DefaultHostName></DefaultHostName>

    <PermittedHosts>

    <HostName>xxx.com</HostName>

    <HostName>yyyy.com</HostName>

    <HostName>hhhh.com</HostName>

    <HostName>ttt.com</HostName>

    </PermittedHosts>

     

    You must restart the SSRS Service once you done all the above setup.

    Raj
    Sunday, July 27, 2008 10:29 PM
  •  hey001us wrote:

    Its working cool once We Setup this:

    Cheers ukboy

     

    Log into Exchange 2003 server (mailserverName) and start Exchange System Manager.

    Expand the organization_name object, and then expand the Servers node. Expand the server_name object of the server on which you want to control mail relay (mailserverName) , and then expand the Protocols node.

    Expand the SMTP node, right-click the virtual SMTP server on which you want to control mail relay (mailserverName), and then click Properties

    Click Relay.

    Click Add. Enter the IP address(111.111.1.80).

    In the Relay Restrictions dialog box, click OK.

    Click Apply, and then click OK in the Default SMTP Virtual Server Properties dialog box.

     

    <SendEmailToUserAlias>False</SendEmailToUserAlias>

    <DefaultHostName></DefaultHostName>

    <PermittedHosts>

    <HostName>xxx.com</HostName>

    <HostName>yyyy.com</HostName>

    <HostName>hhhh.com</HostName>

    <HostName>ttt.com</HostName>

    </PermittedHosts>

     

    You must restart the SSRS Service once you done all the above setup.

    Raj

     

    Do you know how to set this up in Exchange 2007?  We set relaying, but it was a different configuration than above.  I have everything set with permitted hosts as stated in your message, but we still have that problem.

     

    Also, did anybody have to set the SMTPServerPort, SMTPAccountName, SMTPConnectionTimeout, SMTPServerPickupDirectory, SMTPUseSSL, or SMTPAuthenticate fields?  We are able to send emails internally, but not externally.

    Tuesday, July 29, 2008 3:24 PM
  • You open up Exchange Systems Manager client application on your mail server, you than locate SMTP node under the protocols section of the tree node then go to Defaullt SMTP Virtual Server  - right click ...Properties-----in the Properties dialog box go to the  Access tab then go to the Relay Section and supply sql report server IP address - and there you Go !!! Hope this helpfull ... it worked...
    Friday, March 12, 2010 1:37 PM
  • Isn't this strange behavior.I am able to send external mails  from 'send test mail' functionality built in Database Mail in sql 2008 but from reportserver it says invalid email address.If the exchange server was the culprit,even the database mail should not have worked for external mails.

     

    Can someone from Microsoft support give some inputs.

     

    thanks

    chandan

    Friday, March 11, 2011 9:48 AM
  • Fought this issue for a while, so wanted to report back the fix for my system.
    Mine ended up being an Exchange-Authentication problem.. here's the Exchange Powershell script to fix it:

    Get-ReceiveConnector "Local Relay" | Add-ADPermission -User "NT Authority\ANONYMOUS LOGON" -ExtendedRights "ms-Exch-SMTP-Accept-Any-Recipient"

    And then just Restart Service "Microsoft Exchange Transport" to seal the deal.
    After that SSRS could send emails to external users.

    Tuesday, September 06, 2011 7:20 PM
  • Thank you simp1eton! After having to migrate to a new exchange server our SRSS box would not sent email to external addresses. I checked and rechecked the SMTP auth settings in the Exchange console but this shell command did the trick. I executed the command then restarted the service and the emails went right out.
    Tuesday, March 13, 2012 5:14 PM