none
Cannot start "SQL Server Agent" service from SQL Server Configuration Manager. ERROR: "The remote procedure call failed".

    Question

  • Im trying to start SQL Server Agent. I first tried to start it from SQL Server Management Studio by right-clicking on the SQL Server Agent Node of my local server. Only to find out, there isn't a SQL Server Agent node using Management Studio. It's missing.

    So then I launched SQL Server Configuration Manager. It does acknowledge the existence of the SQL Server Agent service as "SQL Server Agent(SQLEXPRESS) state:Stopped,  start mode:Other(Boot,System,Disabled, or Unknown)".

    I right-click the "SQL Server Agent(SQLEXPRESS)" service and select properties. I click on the Service tab and find "Start Mode". I try changing it to both Manual and Automatic and then I click "Apply" or "Ok". Attempting to set the "Start Mode" to either of these options results in the following error: WMI Provide Error: The remote procedure call failed (hexadecimal value).

    Please help. Thanks.



    System configuration: Winndows 7 RTM, Gigabyte GA-EP45-UD3L motherboard, Intel Pentium Dual-Core E6300 Wolfdale @ 2.8GHz, 4GB PC-1066 DDR2 Patriot Viper Memory, 500 GB Western Digital Hard Disk, GeForce 8800GT Videocard
    Monday, October 26, 2009 2:03 AM

Answers

  • Normally express edition do not ship SQL AGENT feature with it . This behaviour changed from sql 2008 express , even though AGENT service shows up in sql config manager for sql express 2008 ,the service is installed in a disabled state and will throw an error as in your case , if you try and start it manually. This is a change in behaviour from SQL 2005 Express Edition which did not create the SQL Agent service and is far from ideal and may be comfusing to customers as confirmed by Microsoft at this link https://connect.microsoft.com/SQLServer/feedback/ViewFeedback.aspx?FeedbackID=351806&wa=wsignin1.0 for this issue however it also won't be fixed in SQL 2008 express.

    SO DO NOT TRY START YOUR SQL AGENT if you are running express edition of sql 2008.

    Hope this helps.
    Thanks, Leks
    • Marked as answer by BradleyA Monday, October 26, 2009 8:06 AM
    Monday, October 26, 2009 6:07 AM
    Answerer

All replies

  • Normally express edition do not ship SQL AGENT feature with it . This behaviour changed from sql 2008 express , even though AGENT service shows up in sql config manager for sql express 2008 ,the service is installed in a disabled state and will throw an error as in your case , if you try and start it manually. This is a change in behaviour from SQL 2005 Express Edition which did not create the SQL Agent service and is far from ideal and may be comfusing to customers as confirmed by Microsoft at this link https://connect.microsoft.com/SQLServer/feedback/ViewFeedback.aspx?FeedbackID=351806&wa=wsignin1.0 for this issue however it also won't be fixed in SQL 2008 express.

    SO DO NOT TRY START YOUR SQL AGENT if you are running express edition of sql 2008.

    Hope this helps.
    Thanks, Leks
    • Marked as answer by BradleyA Monday, October 26, 2009 8:06 AM
    Monday, October 26, 2009 6:07 AM
    Answerer
  • Thank You very much for response. Yes, it helps. I already spent enough time trying to get it to work. I can now rest easy knowing this issue can be put to rest. I wish Microsoft could do something to make these type of things more obvious.

    System configuration: Winndows 7 RTM, Gigabyte GA-EP45-UD3L motherboard, Intel Pentium Dual-Core E6300 Wolfdale @ 2.8GHz, 4GB PC-1066 DDR2 Patriot Viper Memory, 500 GB Western Digital Hard Disk, GeForce 8800GT Videocard
    Monday, October 26, 2009 8:06 AM