none
Can't connect to SQL Server 2008 Reporting Services

    Question

  • When attempting to connect to SQL Server 2008 (evaluation) on Windows XP SP3, using the following url, http://servername:8080/ReportServer

    I receive a popup dialog box asking me for a user name and password to connect to the server.  When I enter the domain\user and password that I think it should be, it pops up two more times and then displays a blank internet explorer web page.  It is a fresh install and I believe I have everything running correctly.

     

    Any input or guidance would be extremely appreciated.

     

    Thank you in advance.

     

    Friday, September 05, 2008 1:01 AM

Answers

  • All,

     

    So... This is what I did.  I thought, if it can't authenticate with my admin user, maybe if I created a new user it would actually work correctly.  So I uninstalled the works, created a new user with user priv's assigned all SQL services in the setup to the newly created user and everything authenticated appropriately.

     

    I did this before I received the recommendation to change the authentication type.  So out of curiosity, I was going uninstall again, remove the previously created user and try changing the authentication type of the config file.  After; the install, prior to changing the config file, I attempted to connect to reportserver/reports.  As you may have guessed, it authenticated correctly.  I have no idea why...

     

    Thanks again for the suggestions.

     

    Take care.

    Saturday, September 06, 2008 1:41 PM

All replies

  • You might be running into the issue mentioned in this blog http://blogs.msdn.com/lukaszp/archive/2008/03/26/solving-the-reporting-services-login-issue-in-the-february-ctp-of-sql-server-2008.aspx

     

    Symptom:

    A) When you access report server or report manager, you get a login prompt multiple times and eventually you get a blank screen.

    B) When you try to publish reports/models from Business Intelligence Development studio, you get access denied errors.

    Solutions:

    1) Remove RSWindowsNegotiate and ensure RSWindowsNTLM is specified in the file rsreportserver.config

    2) OR, change the report server service account to Network Service

    3) OR, configure a specific hostheader for SSRS, configure your DNS server to understand that hostheader, and configure your domain controller to have an SPN for the hostheader and the report server service account.

     

     

     

    • Proposed as answer by belter Thursday, June 17, 2010 11:26 PM
    Friday, September 05, 2008 1:23 AM
    Moderator
  • It looks as though number 1 needs no change.  The file is as recommended.  Utilizing the 2nd suggestion, I did not recieve the login prompt, however, I was not able to connect. (Internet Explorer cannot display the webpage) and number 3 wasn't really attempted.

     

    Thanks for your suggestion.

    Friday, September 05, 2008 5:16 AM
  • First of all, you will hit this issue in the blog if you are running the Report Server service as a domain account.

    Can you provide update on which account are you using to run RS service (you can check this from Reporting Services configuration manager tool)

     

    Option 1 requires you to use NTLM instead of Negotiate. So if you had Negotiate authenticaiton mode in your rsreportserver.config, you should remove it.

     

    What exactly is the error are you seeing when you triedd option 2.

     

    Friday, September 05, 2008 6:34 AM
    Moderator
  • Hi Rokky,

     

    I have faced the same problem when I installed SQL Server and tried accessing the report manager or report server.

     

    I didn't find the solution to the problem, but I was able to access the report manager and report server by using the IP address in the URL instead of the server name. You could probably try this out.

     

    Regards,

    Friday, September 05, 2008 8:14 AM
  • Thanks for the response, but no luck.

    Friday, September 05, 2008 3:54 PM
  • I set it up with my main local user, so when I try to authenticate I use the following <computer name\user id>.  It is just  a local laptop install, so I don't believe the domain information would apply.

     

    From my  rsreportserver.config file:

     

    <Authentication>

    <AuthenticationTypes>

    <RSWindowsNTLM/>

    </AuthenticationTypes>

    <EnableAuthPersistence>true</EnableAuthPersistence>

    </Authentication>

     

    The word "Negotiate" was not found anywhere in the file.  I did not modify the file from the original iso image.

     

    Option two yields the same result as when i used <computer name\user id>, 3 pop-ups and then a blank screen.

     

    Thank you for your assistance.

    Friday, September 05, 2008 4:24 PM
  • Can you try basic authentication? Replace RSWindowsNTLM with RSWindowsBasic.

     

    Friday, September 05, 2008 9:41 PM
    Moderator
  • All,

     

    So... This is what I did.  I thought, if it can't authenticate with my admin user, maybe if I created a new user it would actually work correctly.  So I uninstalled the works, created a new user with user priv's assigned all SQL services in the setup to the newly created user and everything authenticated appropriately.

     

    I did this before I received the recommendation to change the authentication type.  So out of curiosity, I was going uninstall again, remove the previously created user and try changing the authentication type of the config file.  After; the install, prior to changing the config file, I attempted to connect to reportserver/reports.  As you may have guessed, it authenticated correctly.  I have no idea why...

     

    Thanks again for the suggestions.

     

    Take care.

    Saturday, September 06, 2008 1:41 PM
  • I am using Sql Server 2008 Reporting Services. 
    When you access report server or report manager, you get a login prompt multiple times and eventually you get a blank screen.
    sridhar
    Monday, February 23, 2009 8:40 PM
  • Hi All

    I am also having similar problems with accessing Report Manager.  Currently I have domain account as a Service Account setup.  And in the rsreportserver.config file I have removed RSWindowsNegotiat authenticatio.

    Is there any other option that I can possibly try?

    Thank you very much

    Jimit

    Friday, February 27, 2009 4:53 AM
  • I'm just chiming in here since Rokky's solution ended much frustration for me.  As he did, I simply created a new user account and added it to the default Users group as well as the 6 SQLServer groups:

    SQLServer2005SQLBrowserUser$computername,
    SQLServerFDHostUser$computername$sqlservername, SQLServerMSSQLServerADHelperUser$computername,
    SQLServerMSSQLUser$computername$sqlservername,
    SQLServerReportServerUser$computername$reportservername.sqlservername,
    SQLServerSQLAgentUser$computername$sqlservername

    I also changed the authentication type in rsreportserver.config to...

    <Authentication>
            <AuthenticationTypes>
                <RSWindowsNTLM/>
            </AuthenticationTypes>
            <EnableAuthPersistence>true</EnableAuthPersistence>
        </Authentication>

    Then ,through the Reporting Services Configuration Manager, I assigned the new user as the Service Account and Execution Account and assigned the Web Service URL and Report Manager URL using the server IP address.  Then I restarted the server and authentication worked.
    Wednesday, March 18, 2009 2:36 PM
  • I'm just chiming in here since Rokky's solution ended much frustration for me.  As he did, I simply created a new user account and added it to the default Users group as well as the 6 SQLServer groups:

    SQLServer2005SQLBrowserUser$computername,
    SQLServerFDHostUser$computername$sqlservername, SQLServerMSSQLServerADHelperUser$computername,
    SQLServerMSSQLUser$computername$sqlservername,
    SQLServerReportServerUser$computername$reportservername.sqlservername,
    SQLServerSQLAgentUser$computername$sqlservername

    I also changed the authentication type in rsreportserver.config to...

    <Authentication>
            <AuthenticationTypes>
                <RSWindowsNTLM/>
            </AuthenticationTypes>
            <EnableAuthPersistence>true</EnableAuthPersistence>
        </Authentication>

    Then ,through the Reporting Services Configuration Manager, I assigned the new user as the Service Account and Execution Account and assigned the Web Service URL and Report Manager URL using the server IP address.  Then I restarted the server and authentication worked.
    I have same problem and It worked with your Help. But, always user authentification is needed ? Any option to avoid user authentification ?


    Sorry by my bad English

    Thank you very much
    Tuesday, May 05, 2009 6:29 PM
  • I'm having a similar problem, but it's only for one user. I currently have the roles set up as Domain Users can Browse only. All other users in the company (that I know of) can access report manager just fine. This one new person can only access it if I add a role specifically for his username. He is part of "Domain Users".

    Thanks,

    Paul
    Monday, December 21, 2009 5:21 PM
  • had similar issues myself.

     Had to use the SETSPN utility to create a new HTTP entry for the domain account used by my RS service.
    created the plain & FQDN entries like below:

    setspn -A http/servername domain\myserviceacct
    setspn -A http/servername.domain.whatever domain\myserviceacct

    Before doing so, I was able to connect to the RS manager screen at http://servername/reports
    but couldn't do the same via. any remote client, using domain admin or otherwise.  I could see errors in my client's system log:
    Provider
          [ Name] Microsoft-Windows-Security-Kerberos
          [ Guid] {98E6CFCB-EE0A-41E0-A57B-622D4E1B30B1}
          [ EventSourceName] Kerberos
       
    - EventID 4
          [ Qualifiers] 16384
    • Proposed as answer by CommanderQ Wednesday, October 13, 2010 8:30 PM
    Monday, December 21, 2009 11:46 PM
  • Had the same problem i.e. could open Report Manager on the SSRS server but could not access it from another pc - login box, 3 tries, blank screen.  Tried every solution listed but nothing worked.  Even did a clean install of SQL 2008 R2. 

    Eventually found the setting 'Enable Integrated Windows Authentication*' on the client pc.  Ticked the box, restarted IE and it worked.

     

    Thursday, September 09, 2010 7:54 PM
  • I had same problem.

    Eventually solved it by removing host headers in Reporting Services Configuration Manager, setting unique port and connecting as http://localhost:8019 from the server (whilst using Run As Administrator and Trusted sites as described elsewhere in this thread).  I had to use main Administrator user.  Once I had set up logins in Report Manager I reinstated the host headers allowing remote access.

     

    Hope this saves people a few hours.

     

    Ian

     

    Thursday, September 16, 2010 9:32 AM
  • I had an issue with the report manager url returning 404 when only using the HTTP link. The HTTPS link worked just fine. Here's what I found.

    I was able to solve my issue of the Report Manager URL not working when using HTTP, but working using HTTPS. A netmon trace revealed that an HTTP 302 redirect request to the HTTPS page. I modified the rsreportserver.config file to update this line:

     <Add Key="SecureConnectionLevel" Value="0"/>

    The original value was set to 2.

    Here is a great post on the different values and a better explanation of the underlying issue:

    http://blog.hoegaerden.be/2009/05/24/reporting-services-2008-and-ssl/


    Jason Ogle MCITP Enterprise Administrator
    • Proposed as answer by Jason Ogle Wednesday, November 24, 2010 7:38 PM
    Thursday, November 18, 2010 2:33 PM
  • RSWindowsBasic worked for me!!!


    John Dann
    Tuesday, June 14, 2011 1:28 PM
  • Option 2 worked perfect for me! Thanks

    2) OR, change the report server service account to Network Service

    Wednesday, March 07, 2012 5:30 PM
  • If all of the above possible solutions didn't help you out, here's one more setting you can look at.  I saw the exact same behaviour as explained in the question when remote PCs needed to connect to an SSRS instance running on a regular XP box.

    On the "server", open the Local Security Policy window (on XP: Control Panel > Administrative Tools > Local Security Policy).  Navigate to Local Policies > User Rights Assignment.  There's a policy called Access this computer from the network.  By default, not a lot of users/groups have access to this.  To be able to access the report server remotely (while using NTLM) you should add the user (or through a group) that needs this access.

    Solved the "blank screen" problem for me!

    If that doesn't work, have a look at the Security log in the Event Viewer, it should contain a reason why access is not granted.


    MCITP SQL Server 2008 (DEV); MCTS SQL Server 2008 (BI, DEV & DBA)

    Thursday, June 28, 2012 8:22 AM