none
Code Page

    Question

  • Hello,

    I am getting following error

    Error: 0xC02020F4 at Data Flow Task, OLE DB Source [1]: The column "dbname" cannot be processed because more than one code page (936 and 1252) are specified for it.

    Error: 0xC02020F4 at Data Flow Task, OLE DB Source [1]: The column "dbsize" cannot be processed because more than one code page (936 and 1252) are specified for it.

    Error: 0xC02020F4 at Data Flow Task, OLE DB Source [1]: The column "Owner" cannot be processed because more than one code page (936 and 1252) are specified for it.

    Error: 0xC02020F4 at Data Flow Task, OLE DB Source [1]: The column "Status" cannot be processed because more than one code page (936 and 1252) are specified for it.

    Error: 0xC02020F4 at Data Flow Task, OLE DB Source [1]: The column "CompLevel" cannot be processed because more than one code page (936 and 1252) are specified for it.

     

    When I run the package itself it is working fine and when I am calling the package from another package getting this error. From Parent package I sending servername for olde db source to this package.

    Thanks.

    Wednesday, December 06, 2006 6:16 AM

Answers

  • hi Faran

    Try by setting "AlwaysUseDefaultCodePage" property of oledb source as true.

    Thanks and regards

    Rahul Kumar, Software Engineer, India

     

    Wednesday, December 06, 2006 1:05 PM
  • The package is not saved by default.

     

    When you get to the last page of the wizard, title Save and Execute Package, check the Save SSIS Package option, and save the package. I would choose File System. You can then open BIDS, and create a new SSIS project, to which you can add the wizard generated package.

     

    The wizard is by its nature limited in the options it exposes, compared to the full SSIS designer. In this case you need to use the designer to access the more advanced settings. By saving your package and then using BIDS, the designer, hopefully you can get round the errors.

     

    Monday, February 18, 2008 1:48 PM
    Moderator

All replies

  • hi Faran

    Try by setting "AlwaysUseDefaultCodePage" property of oledb source as true.

    Thanks and regards

    Rahul Kumar, Software Engineer, India

     

    Wednesday, December 06, 2006 1:05 PM
  • I also experienced the following error message:

     The column "%1!s!" cannot be processed because more than one code page (%2!d! and %3!d!) are specified for it.

     Here are the details of my case:

    BACKGROUND
    While building SSIS packages graphically within VS 2005 design mode, a metadata code behind page is modified to reflect the graphical controls used within the designer. It is here within the metadata code-behind where controls reference their parent page with a page number. Each SSIS package has a code-behind with a default page number. Different SSIS packages should have different page numbers.

     
    CAUSE
    I was working with one SSIS package and created a second package that would use some of the configured controls from the first package. By copying controls from the first package to the second package, I ended up with several controls using the page number from its source. So, when I attempted to debug the second package I received the following message:

     The column "ProductId" cannot be processed because more than one code page (1252 and 65001) are specified for it.

     In short the first SSIS package had a page number of 1252 and the second SSIS package had a page number of 65001. So all of the controls copied from the first package retained their 1252 page number references.

     SOLUTION
    I edited the metadata code-behind by replacing all 1252 page number references with 65001.

     This solution worked for me and I hope others will find it useful.

    • Proposed as answer by Thimmana Tuesday, September 25, 2012 5:41 PM
    Wednesday, December 13, 2006 7:02 PM
  • How to set the "AlwaysUseDefaultCodePage" property?

    Thank you.

     

    Wednesday, August 08, 2007 3:45 AM
  • In your data flow transformation, in the properties window of the ole db source or destination you can set this.

    Thanks

    Wednesday, August 08, 2007 4:13 AM
  • I faced similar problem and "AlwaysUseDefaultCodePage" work fine with me and fix my problem.

    you are great man (Y)

    thanks
    Monday, September 17, 2007 8:51 AM
  • Hi,

     

    Can you please advise how to change this custom property in an MS SQL 2005 environment. The instructions please... thanks. Sheni

     

     

    Tuesday, February 12, 2008 12:58 PM
  • Have you looked in the Properties window? Press the key F4, that will bring it to the foreground.

     

    There are actually two solutions described, and I think both have been covered in detail. What are you trying to do?

     

     

    Tuesday, February 12, 2008 2:12 PM
    Moderator
  •  

    Hi,

     

    We have two SQL servers, one in our development environment and the second on the production server. Recently, the  development server/platform was migrated to Vista Business.

     

    Since then we are facing problems in exporting data using "SQL Server Import and Export Wizard" on to the production server. The following error occurs for all columns in all the tables. There is some Arabic content as well in the database. This was working with Windows XP

     

      Error 0xc02020f4: Data Flow Task: The column "tbTempCustID" cannot be processed because more than one code page (1256 and 1252) are specified for it.  (SQL Server Import and Export Wizard)

    We have searched all the forums etc to rectify the issue. The most common answer found was to set AlwaysUseDefaultCodePage=true.

     

    I have no clue on how to change this property. It is mentioned as in the Data Flow Properties - Custom Properties. How to reach that module, pls  help.

    Please let me know if you have any other solutions to the above problem. Thanks in advance.

     

    M.R.S

    Thursday, February 14, 2008 7:21 AM
  •  M.R.S. wrote:

     

    Hi,

     

    We have two SQL servers, one in our development environment and the second on the production server. Recently, the  development server/platform was migrated to Vista Business.

     

    Since then we are facing problems in exporting data using "SQL Server Import and Export Wizard" on to the production server. The following error occurs for all columns in all the tables. There is some Arabic content as well in the database. This was working with Windows XP

     

      Error 0xc02020f4: Data Flow Task: The column "tbTempCustID" cannot be processed because more than one code page (1256 and 1252) are specified for it.  (SQL Server Import and Export Wizard)

    We have searched all the forums etc to rectify the issue. The most common answer found was to set AlwaysUseDefaultCodePage=true.

     

    I have no clue on how to change this property. It is mentioned as in the Data Flow Properties - Custom Properties. How to reach that module, pls  help.

    Please let me know if you have any other solutions to the above problem. Thanks in advance.

     

    M.R.S



    the data flow task doesn't have a property called AlwaysUseDefaultCodePage.  open the package in the BIDS and select the "Data Flow" tab.  there you should see an OLE DB Source and/or Destination component(s).  click on either of these components and press F4.  this exposes the properties window for the component.  you will see the AlwaysUseDefaultCodePage property there.

    hth.
    Thursday, February 14, 2008 8:33 AM
    Moderator
  • Hi,

     

    Thanks for the reply. This is actually where I am stuck. I am not sure what is the 'package' that you are refering to or the 'BIDS' component.  I am initiating the data export by right clicking on the database in  SQL Server Mangement Studio, and clicking on Tasks > Expot data. There is no properties window / F4 option available through out the screens in this type of transaction. Can you please help me to reach the solution that you advised in your reply. Thanks in advance.

     

    Regards

    M.R.S.

     

    Sunday, February 17, 2008 12:45 PM
  •  M.R.S. wrote:

    Hi,

     

    Thanks for the reply. This is actually where I am stuck. I am not sure what is the 'package' that you are refering to or the 'BIDS' component.  I am initiating the data export by right clicking on the database in  SQL Server Mangement Studio, and clicking on Tasks > Expot data. There is no properties window / F4 option available through out the screens in this type of transaction. Can you please help me to reach the solution that you advised in your reply. Thanks in advance.

     

    Regards

    M.R.S.

     



    BIDS stands for Business Intelligence Development Studio.  BIDS is Visual Studio 2005 with the facility to create SQL Server 2005 business intelligence solutions.  BIDS ships with SQL Server 2005.

    Under the covers, the inport/export wizard creates an ssis package which is stored somewhere in the development environment (sorry, i don't know where).  perhaps someone in the SQL Server Tools General forum can assist you locating your package.

    hth.
    Monday, February 18, 2008 12:30 AM
    Moderator
  • The package is not saved by default.

     

    When you get to the last page of the wizard, title Save and Execute Package, check the Save SSIS Package option, and save the package. I would choose File System. You can then open BIDS, and create a new SSIS project, to which you can add the wizard generated package.

     

    The wizard is by its nature limited in the options it exposes, compared to the full SSIS designer. In this case you need to use the designer to access the more advanced settings. By saving your package and then using BIDS, the designer, hopefully you can get round the errors.

     

    Monday, February 18, 2008 1:48 PM
    Moderator
  • Not necessary.

    It depends on situation what kind of file you are importing either directory or using SSIS.

    For Text or CSV file.It doesnt work.

    Rana
    Tuesday, January 19, 2010 12:01 PM
  • I set "AlwaysUseDefaultCodePage" property of oledb source as true. and have same problem

     

    Error at Data Flow Task [SQL Server Destination [699]]: The column "ID" cannot be processed because more than one code page (1252 and 1256) are specified for it.

    Error at Data Flow Task [SQL Server Destination [699]]: The column "Postal" cannot be processed because more than one code page (1252 and 1256) are specified for it.

    Error at Data Flow Task [SQL Server Destination [699]]: The column "First" cannot be processed because more than one code page (1252 and 1256) are specified for it.

    Error at Data Flow Task [SQL Server Destination [699]]: The column "Last" cannot be processed because more than one code page (1252 and 1256) are specified for it.

    Error at Data Flow Task [SQL Server Destination [699]]: The column "address" cannot be processed because more than one code page (1252 and 1256) are specified for it.

    Error at Data Flow Task [SSIS.Pipeline]: "component "SQL Server Destination" (699)" failed validation and returned validation status "VS_ISBROKEN".

    Error at Data Flow Task [SSIS.Pipeline]: One or more component failed validation.

    Error at Data Flow Task: There were errors during task validation.

     (Microsoft.DataTransformationServices.VsIntegration)

     

    any help

    Monday, April 05, 2010 10:15 PM
  • You will have to do a 2 stage Transformation.

    First use the DataConversion Transform and convert these columns from their original datatype to DT_WSTR (which is not CodePage dependent).

    Use the output of the DataConversion Transform and push the data into a table that contains NVARCHAR (not VARCHAR) columns.

    It should work without any issues.

    I had a similar problem with data coming in from a CSV file that had a UTF-8 format . I was able to resolve it with these steps.

     

    Cheers!

    -Andy

     

    • Proposed as answer by AndyMenon Thursday, July 29, 2010 8:39 PM
    Thursday, July 29, 2010 8:39 PM
  • I also found a solution. If you use ADO.NET destinations in your Data Flow Tasks instead of default OLEDB destination (automatically created by Import/Export wizard), it works well.

    Thursday, January 13, 2011 2:01 PM
  • encountered similar Problem. I don't know why but using Derived Columns failed, even after forcing conversion (DT_STR, 16, 1255) [Column1].

    Using ADO.NET solved my problem. Can you please explain WHY it helped?

     

    Thanks,

    Itay

    Wednesday, August 31, 2011 12:50 PM
  • I wanted to post an alternate and easier solution if it's appropriate for your situation. 

    I was trying to do a quick import of data from a CSV file (which I had already done successfully).  For some reason this time when I used the Data Import Wizard (not saved to BIDS) I got the error above: "The column "xxxx" cannot be processed because more than one code page (65001 and 1252) are specified for it." 

    After looking at the posts above, and based on previous experience, I knew that the correct code page was 1252.  I hit the "Back" button in the wizard until I got to the Destination selection screen and the code page selection of 65001 was there.  I simply changed this to 1252 and the import went through with no problem!

    Sandy

    Friday, September 23, 2011 3:03 PM
  • Hi,

    What you should do is to use data conversion component between your source and destination. What you should make sure that you actually need to convert the data into Unicode which you can do that just after source task by adding conversion.

    Thanks

    Anu

    Friday, November 30, 2012 7:08 AM
  • Hello Guys,

    i am having the same problem but none of the proposed solutions work for me. the thing is that my source DB is an SQL server DB table that contains Arabic fields the code page of the Source is 1256. 

    my destination DB is an SQL Compact Edition (with nvarchar fields) the destination page is 1252 

    if i use SSIS to import Data to the compact DB the arabic fields in the source destination appear rubbish 

    if i set AlwaysUseDefaultCodePage to true, an error occurs (cannot be processed because more than one code page (1252 and 1256) are specified for it )

    Please Help!!

    Tuesday, November 05, 2013 2:30 PM
  • hi Faran

    Try by setting "AlwaysUseDefaultCodePage" property of oledb source as true.

    Thanks and regards

    Rahul Kumar, Software Engineer, India

     

    It is not enough, also the default code page of the OLEDB destination needs to match to the codepage used by the source (file) e.g. for UTF-8 it can be


    Arthur My Blog

    Wednesday, July 09, 2014 3:40 PM
    Moderator