none
Reporting services connection logon failed

    Question

  • I am trying to connect to the Database using Windows 'integrated security'. I am getting Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'. I have the following connection string.

    Data Source=testDB;Initial Catalog=test1;Integrated Security=SSPI 

    Could you please let me know if there are any suggestions? Thank you.

    Thursday, November 10, 2011 2:50 PM

Answers

  • Hi anate,

    Thanks for your post.

    Whenever you use Windows Authentication to connect to the specified database, you need to assign the accessing right of the relevant database to your current windows login. Please refer to the steps below:
    1. Use SSMS to connect to the TestDB.
    2. Expand the Security node.
    3. Right-click Logins node, select New login.
    4. Type in your windows login (such as domain\name)as login name.
    5. Switch to Server Roles tab, check the public and sysadmin checkbox.
    6. Switch to Users Mapping tab, check the test1 Database in the first section, and check the db_owner and public roles in the below section.
    7. Click ok to finish.

    Thanks,
    Bill Lu


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Monday, November 14, 2011 8:39 AM

All replies