none
Changing Polling Interval in Merge Replication...

    Question

  • Hi,

       I want to, how to change the polling interval of the merge agent in the merge replication. Now the default polling interval it shows 60seconds. how to change this polling interval.

       If the Polling interval is reduced to 30seconds then the time taken to fetch data from publisher is reduced is that correct...

       Please need help about this... Thanking You...
    Tuesday, May 12, 2009 2:13 PM

All replies

  • Right the polling interval controls how long the merge agent will wait after it has finished a sync before syncing again.

    You can set this in your profile or by editing your merge job and setting -PollingInterval  30

    This is for 30 seconds. You can make this 1 second if you want. On high volume servers its going to have limited use.
    looking for a book on SQL Server replication? http://www.nwsu.com/0974973602.html looking for a book on SQL Server 2008 Administration? http://www.amazon.com/Microsoft-Server-2008-Management-Administration/dp/067233044X looking for a book on SQL Server 2008 Full-Text Search? http://www.amazon.com/Pro-Full-Text-Search-Server-2008/dp/1430215941
    Tuesday, May 12, 2009 2:26 PM
  • Hi,
       Thanking You. But please can you give me a brief description of where and how to change the polling interval for merge agent in merge replication.

    Thanking You...
    Tuesday, May 12, 2009 2:33 PM
  • The Polling interval is set to 60 seconds by default.

    If you are using SQL Server 2008, follow this steps:

    1.- SQL Server Agente->Job Activity Monitor

    2.- Show the Job Activity Monitor List, order by Category, locate your Replication JOB in  REPLMERGE category, double click.

    3.- Select the Schedules Tab/option, you can see the replication agent schedule, click the button Edit.

    4.- Appear a Job shcedule properties windows, change the schedule type  to Recurring

    5.- Modify it according to your preferences

    Greetings from Mexico

    Thursday, February 28, 2013 7:28 PM