none
SQL 2008 R2 agent not starting

    Question

  • I used the following command from command prompt to start the agent :

     


    C:\Program Files\Microsoft SQL Server\MSSQL10_50.MSSQLSERVER\MSSQL\Binn>sqlagent.exe
     -c -v>c:\sqlagent.out

     

    and here is the output of the log file generated:

     


    Microsoft (R) SQLServerAgent 10.50.1600.1
    Copyright (C) Microsoft Corporation.

    2011-08-12 02:45:15 - ? [094] SQLServerAgent started from command line

    2011-08-12 02:45:15 - ? [100] Microsoft SQLServerAgent version 10.50.1600.1 ((Unknown) unicode retail build) : Process ID 1988

    2011-08-12 02:45:15 - ? [101] SQL Server BR-SQL08DEV version 10.50.1600 (0 connection limit)

    2011-08-12 02:45:15 - ? [102] SQL Server ODBC driver version 10.50.1600

    2011-08-12 02:45:15 - ? [103] NetLib being used by driver is DBNETLIB.DLL; Local host server is

    2011-08-12 02:45:15 - ? [310] 4 processor(s) and 4096 MB RAM detected

    2011-08-12 02:45:15 - ? [339] Local computer is BR-SQL08DEV running Windows NT 6.1 (7600)

    2011-08-12 02:45:15 - ? [432] There are 12 subsystems in the subsystems cache

    2011-08-12 02:45:15 - ! [364] The Messenger service has not been started - NetSend notifications will not be sent

    2011-08-12 02:45:15 - ! [298] SQLServer Error: 22022, Usage:  EXECUTE xp_sqlagent_notify 'A', NULL, NULL, <alert_id>, <action type> [SQLSTATE 42000]

    2011-08-12 02:45:15 - ! [442] ConnConnectAndSetCryptoForXpstar failed (0).

    2011-08-12 02:45:16 - ? [098] SQLServerAgent terminated (normally)

     

    Please share any inputs if you have.

     

    Thanks

    Chandan

    Friday, August 12, 2011 6:51 AM

Answers

  • I managed to resolve the issue. I went to the registry HKEY_LOCAL_MACHINE---> Software--->Microsoft---> Microsoft SQL Server

     

    Located my instance here and assigned the full permissions to the windows login. It worked after that.

     

    Ideally, the configuration manager should assign the permissions directly without someone having to go to the registry but it did not happen in this case. This could be due to UAC enabled on my windows 2008 server.

     

    The solution is not very elagant but at the same time does not look too dirty!

     

    Cheers

    Chandan

    • Marked as answer by Chandan jha Wednesday, August 17, 2011 12:00 PM
    Wednesday, August 17, 2011 10:14 AM

All replies

  • Hi Chandan,

    Fix for this issue was first released in Cumulative Update 5 of SQL SERVER 2008 R2 and I can see your SQL SERVER currently on RTM(10.50.1600.1). Please check following KB for detail:

     

    http://support.microsoft.com/kb/975752

     


    Vikas Rana
    Friday, August 12, 2011 7:23 AM
  • Hi Chandan,

    Fix for this issue was first released in Cumulative Update 5 of SQL SERVER 2008 R2 and I can see your SQL SERVER currently on RTM(10.50.1600.1). Please check following KB for detail:

     

    http://support.microsoft.com/kb/975752

     


    Vikas Rana
    Thanks for your reply. I will try applying the CU. On the webpage, there are many fixes listed for x64 version. which one to choose among them?
    Friday, August 12, 2011 7:54 AM
  • I have chosen: SQLServer2008R2_RTM_CU5_2438347_10_50_1753_x64

     

    I will try to apply it now and see what happens after that. Thanks Vikas for your attention.

    Friday, August 12, 2011 7:56 AM
  • No luck even after applying the patch. the other instance runs using the same login on this server but the default instance fails. If i make the account, sysadmin on the windows server, it works.

     

    I am trying to disable UAC and see if it helps.

     

    Chandan

    Friday, August 12, 2011 12:40 PM
  • Hi Chandan,

    From your last message as you mentioned if you make it as SYSADMIN on local system it works. So just check if this account has permissions as required for a SQL Agent Startup account to be.

    http://msdn.microsoft.com/en-us/library/ms191543.aspx

    http://technet.microsoft.com/en-us/library/ms366280.aspx

     

     


    Regards Gursethi Blog: http://gursethi.blogspot.com/ ++++ Please mark "Propose As Answer" if my answer helped ++++
    • Proposed as answer by Peja Tao Monday, August 15, 2011 5:19 AM
    Friday, August 12, 2011 1:47 PM
  • Hi Chandan,

    From your last message as you mentioned if you make it as SYSADMIN on local system it works. So just check if this account has permissions as required for a SQL Agent Startup account to be.

    http://msdn.microsoft.com/en-us/library/ms191543.aspx

    http://technet.microsoft.com/en-us/library/ms366280.aspx

     

     


    Regards Gursethi Blog: http://gursethi.blogspot.com/ ++++ Please mark "Propose As Answer" if my answer helped ++++


    I believe, whenever we choose an account and apply it through configuration manager, it assign the permissions automatically to any policies which are required for a service to run using a domain account. BTW, i verified that all permissions are already in place as mentioned in the above article.

     

    Thanks

    Chandan

    Tuesday, August 16, 2011 6:44 AM
  • I managed to resolve the issue. I went to the registry HKEY_LOCAL_MACHINE---> Software--->Microsoft---> Microsoft SQL Server

     

    Located my instance here and assigned the full permissions to the windows login. It worked after that.

     

    Ideally, the configuration manager should assign the permissions directly without someone having to go to the registry but it did not happen in this case. This could be due to UAC enabled on my windows 2008 server.

     

    The solution is not very elagant but at the same time does not look too dirty!

     

    Cheers

    Chandan

    • Marked as answer by Chandan jha Wednesday, August 17, 2011 12:00 PM
    Wednesday, August 17, 2011 10:14 AM
  • Hi Chandan,

     

    Thank you for sharing your experience which will be helpful to other community members who have the same issue.


    Best Regards,
    Peja

    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, August 17, 2011 2:55 PM