none
SSRS 2005 Date Parameter Default Value Update

    Question

  • Hello guys,

    I created a report in SSRS 2005 and I have a date parameter that has the default value:

    select min(DateTaken) from Table

    When I click on the Preview tab, I see the minimum date value populating the date search field which is great. However, when I add more data into the database which has a lower date, the date field in SSRS does not update automatically. I have to exit SSRS and start it again to see the change in the date field.

    Is there a way that I can add a refresh statement in the query where SSRS would look if there is a new value in the database befoew showing the min(DateTaken)?

    Thanks.

    Sam

    Thursday, March 29, 2012 5:36 PM

Answers

  • Hi itti_sam,

    As far as I have tested by creating a parameter retrieving list from a dataset query, every time I change the dataset results, the parameter refreshed immidiately.

    Could you please click the Refresh button while previewing? If the parameter list refreshed then, this issue might be caused by report cache.

    To turn off this caching feature, please add the following key into 'RSReportDesigner.config'

    <Add Key = "CacheDataForPreview" Value="False"/>(located at [SQL Server Path]\80\Tools\Report Designer)

    Thanks,
    Lola


    Please remember to mark the replies as answers if they help.

    Monday, April 02, 2012 4:42 AM

All replies

  • Does 2005 have the Always Refresh option in the parameter setup like you have in 2008 and 2012?  (Advanced tab on the parameter Properties dialog)

    Insight: The ability to see a thrilling adventure where others see only a near-death experience


    Thursday, March 29, 2012 6:22 PM
  • Hi itti_sam,

    As far as I have tested by creating a parameter retrieving list from a dataset query, every time I change the dataset results, the parameter refreshed immidiately.

    Could you please click the Refresh button while previewing? If the parameter list refreshed then, this issue might be caused by report cache.

    To turn off this caching feature, please add the following key into 'RSReportDesigner.config'

    <Add Key = "CacheDataForPreview" Value="False"/>(located at [SQL Server Path]\80\Tools\Report Designer)

    Thanks,
    Lola


    Please remember to mark the replies as answers if they help.

    Monday, April 02, 2012 4:42 AM