none
Named Pipes Provider, error: 40 - Could not open a connection to SQL Server

    Question

  • This was originally posted in the SSIS Forum, but a member of the IS team suggested it be moved here.  "Most recently I got this error (Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) so does this mean that SQL Server is still trying to use named pipes even if I only have TCP/IP enabled in SQL Server Configuration Manager?"

    I'm having the same issue, and here's our scenario:

    1. Installed SQL Server 2005 Developer Edition on a machine with WinXP SP2 and enabled remote connections over TCP/IP
    2. Installed SQL Server 2005 Standard Edition on a machine with Win2003 SP1 (remote connections over TCP/IP enabled by default)
    3. Attempted to 'Copy Database' from Developer Edition TO Standard Edition using 'Detach and Attach' method and recieved the error on the Win2003 machine: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server
    4. Attempted to 'Copy Database' from Developer Edition TO Standard Edition using 'SQL Management Objects' method and recieved the error on the Win2003 machine: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server
    5. Reinstalled Standard Edition on the Win2003 SP1 machine
    6. Checked all the settings on both machines several times, restarted services etc., and read every post I could find referencing the error.
    7. Same error
    8. Lost my last hair

    Thanks in advance,

    Steve

    Friday, January 06, 2006 2:54 PM

Answers

  • OMG u guys saved me 20000 hrs of work. I had the same problem and now it works.
    Thanks for all the help;)
    Also, if this still doesnt fix ur problem , try these tips
    1. Enable the TCP/IP protocol using the Surface Area Configuration Utility
    2. Make sure the TCP/IP protocol is enabled in the SQL Server Configuration Utility
    3. Make sure the SQL Server browser is started. Note this step is optional. It is possible to set the SQL Server instance to use a fixed IP address - but this is non-standard for named instances
    4. Make sure SQL Server and SQL Server Browser are exempted by the firewall on the server machine. This is done by putting sqlservr.exe and sqlbrowser.exe as an exception in the windows firewall.
    5. Note: In order to get things to work. You might need to completely reboot the server machine after making the changes. There have been reports (thanks P.C.) that starting and stopping the SQL Server and Browser software is not enough.
    resource:www.datamasker.com

    Monday, March 05, 2007 10:15 PM
  • The error is reported by client library. While your server is listeing on remote TCP, client will still try TCP and NP connection in order. So the error client behavior is expected. From what you have described, I believe that even though you enabled the remote TCP connection on the XPSP2 machine, you didn't make the TCP listening port an exception of XPSP2 personal firewall. You should follow steps below to resolve this issue.

     

    1. check the SQL Server Errorlog to make sure SQL Server is now listening on TCP/IP and confirm which port it is listening on.  Usually 1433.  In the Errorlog, you will see several lines that discuss what SQL Server is listening on. Below is an example:

     2006-01-04 01:41:07.65 server    SQL server listening on 10.254.1.150: 1433.     <--Shows the IP Address and the port.

     2006-01-04 01:41:07.65 server    SQL server listening on 127.0.0.1: 1433.          <--Shows another IP Address and the port.

     2006-01-04 01:41:07.69 server    SQL server listening on TCP, Shared Memory, Named Pipes.

     2006-01-04 01:41:07.69 server    SQL Server is ready for client connections             

    2, Make sure on Windows XP that the firewall is not blocking that port.

    3, go to your client machine and run the client network configuration tool (cliconfg.exe)  Make sure TCP/IP is enabled, click properties and make sure the port number is the same one as SQL Server is listening on. Here you can enable NP or disable client NP as well.

     Once both the client and the server are using TCP/IP with the same port number and the firewall on server machines is not blocked, you should be able to connect.

     Hope this helps.

     

     

     

    Tuesday, January 10, 2006 9:56 AM
  • From the error message, your scenario is broken on connection stage and I would like to know if you have tried basic connectivity tests between the two mahcines you are working on. One simple way to verifty connectivity is to use command line tools, such as osql.exe. For example, osql -E -Stcp:servername\instancename. If it connects cross-machine successfully, please also verify that your connection string in your scenario is correct.

    Wednesday, January 11, 2006 6:43 AM
  • In general the error:

     

    Named Pipes Provider, error: 40 - Could not open a connection to SQL Server

    Is just a basic connectivity error meaning the client could not connect to the target SQL Server.   So just follow the basic connectivity troubleshooting guidelines on our SQL Protocols blog, see:

    SQL Server 2005 Connectivity Issue Troubleshoot - Part I

    http://blogs.msdn.com/sql_protocols/archive/2005/10/22/483684.aspx

    and

    SQL Server 2005 Connectivity Issue Troubleshoot - Part II

    http://blogs.msdn.com/sql_protocols/archive/2005/10/29/486861.aspx

    This should help you debug the problem.

     

     

    Monday, March 27, 2006 6:42 PM
  • Hi Steve,

    I just ran the Copy Database Wizard myself on my SQL Server 2005 and I suspect the problem you are running into is due to the account that SQL Agent runs under.  You need to create a SQL Agent Proxy account that can login to the remote machine and then use this account.  By default the SQL Agent service account does not have remote access. 

    When you get to the page thay says: "Schedule the Package" at the bottom you will see the "Integration Services Proxy Account" selection, you need to create an account that can login to the remote machine (standard account is easiest) and then select this account rather than "SQL Server Agent Service Account"

    See ->

    How to: Create a Proxy (SQL Server Management Studio)  

    http://msdn2.microsoft.com/en-us/library/ms190698.aspx

    Matt

    Friday, January 20, 2006 9:08 PM

All replies

  • The error is reported by client library. While your server is listeing on remote TCP, client will still try TCP and NP connection in order. So the error client behavior is expected. From what you have described, I believe that even though you enabled the remote TCP connection on the XPSP2 machine, you didn't make the TCP listening port an exception of XPSP2 personal firewall. You should follow steps below to resolve this issue.

     

    1. check the SQL Server Errorlog to make sure SQL Server is now listening on TCP/IP and confirm which port it is listening on.  Usually 1433.  In the Errorlog, you will see several lines that discuss what SQL Server is listening on. Below is an example:

     2006-01-04 01:41:07.65 server    SQL server listening on 10.254.1.150: 1433.     <--Shows the IP Address and the port.

     2006-01-04 01:41:07.65 server    SQL server listening on 127.0.0.1: 1433.          <--Shows another IP Address and the port.

     2006-01-04 01:41:07.69 server    SQL server listening on TCP, Shared Memory, Named Pipes.

     2006-01-04 01:41:07.69 server    SQL Server is ready for client connections             

    2, Make sure on Windows XP that the firewall is not blocking that port.

    3, go to your client machine and run the client network configuration tool (cliconfg.exe)  Make sure TCP/IP is enabled, click properties and make sure the port number is the same one as SQL Server is listening on. Here you can enable NP or disable client NP as well.

     Once both the client and the server are using TCP/IP with the same port number and the firewall on server machines is not blocked, you should be able to connect.

     Hope this helps.

     

     

     

    Tuesday, January 10, 2006 9:56 AM
  • Nan,

    Before I get on with this post - thank you for your reply.

    The XPSP2 machine actually had the firewall disabled, and I verified that it could accept connections on the the associated ports with the Shields Up utility.  I tested this on both machines.

    I can connect to the server from the XPSP2 machine, Import / Export, manage, view logs, and do everything EXCEPT get the Copy Database package to run.  SQL Server Agent always fails on the last step with the following error:

    Event Type: Error
    Event Source: SQLISPackage
    Event Category: None
    Event ID: 12550
    Date:  1/10/2006
    Time:  1:34:15 PM
    User:  NT AUTHORITY\SYSTEM
    Computer: 401SERVER
    Description:
      Event Name: OnError
     Message: Failed to connect to server BETHESDA.
    StackTrace:    at Microsoft.SqlServer.Management.Common.ConnectionManager.Connect()
       at Microsoft.SqlServer.Dts.Tasks.TransferObjectsTask.TransferObjectsTask.OpenConnection(Server& server, ServerProperty serverProp)
    InnerException-->An error has occurred while establishing a connection to the server.  When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)
    StackTrace:    at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection)
       at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj)
       at System.Data.SqlClient.TdsParser.Connect(Boolean& useFailoverPartner, Boolean& failoverDemandDone, String host, String failoverPartner, String protocol, SqlInternalConnectionTds connHandler, Int64 timerExpire, Boolean encrypt, Boolean trustServerCert, Boolean integratedSecurity, SqlConnection owningObject, Boolean aliasLookup)
       at System.Data.SqlClient.SqlInternalConnectionTds.OpenLoginEnlist(SqlConnection owningObject, SqlConnectionString connectionOptions, String newPassword, Boolean redirectedUserInstance)
       at System.Data.SqlClient.SqlInternalConnectionTds..ctor(DbConnectionPoolIdentity identity, SqlConnectionString connectionOptions, Object providerInfo, String newPassword, SqlConnection owningObject, Boolean redirectedUserInstance)
       at System.Data.SqlClient.SqlConnectionFactory.CreateConnection(DbConnectionOptions options, Object poolGroupProviderInfo, DbConnectionPool pool, DbConnection owningConnection)
       at System.Data.ProviderBase.DbConnectionFactory.CreatePooledConnection(DbConnection owningConnection, DbConnectionPool pool, DbConnectionOptions options)
       at System.Data.ProviderBase.DbConnectionPool.CreateObject(DbConnection owningObject)
       at System.Data.ProviderBase.DbConnectionPool.UserCreateRequest(DbConnection owningObject)
       at System.Data.ProviderBase.DbConnectionPool.GetConnection(DbConnection owningObject)
       at System.Data.ProviderBase.DbConnectionFactory.GetConnection(DbConnection owningConnection)
       at System.Data.ProviderBase.DbConnectionClosed.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory)
       at System.Data.SqlClient.SqlConnection.Open()
       at Microsoft.SqlServer.Management.Common.ConnectionManager.InternalConnect(WindowsIdentity impersonatedIdentity)
       at Microsoft.SqlServer.Management.Common.ConnectionManager.Connect()
     Operator: NT AUTHORITY\SYSTEM
     Source Name: BETHESDA_401SERVER_Transfer Objects Task
     Source ID: {86F355AD-3B74-4D7B-8D2D-C743C790A269}
     Execution ID: {91B7C32C-C439-4EDB-8A0F-9F8BF207BC06}
     Start Time: 1/10/2006 1:34:15 PM
     End Time: 1/10/2006 1:34:15 PM
     Data Code: 0

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    Have you (or anyone else) successfully executed a Copy Databse task?

    Steve

    Tuesday, January 10, 2006 6:38 PM
  • From the error message, your scenario is broken on connection stage and I would like to know if you have tried basic connectivity tests between the two mahcines you are working on. One simple way to verifty connectivity is to use command line tools, such as osql.exe. For example, osql -E -Stcp:servername\instancename. If it connects cross-machine successfully, please also verify that your connection string in your scenario is correct.

    Wednesday, January 11, 2006 6:43 AM
  • Nan,

    I'm probably going to thank you for your help every time I post - so again, thanks for your help.  I've tried the basic connectivity tests (below is the command line output) and they were successful.  I have had no connectivity issues using SQL Studio or otherwise, unless it involves using the 'Copy Database' task and SQL Server Agent.

    Microsoft Windows XP [Version 5.1.2600]
    (C) Copyright 1985-2001 Microsoft Corp.

    C:\Documents and Settings\Steve>sqlcmd -S 401Server -i C:\TestQuery.sql
    Changed database context to 'Test'.
    Location_ID Location_Name
    ----------- --------------------------------------------------
    0010-10     ADAMSVILLE
    0011-10     ALLENTOWN
    0011-11     EASTON
    0011-12     BETHLEHEM
    0011-13     EASTON RENTAL MART

    (5 rows affected)

    C:\Documents and Settings\Steve>osql -E Stcp:401Server
    1> exit

    C:\Documents and Settings\Steve>

    Has anyone been able to successfully execute a 'Copy Database' from one SQL Server 2005 to another?

    Steve

    Wednesday, January 11, 2006 12:38 PM
  • Just to confirm, did you try basic connectivity test from 401SERVER to BETHESDA?
    • Proposed as answer by Wagtec Monday, April 29, 2013 6:28 AM
    Wednesday, January 11, 2006 6:59 PM
  • Hi Steve,

    I just ran the Copy Database Wizard myself on my SQL Server 2005 and I suspect the problem you are running into is due to the account that SQL Agent runs under.  You need to create a SQL Agent Proxy account that can login to the remote machine and then use this account.  By default the SQL Agent service account does not have remote access. 

    When you get to the page thay says: "Schedule the Package" at the bottom you will see the "Integration Services Proxy Account" selection, you need to create an account that can login to the remote machine (standard account is easiest) and then select this account rather than "SQL Server Agent Service Account"

    See ->

    How to: Create a Proxy (SQL Server Management Studio)  

    http://msdn2.microsoft.com/en-us/library/ms190698.aspx

    Matt

    Friday, January 20, 2006 9:08 PM
  • Thanks for the reply Matt..  I've been off-site working on a different project and will post again as soon as I'm able to implement your suggestion.

    Steve

    Wednesday, January 25, 2006 1:06 AM
  • I'm getting the same error in a C# windows app. However, the SQL server that I'm using is 2000, not 2005. Does this matter? If not, does anyone have a solution?

    Saturday, February 18, 2006 7:29 PM
  • Hi,

    I am able to remotely connect to SQL Server 2005 using the Management Studio and also via application running on the client machine.

    I am attempting a setup project for dynamically creating database for which I need to connection to the sql server during install. It is at this stage that I get the error - Default settings do not allow remote connections. Whereas on my sql server remote connections using both named pipes as well as tcp / ip are enabled...

    PLZ HELP!!

    Monday, March 27, 2006 11:09 AM
  • In general the error:

     

    Named Pipes Provider, error: 40 - Could not open a connection to SQL Server

    Is just a basic connectivity error meaning the client could not connect to the target SQL Server.   So just follow the basic connectivity troubleshooting guidelines on our SQL Protocols blog, see:

    SQL Server 2005 Connectivity Issue Troubleshoot - Part I

    http://blogs.msdn.com/sql_protocols/archive/2005/10/22/483684.aspx

    and

    SQL Server 2005 Connectivity Issue Troubleshoot - Part II

    http://blogs.msdn.com/sql_protocols/archive/2005/10/29/486861.aspx

    This should help you debug the problem.

     

     

    Monday, March 27, 2006 6:42 PM
  • did you ever get that sorted out?
    Thursday, December 21, 2006 7:45 PM
  • i am opening the ERRORLOG file in the MSSQL.1\MSSQL\LOG. i can see lines of it shutting down and starting up but it doesn't show the line where it says what ip port its using.
    Thursday, December 21, 2006 7:48 PM
  • Also -

     

    Windows XP with SP2, Windows Firewall is probably blocking your SQL connection:

    http://support.microsoft.com/default.aspx?scid=kb;en-us;839269

     

     

    Thursday, February 22, 2007 4:06 AM
  • OMG u guys saved me 20000 hrs of work. I had the same problem and now it works.
    Thanks for all the help;)
    Also, if this still doesnt fix ur problem , try these tips
    1. Enable the TCP/IP protocol using the Surface Area Configuration Utility
    2. Make sure the TCP/IP protocol is enabled in the SQL Server Configuration Utility
    3. Make sure the SQL Server browser is started. Note this step is optional. It is possible to set the SQL Server instance to use a fixed IP address - but this is non-standard for named instances
    4. Make sure SQL Server and SQL Server Browser are exempted by the firewall on the server machine. This is done by putting sqlservr.exe and sqlbrowser.exe as an exception in the windows firewall.
    5. Note: In order to get things to work. You might need to completely reboot the server machine after making the changes. There have been reports (thanks P.C.) that starting and stopping the SQL Server and Browser software is not enough.
    resource:www.datamasker.com

    Monday, March 05, 2007 10:15 PM
  • I tried everything mentioned above, however I still cannot connect...

    I tried with xxx.xxx.xxx.xxx, xxx.xxx.xxx.xxx\SQLEXPRESS, name, name\SQLEXPRESS.

    I tried with ODBC Datasource, SQL Server (both OLEDB & SQL), SQL DB file.

    I tried with Windows authentication & SQL server authentication

    I Tried with/without Firewall

    I tried Firewall exception of SQL Service in port 445 for both internal & external cards (internal hasn't firewall enabled, however I tried it)

    Simply, it does not work for me. Always the same error...

    I have enabled remote connections for both tcp/ip and named pipes and restarted the server, I even restarted the machine.

    What am I doing wrong?
    Wednesday, March 14, 2007 11:50 AM
  • mmm i have this exactly:

            SqlConnection ^ m_conn ;

         m_conn = gcnew SqlConnection();
         m_conn->ConnectionString="Data Source=SOFTWARE5\\SQLEXPRESS;Initial Catalog=YuisUsersDatabase;Integrated Security=True" ;
         m_conn->Open();

    or see this: http://www.mindcontroll.com/yui/lala/phpBB2/viewtopic.php?t=5

    if it still doesnt work mmmmm  do the tcp/ip and such configuration and  restart ur server.
    Wednesday, March 14, 2007 5:44 PM
  • What is your server/instance name? If it's a default instance, use "name or IP". If the instance name is ABCDE, use "name\ABCDE". Don't know why you try both. Why port 445 for firewall exception? 

    You can check this blog and follow the steps.

    Thursday, March 15, 2007 6:01 PM
  • There are strange things happening.... I do not know why but sometimes I am getting this error, but others not, while trying to connect from tha same machine, to the same SQL, with exactly the same connection string...

     

    Except that, I have created some sql batches in order to create dynamicly a DB and some tables to it, however when I am running the code from within VS2005 using F10, everything works ok, however when I am running the same script, without debuging I returns an SQL exception, which occures if at least one of the scripts did not run.

    What is going wrong? How can it be possible for the same code to run sometimes?

    Monday, March 19, 2007 3:06 PM
  • It's possible for the same connection string to fail to connect to the same server from same client.

    Possible reasons include:

    1. Poor network link from client to server.

    2. Server is very busy (meaning high CPU) and cannot respond to new connection attempts.

    3. Server is running out of memory (so high memory usage for SQL).

    4. tcp-ip layer on client is over-saturated with connection attempts so tcp-ip layer rejects the connection.

    5. tcp-ip layer on server side is over-staturated with connection attempts and so tcp-ip layer is rejecting new connections.

    6. With SQL 2005 SP2 and later there could be a custom login trigger that rejects your connection.

    You can increase the connect timeout to potentially alleviate issues #2, #3, #4, #5.  Setting a longer connect timeout means the driver will try longer to connect and may eventually succeed.

    To determine the root cause of these intermittent failures is not super easy to do unfortunately.  What I normally do is start by examining the server environment, is the server constantly running in high CPU for example, this points to #2.  Is the server using a hugh amount of memory, this points to #3.   You can run SQL Profiler to monitor logins and look for patterns of logins, perhaps every morning at 9AM there is a flurry of connections etc...

    Monday, March 19, 2007 8:54 PM
  • I had this error and looked through countless forums for a solution but none of them worked for me.

    I am using a SQL Server 2000 database but my error message was relating to SQL 2005 which was very frustrating.  My application worked fine on my local machine but when I copied it to the remote production server, it always crashed when I tried to do anything involving the Membership class (such as logging in).

    In the end, I discovered that my web.config file was missing the <roleManager> element.  This wasn't a problem locally since it was in the machine.config file.  Since I've added this element, it all works like a dream!

     

     

    Wednesday, March 21, 2007 7:26 AM
  • hi, i m having same problems but couldnt solve it......

    i have try to do all e suggestion but still same....can anybody help me....pls.....

    i m trying to connect the database from local.

    System.Data.SqlClient.SqlException was unhandled by user code
      Message="An error has occurred while establishing a connection to the server.  When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)"
      Source=".Net SqlClient Data Provider"
      ErrorCode=-2146232060
      Class=20
      LineNumber=0
      Number=53
      Server=""
      State=0
      StackTrace:
           at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection)
           at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj)
           at System.Data.SqlClient.TdsParser.Connect(Boolean& useFailoverPartner, Boolean& failoverDemandDone, String host, String failoverPartner, String protocol, SqlInternalConnectionTds connHandler, Int64 timerExpire, Boolean encrypt, Boolean trustServerCert, Boolean integratedSecurity, SqlConnection owningObject, Boolean aliasLookup)
           at System.Data.SqlClient.SqlInternalConnectionTds.OpenLoginEnlist(SqlConnection owningObject, SqlConnectionString connectionOptions, String newPassword, Boolean redirectedUserInstance)
           at System.Data.SqlClient.SqlInternalConnectionTds..ctor(DbConnectionPoolIdentity identity, SqlConnectionString connectionOptions, Object providerInfo, String newPassword, SqlConnection owningObject, Boolean redirectedUserInstance)
           at System.Data.SqlClient.SqlConnectionFactory.CreateConnection(DbConnectionOptions options, Object poolGroupProviderInfo, DbConnectionPool pool, DbConnection owningConnection)
           at System.Data.ProviderBase.DbConnectionFactory.CreatePooledConnection(DbConnection owningConnection, DbConnectionPool pool, DbConnectionOptions options)
           at System.Data.ProviderBase.DbConnectionPool.CreateObject(DbConnection owningObject)
           at System.Data.ProviderBase.DbConnectionPool.UserCreateRequest(DbConnection owningObject)
           at System.Data.ProviderBase.DbConnectionPool.GetConnection(DbConnection owningObject)
           at System.Data.ProviderBase.DbConnectionFactory.GetConnection(DbConnection owningConnection)
           at System.Data.ProviderBase.DbConnectionClosed.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory)
           at System.Data.SqlClient.SqlConnection.Open()
           at _Default.Page_Load(Object sender, EventArgs e) in d:\VD WEB\Test_database\Default.aspx.cs:line 24
           at System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e)
           at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e)
           at System.Web.UI.Control.OnLoad(EventArgs e)
           at System.Web.UI.Control.LoadRecursive()
           at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

    thanks a lot

    Wednesday, March 21, 2007 10:18 AM
  • Was having the same problem trying to connect to a 2000 db and a VB2005 application.  The permissions were not correct.  Using Enterprise Manager I created a Role for my Database with all tables/views' Select options checked (it's just a reporting application.)  Then, in Enterprise Manager under Security | Logins, I added my user and assigned that role to the login under Database Access of the Properties.  This tells Sql Server that this user is allowed to select any table or view (because that's how I set up the Role.)  Reran the app and it worked.  Yes, there was victory in the air.
    Thursday, April 19, 2007 8:38 PM
  • Just to say this was exactly the problem I had, and yours was the only posting that I could find which clearly identified the problem and corrective action I needed to take. (Could not copy databases between machines with SQL Server 2005 Copy Database Wizard until I set up a proxy account).  Matt, many thanks.
    Saturday, June 02, 2007 8:57 AM
  • I'm having the same problem to since i reïnstalled my computer en re-attached the db's i'm using. But the funny rhing is that i do not connect to a remote machine. My VB.NET app and my DB are on the same machine. Any ideas?
    Sunday, June 03, 2007 11:40 AM
  •  

    Change the TCP Dynamic Ports entry to 1433.

     

    Go to Computer Management -> SQL Server 2005 Network Configuration -> Protocols for <Instance Name>. Click on the IP Address Tab. Under IPAll, change the 5-digit port# for TCP Dynamic Ports to 1433.

    Tuesday, July 10, 2007 4:08 PM
  • Actually Kashmiriat - I checked that value and not only are your instructions for getting to that value incorrect, but if the TCP Dynamic Ports is blank (as it states in the properties sheet directly below the field) it is *not* used.  There is no need to change this field to 1433.

     

    That aside, I'm still unable to get this to work.  I did try what Matt suggestion and setup a Proxy account in the SQL Agent service, selected it in the wizard - but the copy still fails with an encrypted message on the server that is initiating the copy:

     

    SQL Server Scheduled Job 'CDW_FRANCOTYP_NANOOK_3_1_3' (0xAC96B4FF0F876D4C9083F09860732183) - Status: Failed - Invoked on: 2007-07-12 10:23:42 - Message: The job failed.  The Job was invoked by User websync.  The last step to run was step 1 (CDW_FRANCOTYP_NANOOK_3_1_3_Step).

     

    So, just to be clear - I have two seperate SQL servers running SQL2005.  One is local and one is remote (over the internet).  I am initiating the copy from the local server.  The Proxy Account should be the same as the account on the remote SQL server, correct?  Any ideas on how to resolve this issue? 

    Thursday, July 12, 2007 4:35 PM
  • Okay -

     

    I finally got this resolved and thought I would follow up (what a concept, huh?). 

     

    1) you need to create a proxy account as specified by MATT (see further up in the thread). 

    How to: Create a Proxy (SQL Server Management Studio)  

    http://msdn2.microsoft.com/en-us/library/ms190698.aspx

     

    How to: Create a Credential (SQL Server Management Studio)

    http://msdn2.microsoft.com/en-us/library/ms190703.aspx

    2) If you are connecting to a remote SQL server over TCP - you need to specify an Alias so that you can reference the SQL Server Instance Name instead of the IP address:

     

    SQL Server Configuration Manager -> SQL Native Client Configuration -> Aliases -> Create new alias

    • Enter the Alias Name (Name of the remote SQL Instance - this has to match exactly the name of the Remote SQL Server)
    • Enter the Port (1433)
    • Select TCP/IP as the protocol
    • Enter the IP Address

    That should do it.

     

    -JohnnyH

     

     

    Friday, July 13, 2007 7:35 PM
  • I have tried all the above.its still not working

    Saturday, July 28, 2007 5:07 PM
  • Hi Johnny or Matt!

    How would creating a proxy account and aliases plays a part when 2 remote servers connect to each other for copy database to work?

    Thanks in Advance!

    Monday, August 20, 2007 5:37 PM
  • I would also like to know..

    If you have 2 alias to point to two different servers,do we still enter port 1433 for the second alias too?

    Thank you

    Monday, August 20, 2007 5:43 PM
  • You need enter the port number only when you are creating alias, don't need to enter it when using it.

    You can check this blog for more details about alias: http://blogs.msdn.com/sql_protocols/archive/2007/01/07/connection-alias.aspx

    Thanks.

    Monday, August 20, 2007 5:50 PM
    • Proposed as answer by Andris Marte Friday, June 29, 2012 3:12 PM
    Tuesday, August 21, 2007 7:54 PM
  • I tried to set  TCP dynamic port but couldnot able to find out IP Address Tab under IPAll.Can You please Help.

    Thanks.

     

    Thursday, August 23, 2007 4:32 PM
  •  

    Go to Start>Programs>MS SQL 2005>Cofiguration Manager

    when you expand your SQL Server 2005 Network configuration, it will list out the number of database instances you have installed.

    Choose the 'Protocols for 'yourDBinstance',double click

    Right click on the TCP/IP and choose properties

    Click on the IP Addresses tab.

    Scroll to the bottom and if your IPALL Dynamic Port is set to 0,

    enter in the port number you wanna use.

    SQL will prompt you to restart the SQL service and you a connect to this name instance 'tru the dynamic port number

    Friday, August 24, 2007 2:03 AM
  • I've done everything in every list, and I still cannont connect.  I'm using SQL Server Express.  I've:

     

    1. Enabled Local and Remote connections using both TCP/IP and named pipes through the Surface Area Config

    2. Enabled TCP/IP and named pipes in the Server Config utility

    3. I'm using the <servername>/SQLEXPRESS name as my DataSource in my connection string

    4. I've restarted everything.

    5. I've turned off my firewall and Norton AV

     

    I have SQL Server on the same machine... I'm losing my mind.

    Wednesday, August 29, 2007 6:10 AM
  • Please use <servername>\SQLEXPRESS, rather than <servername>/SQLEXPRESS. Is your SQL Browser on?

    Wednesday, August 29, 2007 6:24 AM
  • Thanks Nan Tu for the post.

    I was getting the connection error for the remote sql server 2000. I did the changes by using cliconfig.exe and it's now working!

     

    Thanks

    Shridhar

     

    Sunday, October 07, 2007 9:47 AM
  •  Nan Tu wrote:

    The error is reported by client library. While your server is listeing on remote TCP, client will still try TCP and NP connection in order. So the error client behavior is expected. From what you have described, I believe that even though you enabled the remote TCP connection on the XPSP2 machine, you didn't make the TCP listening port an exception of XPSP2 personal firewall. You should follow steps below to resolve this issue.

     

    1. check the SQL Server Errorlog to make sure SQL Server is now listening on TCP/IP and confirm which port it is listening on.  Usually 1433.  In the Errorlog, you will see several lines that discuss what SQL Server is listening on. Below is an example:

     2006-01-04 01:41:07.65 server    SQL server listening on 10.254.1.150: 1433.     <--Shows the IP Address and the port.

     2006-01-04 01:41:07.65 server    SQL server listening on 127.0.0.1: 1433.          <--Shows another IP Address and the port.

     2006-01-04 01:41:07.69 server    SQL server listening on TCP, Shared Memory, Named Pipes.

     2006-01-04 01:41:07.69 server    SQL Server is ready for client connections             

    2, Make sure on Windows XP that the firewall is not blocking that port.

    3, go to your client machine and run the client network configuration tool (cliconfg.exe)  Make sure TCP/IP is enabled, click properties and make sure the port number is the same one as SQL Server is listening on. Here you can enable NP or disable client NP as well.

     Once both the client and the server are using TCP/IP with the same port number and the firewall on server machines is not blocked, you should be able to connect.

     Hope this helps.

     

     

     

    Monday, October 15, 2007 1:47 PM
  •  

    Thnaks
    Monday, October 15, 2007 4:10 PM
  • Hi, Steve

     

        1) When you did 'detach and attach' operation, are you sure the right server name given?

        2) Are you sure you give the right instance name if it is named instance?

        3) Are you sure you give correct credential to login?

       

        Please check out following two blogs:

     

        1) http://blogs.msdn.com/sql_protocols/archive/2007/03/31/named-pipes-provider-error-40-could-not-open-a-connection-to-sql-server.aspx

        2) http://blogs.msdn.com/sql_protocols/archive/2007/05/16/named-pipes-provider-error-40-could-not-open-a-connection-to-sql-server-microsoft-sql-server-error-xxx.aspx

     

    Good Luck!

    Ming.

    Tuesday, October 16, 2007 5:14 PM
  • Wow, i still have alerts on this. nice to see it still goes and people are actually solving this! maybe we should put this on platinum on one of the all time annoyances now resolving problems.

    cheers
    Charles
    Tuesday, October 16, 2007 5:17 PM
  • I think I got a solution...

    the error is in the connection string and in the configuration... if you'll use the IP instead of (loca), localhost, <machinename>\SQLEXPRESS, it will work. So use 127.0.0.1... the server will love it... and one more thing... at Protocols (SQL Server Configuration) at TCP/IP, set at IPAll - TCP Dymanic ports 1433 and one more... of course... set trusted connection to true... (you should allow remote connections too)..

    So, the connection string is :

    "Provider=SQLNCLI;Server=127.0.0.1;Database=database;Trusted_Connection=yes;"

    Hope this helps someone..

     

    P.S. : from my point of view.. I think this solution is a stupid one as long as local = localhost = 127.0.0.1... I guess for the SQLExpress.... local = localhost != 127.0.0.1

    Thursday, October 18, 2007 9:05 PM
  • Probably way too late and I can't say I've read through ALL the replies, but if the SQL Server Browser service isn't enabled and running you'll see nothing.  I lost a good few hours on this and not just once.  You think if the SQL Server service is running then VS will see the databases. Tis not so.
    Saturday, November 24, 2007 7:46 PM
  •  

    An error has occurred while establishing a connection to the server.  When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) (.Net SqlClient Data Provider)

     

     

    Server Name: alaayacoub
    Error Number: 233
    Severity: 20
    State: 0

     

    Program Location:

       at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection)
       at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj)
       at System.Data.SqlClient.TdsParser.Connect(Boolean& useFailoverPartner, Boolean& failoverDemandDone, String host, String failoverPartner, String protocol, SqlInternalConnectionTds connHandler, Int64 timerExpire, Boolean encrypt, Boolean trustServerCert, Boolean integratedSecurity, SqlConnection owningObject, Boolean aliasLookup)
       at System.Data.SqlClient.SqlInternalConnectionTds.OpenLoginEnlist(SqlConnection owningObject, SqlConnectionString connectionOptions, String newPassword, Boolean redirectedUserInstance)
       at System.Data.SqlClient.SqlInternalConnectionTds..ctor(DbConnectionPoolIdentity identity, SqlConnectionString connectionOptions, Object providerInfo, String newPassword, SqlConnection owningObject, Boolean redirectedUserInstance)
       at System.Data.SqlClient.SqlConnectionFactory.CreateConnection(DbConnectionOptions options, Object poolGroupProviderInfo, DbConnectionPool pool, DbConnection owningConnection)
       at System.Data.ProviderBase.DbConnectionFactory.CreateNonPooledConnection(DbConnection owningConnection, DbConnectionPoolGroup poolGroup)
       at System.Data.ProviderBase.DbConnectionFactory.GetConnection(DbConnection owningConnection)
       at System.Data.ProviderBase.DbConnectionClosed.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory)
       at System.Data.SqlClient.SqlConnection.Open()
       at Microsoft.SqlServer.Management.UI.VSIntegration.ObjectExplorer.ObjectExplorer.ValidateConnection(UIConnectionInfo ci, IServerType server)
       at Microsoft.SqlServer.Management.UI.ConnectionDlg.Connector.ConnectionThreadUser()

    Tuesday, December 11, 2007 7:31 AM
  •  Eusebiu wrote:

    I think this solution is a stupid one as long as local = localhost = 127.0.0.1... I guess for the SQLExpress.... local = localhost != 127.0.0.1

     

    Though I do agree that it is not easy to make this work, localhost and 127.0.0.1 is programatically not the same my friend, though both refer to the same computer the method of communication used and the protocols in play are different. A named pipe is not an IP connection and does not function the same way. Credentials and other aspects are different. SQL connections will work either on tcpip, pipe OR named instance. See http://msdn2.microsoft.com/de-de/library/ms189307.aspx for standards and here http://en.wikipedia.org/wiki/Named_pipe.  

     

    If you have a Named Pipes Provider Error (that is the topic subject)  than by definition of the error itself you are trying to use a "named pipe" . I would not troubleshoot a TCP/IP error based on that information unless that is the method of communication you want to use. Though I guess most here will not care what to use as long as "it works". Most Connection errors never mind which method you use are based on the fact that the machine/ name/ pipe/ instance is not found, in clear: properly resolved , that is name resolution first before security second.  That is why so many posts here refer to the "SQL Browser" as kind of Name Resolution Workaround. To connect to a database you need to identify different main parameters: Where is that database ? (computer)  how do I want to connect to it ? (choose protocol)  What runs the database ? (DB Engine Instance) What is the database name ? (dbname)  What credentials do I need to hack into it ? User and password ? how to I vcerify those credentials (might be certificate or kerberos or named account) etc ..

     

    You would not look for a security problem when the connection code has not even established the initial connection, cause security is cheked AFTER that, it would be like frantically searching for a plane in airspace which is overdue at the destination which had never left the runway in the first place.

     

     

    Tuesday, January 08, 2008 1:25 PM
  • Hello . Tank you of Answer.

    again Can't Connect to Sql.

    I havn't SQLSERVER and create database in Microsoft Visual Studio 2005 (C#).

    I am University Student. This My End Project.

    Email:

    hamidreza_ghorbany_roz@roz.com

    hamdreza_ghorbany_roz@yahoo.com

    hamidreza.ghorbany.roz@gmail.com

     

     

    Saturday, January 12, 2008 7:54 PM
  • Hello . Tank you of Answer.

    again Can't Connect to Sql.

    I havn't SQLSERVER and create database in Microsoft Visual Studio 2005 (C#).

    My Computer Have WinXP SP2 - version 2002.

    I am University Student. This My End Project.

    Email:

    hamidreza_ghorbany_roz@roz.com

    hamdreza_ghorbany_roz@yahoo.com

    hamidreza.ghorbany.roz@gmail.com

     

     

    Saturday, January 12, 2008 7:58 PM
  •  

    Hi,

     

    I am facing the same problem.

     

    Following is my s/w configuration details:

    1. Win XP with SP 2

    2. Visual Studio 2005 Professional Edition

    3. SQL Server 2005 Standard Edition

     

    I can connect to the remote database server through SQL Server Management Studio but when trying to open the ASPX page in IE, it gives me the same error.

     

    Let me retype it for your reference.

     

    An error has occurred while establishing a connection to the server.  When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)

     

    I followed all of the steps that you have mentioned, they are as follows:

     

    1. SQL Server 2005 Surface Area Configuration for SQL Server Browser Service (Done)

    2. Win XP Firewall exceptions are created for SQL Server (EXE) and SQL Server Browser Service (EXE)

    3. Added port 1433 as exception under Win XP firewall.

     

    Please let me know if I am missing something.

     

    Awaiting for your pink and healthy response,

     

    Regards,

     

    Umesh.

     

    Wednesday, January 16, 2008 11:22 AM
  • If you can connect remotely from SQL Server Management Studio, then remote connectivity is working.

     

    Therefore, the problem resides inside the ASPX page.

     

    When this happens you need to step back and do things one step at a time.  What I would do is create a very very simple ASPX page that just opens a SqlConnection object to the server in a try catch block and reports the error back.

     

    Then try things like:

     

    Use connection string in form:

     

    "server=tcp:123.123.123.123,1433;user id=test;password=test;"

     

    Note I used the tcp: prefix to force SqlConnection to use the TCP-IP protocol.

    I used the IP address of the SQL Server to ensure that there are no DNS problems.

    I also used ,1433 to force it to use port 1433.

     

    Once this works, then you can replace IP with server name, like so:

     

    "server=tcpTongue TiederverName,1433;user id=test;password=test;"

     

    If this works then remove the port and tcp, etc...

     

     

     

     

     

     

     

     

     

     

     

     

     

    Wednesday, January 16, 2008 6:31 PM
  • Just a quick comment.  I had the same error come up.  After reading through the posts here I checked the SQL Manager and found that SQL was turned off.  I turned it back on and now everything works fine.  I'm not saying this was the problem listed here but I received the same error code and came up with a different solution.  Sometimes it is the simplest solution that causes the greatest problems. 
    Friday, January 25, 2008 5:44 PM
  • Hi,

    I'm encountering the original issue of "Named Pipes Provider, error: 40 windows" but am having problems determining how to fix it due to the environment I'm using.  I have two SQL Servers installed on two separate Win2K3 Server boxes, one is SQL Server 2000 and the other is SQL Server 2005.  The SQL Server 2000 contains the actual application data.  The 2005 database is used only for Reporting Services.  I've set up the reports on SSRS such that their datasources hit the 2000 server.  This is using SQL Server authentication.

    When testing the reports via SSRS (in Visual Studio 2005), the connection to the data works and the reports are generated fine.  When I deploy them to the reporting server and launch IE to test locally (still on the 2005 box), I get this "Named Pipes Provider, error 40" issue.  I made sure that Named Pipes and TCP were enabled and the port set at 1433 (to match that on the 2000 box). 

    Now I changed the datasource's authentication from SQL Server to Windows authentication.  I tested this in SSRS and this works too.  When I redeployed the reports with this authentication change, testing the reports via IE locally (on the 2005 box) worked.  Great.  Now when I open IE on an external box, i.e. on the 2000 box, and try to test the reports, I get this same error 40 issue.  I've been through this entire thread as well as other similar threads fiddling around with the SQL Server configuration as well as SSRS, to no avail.  I have a feeling this error 40 issue has to due with permissions/authentication between the SQL Server boxes but I can't really be sure.  Anyone have any ideas on how to troubleshoot my situation.  Thanks.

    larry
    Thursday, May 01, 2008 11:25 PM
  • This thread is getting too long to track. Your case is a little bit special. Can you start a new thread and we can drive a solution for this? Please let us know on which account your SSRS is running under in different tests you tried.

    Friday, May 02, 2008 6:13 AM
  • Please add no. 6:

     

    6. Open SQL Server Configuration Manager -> Protocols for Your Server Name -> TCP/IP ->

    fill out for the ip1 : Enable = true,  Ip Address = your Ip Address, Port = 1433, Dynamic = Empty

     

    Dan

    Monday, May 19, 2008 8:11 PM
  •  

    Your solution is what I have been waiting for.

     

    How do you do this:

     

    putting sqlservr.exe and sqlbrowser.exe as an exception in the windows firewall

     

    I am getting the error you are addressing not on a server but on my stand alone machine. So I am clueless as to how to put those two files as exceptions in the windows firewall.  Please feel free to send me the solution directly to my email. It is mitikavuma@hotmail.com.

     

    Thanks,

     

    Wango

    Friday, July 04, 2008 7:18 PM

  • But I didn't get any problem with that, wango


    microsoft crm 3.0 customization
    Monday, August 18, 2008 9:41 AM

  • I had the same errormessage and after 3 hours of searching, i found the answer(for me).

    I was programming a simple C++ application. in this application i created a connection with a sql-database which is located on the same computer as the client-program(which i made). I tried all of your options you showed on the site, but eventually i noticed my connection string was the problem all the time...(yes im stupid). i forgot that in code, a single backslash is useled(\), you have to replace it by 2 backslashed(\\). After applying this change, it workedSmile.

    I hope anyone can use this information, i felt stupid but glad when i fount the errorSmile

    Cheers!
    • Proposed as answer by sqlsavvy Saturday, June 11, 2011 12:45 AM
    Sunday, November 02, 2008 7:19 PM
  • For me -
    Visual Studio 2008 Sp1 + SQL Server 2008 Express
    worked the following:
    Just enabled TCP\IP connection protocol in SQL Server management console and Disabled that Named pipes for good.
    Tuesday, March 03, 2009 2:15 PM
  • I did the same but not working for me. I am trying to connect the sql2000 from vs2008 UI. I have server2003 R2 OS. there are 2 different servers each for source and database.
    If I do use the default iis of vs2008 it connects to sql2000, but not working when I am using IIS of windows..
    Friday, April 03, 2009 3:20 PM
  • An error has occurred while establishing a connection to the server when connecting to SQL server 2005, this failure may be caused by the fact that under default settings SQL server does not allow remote connection. ( provider: Named Pipes Provider, error: 40 – could not open a connection to SQL server. )

    Fix/Workaround/Solution:
    Step 1) Make sure SQL SERVER is up and the instance you try to connect is running.
    Step 2) Your system Firewall should not block SQL Server port.
    Step 3) Go to Computer Management >> Service and Application >> SQL Server 2005 Configuration >> Network Configuration
    Enable TCP/IP protocol. Make sure that SQL SERVER port is by Default 1433.
    Step 4) Now follow this KB Article of MSDN depending on your server :http://support.microsoft.com/default.aspx?scid=kb;EN-US;914277 .

    Friday, May 15, 2009 5:41 PM
    • Proposed as answer by satish phadke Monday, August 24, 2009 6:58 AM
    Wednesday, July 22, 2009 4:14 AM
  • I have faced the same problem. Actually i have changed my admin password. If you have changed your administrator password in between please folow below step to make changes in SQL server.
    Open SQl Server Configuration Manager.
    Right Click on the SQL server
    Select Properties
    Change the Logon details ( If you have changed the password)

    I think this will resoved the issue.
    Mr
    Monday, August 24, 2009 7:02 AM
  • Come on boys , what are those badges for ??????

     

    Did you checked this link before installing ???  http://msdn.microsoft.com/en-us/library/ms143506.aspx

    the problem is SQL setup program passes the prequisties but actually it shouldn't !!!!

    for example SQL 2008 ENTERPRISE wouldn't work on WINDOWS 7 Professional 64Bit    !!!!!!!

    Plz say thanks !!!:-p

     

    Friday, August 06, 2010 7:22 PM
  • Thanks man... the problem was the wrong name!
    Sunday, November 07, 2010 6:49 PM
  • Thank you soooooooooooo much !thanks to you I found the solution!
    Thursday, March 17, 2011 2:36 AM
  • Hi please send me the resolution Thanks
    Tuesday, March 22, 2011 2:18 AM
  • Oh Rob.............I can't even thank you enough for making me realize the same mistake. I was struggling for 4 days connecting from sql server 2008 to vs 2008. I could finally do that now after replacing'\' with '\\' in the connection string.

    Thanks a bunch.

    Saturday, June 11, 2011 12:41 AM
  • I had this error message and the solution was turning off the windows firewall in the sql server I was trying to connect to. I was not able to telnet to the port (i.e. 1433).
    Paulino
    Thursday, June 16, 2011 8:14 PM
  • Hi,

    I also faced the same problem when connecting to my local sql server. The reason was recently I installed sqlexpress as well (in addition to the SQL Server 2008 R2) as a part of a CRM tool. Before that I could connect to the SQL server by just giving the machine name. But after installing another instance (sqlexpress), I should give the instance name as well even when connecting to sql server R2. e.g. machinename\instancename. only the machine name won't work.

     

    Hope this will be helpful.

    Regards,

    Sachith


    Sachith Chandrasiri
    Tuesday, November 01, 2011 12:00 PM
  • This option worked for me!!! thanks too to Nan Tu.
    Friday, June 29, 2012 3:12 PM
  • Hi. I had the same error. I was working with SQL Server 2000 and i could not connect from my app in C# nor SQL Server 2008 Management Studio. After to check and recheck services and configurarions in the server (i recommend so much try the other advises first) i add my windows login used in mi PC (from i wanted to connect) in the Server. Somebody told me its important about security in the network (talking about domains).

    Also, i add the IP Server and its name in the files hosts and lmhosts in my PC.

    I hope to be helpful.

    Wednesday, January 08, 2014 4:20 PM
  • Hi Steve,

    I have also faced the same relevant issue "Named Pipes Provider, error: 40 - Could not open a connection to SQL Server", I did resolved with the given below steps.

    1. You have to check for "SQL Server Services" running fine.
    2. You have to also check for "SQL Server (MSSQLSERVER)" running fine.
    3. You have to make assure that "SQL Server Browser" running fine (green marked)
    4. You have to delete all "Aliases" & create new ones according to requiremenns.
    5. You have to check for "SQL Server Default Portal 1433" has been assigned or not. 
    6. You can check for default port click on left pane "Client Protocols" then click on right "TCP/IP" then right click and click on "properties", you will check here default port "1433"

    7. Now open your "SQL Server Management Studio" right click, click on property and click on "Connections" tab, check for option "Allow remote Connections to this server".

    Hope it will resolve your problem, you may check this article Named Pipes Provider, error: 40 - Could not open a connection to SQL Server has given step by step with snapshots.

    thanks,


    Thursday, February 20, 2014 5:39 AM
  • >2. You have to also check for "SQL Server (MSSQLSERVER)" running fine.

    That means the default instance of SQL Server.

    A named instance would appear like "SQL Server (LONDON)" as an example.

    BOL: http://technet.microsoft.com/en-us/library/ms165614(v=sql.90).aspx


    Kalman Toth Database & OLAP Architect SELECT Video Tutorials 4 Hours
    New Book / Kindle: Exam 70-461 Bootcamp: Querying Microsoft SQL Server 2012



    • Proposed as answer by sai sharan Friday, June 13, 2014 5:30 AM
    Thursday, February 20, 2014 8:08 AM
  • For named pipes error 40 or error 2

    solution

    _______

    GO TO   START--->MICROSOFT SQL SERVER 2012-->CONFIGURATION TOOLS-->SQL SERVER CONFIGURATION MANAGER-->SELECT--.>SQL SERVER SERVICES-->RIGHT CLICK ON SQL SERVER(MSSQLSERVER) SELECT START

    Friday, June 13, 2014 5:53 AM