none
missing Microsoft.SqlServer.ManagedDTS

    Question

  • Hi

    I am trying to run a SSIS package first time through vb.net console application. As the first step, i was trying to add the reference for Microsoft.SqlServer.ManagedDTS assembly but it was not in the available assemblies list box in visual studio 2003!

    Please guide what i am supposed to do to get it, or if there any other alternative.

     

    Thanks in advance

    Utsav

    Wednesday, August 30, 2006 10:32 AM

Answers

  • In the Add Reference dialog window, click on the browse tab.  Then navigate your way to:

    C:\Program Files\Microsoft SQL Server\90\SDK\Assemblies

    There you will find the Microsoft.SQLServer.ManagedDTS.dll, select it and hit okay...

     

    Wednesday, August 30, 2006 2:05 PM
  • ManagedDTS runs in process. If the console app is running on a machine that does not have SSIS loaded on it you will not be able to reference the dll. The application will also crash at the point that you attempt to access DTS objects. This also causes problems if you are executing packages that contain static paths. Because the package runs on the client machine, the paths will be assumed to be local. My solution to this was to create a web service that executes the packages on the server. Unfortunately, this aproach seems to be a huge chore, as I am having problems passing the credentials to the package app object. If anyone has any experience with this, some guidance would be greatly appreciated.
    Friday, March 23, 2007 1:32 PM

All replies

  • In the Add Reference dialog window, click on the browse tab.  Then navigate your way to:

    C:\Program Files\Microsoft SQL Server\90\SDK\Assemblies

    There you will find the Microsoft.SQLServer.ManagedDTS.dll, select it and hit okay...

     

    Wednesday, August 30, 2006 2:05 PM
  • ManagedDTS runs in process. If the console app is running on a machine that does not have SSIS loaded on it you will not be able to reference the dll. The application will also crash at the point that you attempt to access DTS objects. This also causes problems if you are executing packages that contain static paths. Because the package runs on the client machine, the paths will be assumed to be local. My solution to this was to create a web service that executes the packages on the server. Unfortunately, this aproach seems to be a huge chore, as I am having problems passing the credentials to the package app object. If anyone has any experience with this, some guidance would be greatly appreciated.
    Friday, March 23, 2007 1:32 PM
  • See Michael Entin's recent post on this (http://blogs.msdn.com/michen/default.aspx).
    Friday, March 23, 2007 2:20 PM
    Moderator
  • Hello everybody,

    I do have SSIS installed on my box, but the Microsoft.SqlServer.ManagedDTS isn't available in the aforementionned folders.
    It is in fact installed in the GAC. How can i still reference the DLL?? By the way, I looked on our SQL server box, and there it is also installed in the GAC and not available in the folders.
    Thanks in advance
    Thursday, April 10, 2008 4:31 PM
  • Found: Just needed to reinstall the SDK of SQL server which wasn't probably done at initial install

     

    Friday, April 11, 2008 12:25 PM
  • Where did you find the SDK? I am having the same problem and cant find it on any of the disks. I have all the SQL Server 2005 disks.

    Thanks
    Prem
    Friday, December 05, 2008 5:39 PM
  • Make sure that when you install, you select all th options under the client tools - it's one of those.

    Monday, December 08, 2008 5:58 PM
    Moderator
  • Hi,

    I am facing the same problem. I have the SSIS installed on my VPC, but unable to find this dll in the ProgramFiles folder.

    I need to write .Net code to invoke my SsIS package, and I believe it's not possible without having this dll referenced in my code.

    Please help.

    Wednesday, June 30, 2010 12:11 PM
  • 1. Run C:\Windows\assembly\gac_msil in the Run box from Start

    2. Find the dll in folder Microsoft.SqlServer.ManagedDTS

    3. Copy the dll

    • Proposed as answer by quan585 Thursday, January 26, 2012 3:58 PM
    Thursday, January 26, 2012 3:57 PM
  • this works for me, thanks!
    Monday, May 07, 2012 5:45 PM