none
Cannot connect to Sql server 2005 database engine

    Question

  • Hello everybody!

    I am having problems to connect to Sql Server Database Engine. I have recently(yesterday) installed Sql Server 2005 Developer Edition. The installation was totally successfull. Yesterday I was able to connect to Sql Server Database engine via SSMS but today it gives me an error:

    A connection was successfully established with the server, but then an error occurred during the pre-login handshake. (provider: Shared Memory Provider, error: 0 - No process is on the other end of the pipe.) (Microsoft SQL Server, Error: 233)

    For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&EvtSrc=MSSQLServer&EvtID=233&LinkId=20476

    It is strange because only one day before It worked fine.

    Thanks a lot


    Tuesday, August 28, 2007 2:14 PM

Answers

  • WinXP comes with System Restore so roll the operating system back one month if you can see restore point that far back.  Then copy all SQL Server related files to your c drive and run setup and choose repair, if repair is not available run fresh install.  Hope this helps.

     

    Wednesday, August 29, 2007 3:07 PM
  • Everything was resolved!

    It was because of the SSL certificates that Sql Server 2005 Database Engine could not be installed.
    I removed all the certificates and reinstalled Sql Server. Everything was Ok!

    Thank you for help!
    Friday, August 31, 2007 2:40 PM

All replies

  • Never seen that error before.  Try restarting the SQL Server service.

    Tuesday, August 28, 2007 2:39 PM
  • It means that you don't have credentials to access the server, you could increase the numbers of connection with sp_configure.  Try the link below for details.

     

    http://blogs.msdn.com/sql_protocols/archive/2007/05/16/named-pipes-provider-error-40-could-not-open-a-connection-to-sql-server-microsoft-sql-server-error-xxx.aspx

     

    Tuesday, August 28, 2007 3:26 PM
  • At the risk of being too basic - I assumed you've followed all the steps here, correct?

    http://msdn2.microsoft.com/en-us/library/ms345343.aspx

     

    Buck

    Tuesday, August 28, 2007 7:51 PM
    Moderator
  • Well, things are getting more difficult here.

    A friend of mine uninstalled Sql Server from my computer, and I can't install it again. I can install all the components except the Database engine. The error is the same that I got when I tried to connect to Sql Server Database engine before it was uninstalled.

    I tried to install the same Edition in another computer(Windows XP) and I face the same problem. I can not install the database engine. How can I use the sp_configure store procedure if I don't have any instance installed?

    Also I can't change, enable or disable the protocols from Sql Server 2005 Surface Area Configuration because of the lack of the instances.

    Thank you for your help!


    Wednesday, August 29, 2007 10:32 AM
  • At this point I can not follow these steps because I don't have any instance installed.
    I must install the database engine immediately but It always fails because of the same error:

    A connection was successfully established with the server, but then an error occurred during the pre-login handshake. (provider: Shared Memory Provider, error: 0 - No process is on the other end of the pipe.) (Microsoft SQL Server, Error: 233)

    Anything to do?
    Thank U
    Wednesday, August 29, 2007 3:00 PM
  • WinXP comes with System Restore so roll the operating system back one month if you can see restore point that far back.  Then copy all SQL Server related files to your c drive and run setup and choose repair, if repair is not available run fresh install.  Hope this helps.

     

    Wednesday, August 29, 2007 3:07 PM
  • Everything was resolved!

    It was because of the SSL certificates that Sql Server 2005 Database Engine could not be installed.
    I removed all the certificates and reinstalled Sql Server. Everything was Ok!

    Thank you for help!
    Friday, August 31, 2007 2:40 PM
  • Excuse me for my English

     

    I’m Italian

     

    Thank you very mach for your information

    I had same problem

    I read a LOT of internet information without solution.

    The problem was on certificate such you have written.

     

     

    Have o good life

     

    Monday, October 08, 2007 9:36 AM
  • I am a fresher. Please guide me how to remove these certificates.
    Friday, October 15, 2010 6:53 PM