none
The configuration environment variable was not found

    Question

  • I have a Master Package that executes a number a child packages.

     

    In my SSIS Package Configuration:

     

    1.  I have an SSIS Configuation table that holds the connection string.

     

    2.  An XML Configuration File with a setting of configuration location stored in an enviornmental variable.

     

    3. And finally, an Eveniornmental variable with the setting of ProjectFolderAbsolutePath value, where it is the full path of the project folder.

     

    The project functions normally but everytime I open it I get the following error.


    " Warning loading MasterPackage.dtsx: The configuration environment variable was not found.  The environment variable was: "EnviorVariable". This occurs when a package specifies an environment variable for a configuration setting but it cannot be found. Check the configurations collection in the package and verify that the specified environment variable is available and valid."

     

    Can anyone help me resolve this issue?

     

    Thanks 

    Monday, July 28, 2008 10:25 PM

Answers

  • Thanks, the spelling was correct.

     

    What I found was that I needed to actually make an enviornmental variables in control panel, system, advanced tab, enviornmental variable and make a variable with the same name I had named and then re-boot the computer for it to take effect.

     

    Thanks

    Thursday, July 31, 2008 10:10 PM

All replies

  • Have you checked the spelling of your environment variable name?

    Monday, July 28, 2008 11:53 PM
  • Thanks, the spelling was correct.

     

    What I found was that I needed to actually make an enviornmental variables in control panel, system, advanced tab, enviornmental variable and make a variable with the same name I had named and then re-boot the computer for it to take effect.

     

    Thanks

    Thursday, July 31, 2008 10:10 PM
  • Thanks Kajoo, I was facing the same issue with a DTS package created by someone else. This helped me pinpoint it.
    Tuesday, December 20, 2011 8:09 AM
  • I had the same issue. After creating the system environment variable you need to reboot the machine; as sometimes the environment variable is not recognised(if your BIDS is open at the time of environment varialbe creation.) I shared my experience her as well

    http://www.singhvikash.in/2010/12/ssis-configuraion-why-ssis-package-do.html 


    Vikash Kumar Singh || www.singhvikash.in
    Tuesday, December 20, 2011 8:25 AM