none
TITLE: Connect to Server --Cannot connect to PONTING-HP\MSSQLSERVER. - ADDITIONAL INFORMATION: A network-related or instance-specific error occurred while establishing a connection to SQL Server

    Question

  • recently i downloaded sql server 2008 enterprise evaluation and i kept default instance but when i tried to connect to SSMS i got error 87..even i already have sql server 2008 express edition so i thought it would upgrade. Also when i installed again and kept the named instance then i can able to connect to sql server.

     

    So pls help me in this...

     

    Pranav Patel 

    Saturday, June 18, 2011 7:37 AM

Answers

  • recently i downloaded sql server 2008 enterprise evaluation and i kept default instance but when i tried to connect to SSMS i got error 87..even i already have sql server 2008 express edition so i thought it would upgrade. Also when i installed again and kept the named instance then i can able to connect to sql server.

     

    So pls help me in this...

     

    Pranav Patel 

    Hi Pranav,

    If you are make a remote connection,pleae check the following items:

     a. Check the server on which SQL Server is running can be accessible. You can use ping command to test that. For instance, ping <computer_name> or ping <IP_address>. The ping command may be block by the firewall, make sure ICMP is enabled in the firewall. More info, check: http://technet.microsoft.com/en-us/library/cc739791%28v=ws.10%29.aspx#BKMK_4.

    b. Choose appropriate protocol

    c. Configure Windows firewall accordingly based on what protocol you have chosen to use. For detailed information about how to configure Windows Firewall to allow SQL Server, please check http://msdn.microsoft.com/en-us/library/cc646023.aspx.

    d. Enable SQL Server Browser Services
    You need to enable SQL Server Browser Services if the following are both true:

    1. SQL Server is not listening on default 1433 port or not use default pipe name \\.\pipe\sql\query;
    2. The corresponding TCP port or pipe name is not specified in the connection string (such as Srv1\SQL2008, 1500).

    By the way, if you have enabled SQL Server Browser Services, you still need to open UDP 1434 port which is used by Browser Services in the Windows firewall. To make sure you have properly configured SQL Server Browser Services, you can use PortQry.exe, PortQryUI.exe or telnet to test. There tools are easy to find in the Microsoft Download Center.

    Hope this helps.


    Best Regards,
    Peja

    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Peja Tao Monday, June 27, 2011 2:56 AM
    Tuesday, June 21, 2011 2:59 AM

All replies

  • recently i downloaded sql server 2008 enterprise evaluation and i kept default instance but when i tried to connect to SSMS i got error 87..even i already have sql server 2008 express edition so i thought it would upgrade. Also when i installed again and kept the named instance then i can able to connect to sql server.

     

    So pls help me in this...

     

    Pranav Patel 

    Hi Pranav,

    If you are make a remote connection,pleae check the following items:

     a. Check the server on which SQL Server is running can be accessible. You can use ping command to test that. For instance, ping <computer_name> or ping <IP_address>. The ping command may be block by the firewall, make sure ICMP is enabled in the firewall. More info, check: http://technet.microsoft.com/en-us/library/cc739791%28v=ws.10%29.aspx#BKMK_4.

    b. Choose appropriate protocol

    c. Configure Windows firewall accordingly based on what protocol you have chosen to use. For detailed information about how to configure Windows Firewall to allow SQL Server, please check http://msdn.microsoft.com/en-us/library/cc646023.aspx.

    d. Enable SQL Server Browser Services
    You need to enable SQL Server Browser Services if the following are both true:

    1. SQL Server is not listening on default 1433 port or not use default pipe name \\.\pipe\sql\query;
    2. The corresponding TCP port or pipe name is not specified in the connection string (such as Srv1\SQL2008, 1500).

    By the way, if you have enabled SQL Server Browser Services, you still need to open UDP 1434 port which is used by Browser Services in the Windows firewall. To make sure you have properly configured SQL Server Browser Services, you can use PortQry.exe, PortQryUI.exe or telnet to test. There tools are easy to find in the Microsoft Download Center.

    Hope this helps.


    Best Regards,
    Peja

    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Peja Tao Monday, June 27, 2011 2:56 AM
    Tuesday, June 21, 2011 2:59 AM
  • hey thanks for prompt reply but i installed sql server enerprise evalution 2008 in my laptop...so when i named instance it working fine but cant able to connect default instance...
    Tuesday, June 28, 2011 4:52 AM
  • Hi ,

    Thank you for your feedback. Have your tried the IP address as the default instance name? And could you please post the detailed error message?


    Best Regards,
    Peja

    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, June 28, 2011 8:46 AM