none
Error installing Adventureworks - Full Text Search Missing (was:Full Text Search)

    Question

  •  I was installing Adventure Works database for SQL 2008 Evaluation on Windows Vista Home Premium but couldn't complete it because of the following error message:

    "PreInstance() failed for MSSQLSERVER.
    The following features are missing: Full Text Search
    Fix the problems and re-run setup."

    During SQL Installation this feature was selected. Can somebody please help me fix this problem.

    Thanks in advance
    • Edited by Aaron AltonModerator Sunday, December 21, 2008 2:36 AM Title wasn't indicitave of the issue.
    Saturday, December 20, 2008 9:26 AM

Answers

  • Zanta, you just need to make sure that the the full text filter daemon launcher (which iG4 mentioned) is running before restarting the installation.


    If you care about the boring details under the hood, here they are: Unfortunately, the MSI needs to be "elevated" in order to start the service (which it tries to do if the filter daemon is not running); however, unless you start the MSI with elevated permissions, the initial custom actions that check for prerequisites will not be elevated (only the deferred CAs will prompt for elevation). Catch-22, chicken-egg, whatever you want to call it.
    David Reed - MSFT - Microsoft Certified Architect|SQL Server - http://blogs.msdn.com/reedme/
    Wednesday, February 18, 2009 5:44 PM
  • Howdy, jgillin. You should generally use the "Sql Server Configuration Manager" not services.msc for managing SQL Server services; there are some aspects of changing SQL Server config that services.msc is not aware of (especially when changing service identities, etc).

    That said, what you're looking for is the display name SQL Full-text Filter Daemon Launcher (instancename) where instancename is MSSQLSERVER for the default instance or whatever you named it if it's not. That's the service that must be started in order for all things full-text to work.

    The service name under the hood (for use with net start, etc) is MSSQLFDLauncher[$instancename] where $instancename is the instance name for non-default instances.
    David Reed - MSFT - Microsoft Certified Architect|SQL Server - http://blogs.msdn.com/reedme/
    Friday, March 13, 2009 2:52 PM

All replies

  • Have you checked "Full Text Search" when install SQL 2008? It is unchecked by default I think.
    This posting is provided "AS IS" with no warranties, and confers no rights.
    Monday, December 22, 2008 6:09 AM
  • Yes I have done that but it didn't work
    Monday, December 22, 2008 5:20 PM
  • I had the same error. So I reinstall SQl server 2008, I found When selected "Full-text",
    There are "SQL Full-text Filter Daemon Launchar" at "Server Configuration", By default "Account Name" is empty, I set its value are same as "SQL Server Browser", and install SQL Server 2008. then I install "SQL2008.AdventureWorks_All_Databases.x86.msi" successful.
    I think there should be 2 ways, one when installing 2008 setup "Full-text", another should be setup "full-text".
    Monday, February 16, 2009 8:46 PM
  • Zanta, you just need to make sure that the the full text filter daemon launcher (which iG4 mentioned) is running before restarting the installation.


    If you care about the boring details under the hood, here they are: Unfortunately, the MSI needs to be "elevated" in order to start the service (which it tries to do if the filter daemon is not running); however, unless you start the MSI with elevated permissions, the initial custom actions that check for prerequisites will not be elevated (only the deferred CAs will prompt for elevation). Catch-22, chicken-egg, whatever you want to call it.
    David Reed - MSFT - Microsoft Certified Architect|SQL Server - http://blogs.msdn.com/reedme/
    Wednesday, February 18, 2009 5:44 PM
  • Interesting. I'm having the same problem.
    I do have Full Text installed. I very specifically remember checking it and the query

    SELECT SERVERPROPERTY('IsFullTextInstalled')

    returns 1

    However, oddly enough, I do not have a service named MSSQLFDLauncher in my services panel. Any thoughts on this?
    Friday, March 13, 2009 1:08 PM
  • Also, I noticed that in the Binn directory, there is no fdlauncher.exe, but fdhost.dll and a fd.dll do exist.
    Friday, March 13, 2009 1:50 PM
  • Howdy, jgillin. You should generally use the "Sql Server Configuration Manager" not services.msc for managing SQL Server services; there are some aspects of changing SQL Server config that services.msc is not aware of (especially when changing service identities, etc).

    That said, what you're looking for is the display name SQL Full-text Filter Daemon Launcher (instancename) where instancename is MSSQLSERVER for the default instance or whatever you named it if it's not. That's the service that must be started in order for all things full-text to work.

    The service name under the hood (for use with net start, etc) is MSSQLFDLauncher[$instancename] where $instancename is the instance name for non-default instances.
    David Reed - MSFT - Microsoft Certified Architect|SQL Server - http://blogs.msdn.com/reedme/
    Friday, March 13, 2009 2:52 PM
  • I successfully loaded SQL Server 2008 express. When I go to the Configuration Manager under SQL Server 2008, I only see 3 items. SQL Server (SQLEXPRESS), SQL Server Agent (SQLEXPRESS), SQL Server Browser.  SQL Server Agent is stopped and the others are running.  SQL Server is not started at this time. Where do I find the Daemon Launcher?
    Thursday, May 21, 2009 5:28 PM
  • How do you do this? I had no trouble doing this for SQL 2005 but with 2008 & can't even seem to get Server Management working. I've tried so many times it's frustrating
    Unfolding meaning through values
    Tuesday, May 26, 2009 6:02 AM
  • Ok so I tried to start the service from the SQL Server Config manager and it said it was disabled.  I was not able to enable the service because the start menu was disabled.  I started the SQL Server Agent and that let me start the Full-Text Daemon.

     

    In short I just start to turn on the services and finally it let me talk to the Full-Text

     

    Hope this helps

     

    Stewart Rogers

    DataSort Software

    Friday, May 29, 2009 2:04 AM

  • Go to SQL Server Config Manager
    Locate and double click the Full-Text Filter Daemon launcher and switch it from disable to manual. Then click Apply. After you have set it to manual you can start the service.

    Tuesday, June 09, 2009 1:38 PM
  • What worked for me was installing Express with Advanced Services. I installed to a new instance and full-text search was one the check boxes. i had to reinstall VS2k8 sp1 even though it was already installed. But afterwards this worked for me. Hope it helps you move on.
    • Proposed as answer by Checker Friday, June 12, 2009 1:24 AM
    Friday, June 12, 2009 1:23 AM
  • I had the same situation.  I remembered that full text search was the only component that didn't successfully install.  I tried to add full text search from the sql 2008 evaluation dvd and it kept failing.  I found this MS support link explaining that when you try to install SQL Server 2008 from the DVD, the Full Text Search Installation may fail if you have previously installed SQL Server 2008 Express Edition (which I had done).  I wrote the dvd contents locally and successfully installed the full text search component as well as the AdventureWorks database.  Here's the link:

    http://support.microsoft.com/kb/967103

    Hope this helps.
     
    Thursday, June 18, 2009 5:39 PM
  • Hi, I also use SQL Server 2008 evaluation edition, but the option 'Full text search' can't be found from the 'SQL Server Services' list. So how can I enable this feature?

    I remembered all of parts have been installed.
    Thursday, June 25, 2009 6:02 AM
  • I'm having the same problem.
    Downloaded the Express Version of SQL Server 2008, and it seems that it doesn't have Full-text search service.
    Just found this page (Installing Adventure Works with and WITHOUT Full-text search)
    http://www.ssas-info.com/analysis-services-faq/29-mgmt/242-how-install-adventure-works-dw-database-analysis-services-2005-sample-database
    Hope it works.

    I'll update my post as soon I test it.
    Sunday, June 28, 2009 10:03 PM
  • Me toooo.....
    When trying to Start the SQL Server Agant (SQLEXPRESS) I get:
    The service cannot be started, either because it is disabled or because it has no enabled devices associated with it. [0x80070422]

    So: 1) No Agent 2) No Text Search 3) No AdventureWorks

    Please help (maybe they force us to buy the complete SQL Enterprise .....???)
    ADH
    ADH
    Friday, July 24, 2009 6:20 AM
  • Thank you Aaron. It worked.
    Friday, August 14, 2009 5:43 PM
  • I'm having the same problem.

    "PreInstance() failed for MSSQLSERVER.
    The following features are missing: Full Text Search
    Fix the problems and re-run setup."

    I didn't install from a CD - all from the download of the SQLExpress version.  I've tried to re-install several times.  No soap.  Help.  :-(

    BTW there is no "full text filter daemon launcher " feature in my "Sql Server Configuration Manager".   I also checked the "full text search" when I installed the second time, but I think I missed it the first time.



    • Proposed as answer by AlanCam Thursday, September 03, 2009 9:49 PM
    Thursday, August 27, 2009 7:09 AM
  • There are a couple of HotFixes I found somewhere by searching..
    365597_intl_i386_zip.exe and 366379_intl_i386_zip.exe
    I requested them and the link was sent to me. I downloaded them but when I came to instal them the passwords provided did not work.
    Alan Cameron
    Thursday, September 03, 2009 9:51 PM
  • You need SQL Server Express with Advanced Services.  Regular SQL Server Express does not have Full Text services.  See http://msdn.microsoft.com/en-us/library/ms365248.aspx for details.


    Bonnie Feinberg [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights
    Monday, October 19, 2009 7:33 PM
  • Does anyone have the solution?
    1. SQL Server Enterprise Evaluation.
    2. Windows Enterprise 2003 fully patched.
    3. Visual Studio 2008 Professional.
    4. I first installed SQL Server without the FULLTEXT Search.
    5. I ran the Installation later from the DVD - Add Features.
    6. The Full Text Search Option button was there in the list and was available: I checked it ON.
    7. The installation FAILED. The Log was useless - it did not explain why it failed.

    Does anyone have a solution?
    +__+
    Friday, November 13, 2009 2:46 PM
  • Hi,


    First of all,Full text search is an option during the installation steps.
    If you have installed it fine! otherwise get back to the installation page and select add feature to the existing instance.


    Then the full text search is also not started automatically as a service.by default it is not started sometimes even disabled.
    activate it and start the service.then you can proceed with the installation.*****


    Hope that help.



    Tuesday, November 17, 2009 6:17 PM
  • To all:

    This is how I solved this problem:

    1)  Opened Sql Server Configuration manager.

     

    2)   Right-Clicked the instance name (In my case: SQLEXPRESS2008) & SELECTED PROPERTIES.

     

    3)  Selected FILESTREAM tab and selected the 'Enable FILESTREAM for Transact-SQL access box.


    4)  Selected apply and then okay button

    After about a minuet or two of processing, my FILESTREAM daemon reflected my instancename. I was good-to-goo!!


    Tom Johnson
    • Proposed as answer by Mattaniah Friday, May 21, 2010 12:09 PM
    Thursday, December 17, 2009 7:53 PM