none
Report Execution timeout after 5 min

    Question

  • We have a report Model, and clients create various reports based on this report model. Some intensive reports gets timeout after around 5 minutes (We have timed this many times). I was not able to point out where this 5 minute timeout is set.If someone could guide to the point / setting where this timeout is set, I would be grateful.

    Additional Info (But none of them is 5 minutes )

    1.Report execution timeout  for the report is set as DEFAULT (1800 Sec)

    2.Datasource Query timeout setup is '0' (meaning unlimited)

    3.In RSReportServer.config have the 120 s as the DatabaseQuerytimeout value

    4.web.config file in the folder “C:\Programme\Microsoft SQL Server\MSSQL.2\Reporting
    Services\ReportManager have "executionTimeout" as 9000

    5.IIS web site Connection Timeout is 120 sec.

    Error Received:

    REPORT EXECUTION ERROR

    Semantic query execution failed. A severe error occurred on the current command.  The results, if any, should be discarded.
    ----------------------------
    Cannot read the next data row for the data set dataSet.
    ----------------------------
    An error has occurred during report processing.


    • Edited by canadags Friday, March 08, 2013 6:44 PM
    Friday, March 08, 2013 6:17 PM

Answers

  • Hi ,

      I got the solution for my problem:I changed the Report timeout setting under Site setting under report manager. (Site level setting) to 600 sec from 300 sec.

     

    • Marked as answer by canadags Monday, March 18, 2013 5:14 PM
    Monday, March 18, 2013 5:14 PM

All replies

  • Have you taken the query the report is based on and run it in Management Studio to see if it completes or not?  Could be the query is erroring not the report.  That would be my first step. 
    Friday, March 08, 2013 7:41 PM
  • The Query / report is successful if the filter condition narrows the resultant data. If I change the filter condition value -- Say.. reduce the transaction date interval, the report is generated
    • Edited by canadags Friday, March 08, 2013 7:46 PM
    Friday, March 08, 2013 7:45 PM
  • Hi ,

      I got the solution for my problem:I changed the Report timeout setting under Site setting under report manager. (Site level setting) to 600 sec from 300 sec.

     

    • Marked as answer by canadags Monday, March 18, 2013 5:14 PM
    Monday, March 18, 2013 5:14 PM