none
The version of SQL Server instance Shared Component does not match the version expected

    Question

  • Hi,

     

    I have installed sql 2008 R2 and i need to install sp1.  when i try i get the following message

    The version of SQL Server instance Shared Component does not match the version expected by the SQL Server update. The installed SQL Server product version is 10.50.1600.1, and the expected SQL Server version is 10.0.1600.22

    any ideas why the is  happening?

    Thanks

    Friday, August 06, 2010 3:03 AM

Answers

  • You are trying to apply SQL Server 2008 SP1 to SQL Server 2008R2 RTM.
    MCM: Microsoft Certified Master - SQL Server 2008 | MCT: Microsoft Certified Trainer | MCITP: Database Administrator 2008 | MCITP: Database Developer 2008 | MCITP: Database Administrator | MCITP: Database Developer | MCDBA: Microsoft SQL Server 2000
    Friday, August 06, 2010 3:49 AM
  • H,

    Since SQL Server 2008 and SQL Server 2008 R2 are different versions, you cannot apply SQL Server 2008 SP1 to an instance of SQL2008 R2 as Randall mentioned above. By the way, SQL Server 2008 R2 has not had any released service pack yet, so no action required  to install SP now. You can find the latest SPs,CUs or Hotfixes at http://support.microsoft.com.

    Thanks,
    Chunsong


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Monday, August 09, 2010 8:04 AM
    Moderator

All replies

  • You are trying to apply SQL Server 2008 SP1 to SQL Server 2008R2 RTM.
    MCM: Microsoft Certified Master - SQL Server 2008 | MCT: Microsoft Certified Trainer | MCITP: Database Administrator 2008 | MCITP: Database Developer 2008 | MCITP: Database Administrator | MCITP: Database Developer | MCDBA: Microsoft SQL Server 2000
    Friday, August 06, 2010 3:49 AM
  • i thought this was the correct version?  If not RTM then what version should i be using?

    Thanks


    phill
    Friday, August 06, 2010 3:54 AM
  • SP1 is not yet available for SQL 2008 R2.


    Balmukund Lakhani | Please mark solved if I've answered your question
    --------------------------------------------------------------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.
    --------------------------------------------------------------------------------
    My Blog: http://blogs.msdn.com/blakhani
    Team Blog: http://blogs.msdn.com/sqlserverfaq
    Friday, August 06, 2010 3:57 AM
    Moderator
  • Looks like some of the Shared Components of the earlier installation still exist on the system. Please uninstall those components and try installing SP again
    Pradeep Adiga
    My blog: http://www.sqldbadiaries.com
    Friday, August 06, 2010 4:29 AM
  • H,

    Since SQL Server 2008 and SQL Server 2008 R2 are different versions, you cannot apply SQL Server 2008 SP1 to an instance of SQL2008 R2 as Randall mentioned above. By the way, SQL Server 2008 R2 has not had any released service pack yet, so no action required  to install SP now. You can find the latest SPs,CUs or Hotfixes at http://support.microsoft.com.

    Thanks,
    Chunsong


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Monday, August 09, 2010 8:04 AM
    Moderator