none
Microsoft SQL server error:233

    Question

  • I am getting this error when connecting to sql. I cant get into my databases now- its pretty ugly.

     

    "A connection was succesfulyl established with the server, but then an error occured during the login process.

    (provider: Shared Memeory Provoder, error: 0 - No Process is on the other end of the pipe.)Microsoft SQL server error:233

     

    Anyone who knows what is going on soem help would be much appreciated.

    Mat

    Sunday, September 30, 2007 10:03 AM

All replies

  •  


    Which application do you use connecting to SQL Server ? Did you try another one ? Did you try to see if there are any event log entires for the time trying to connect ?


    Jens K. Suessmeyer

    ---
    http://www.sqlserver2005.de
    ---

    Monday, October 01, 2007 6:19 AM
  • You may also want to try connecting with a different login if you haven't already.

    Joe
    Monday, October 01, 2007 12:21 PM
  • Thanks for the answers guys. I tried every possible login to no avail. I ended up having to remove visual studio, sql server 2005 then .NET framwork. Then reinstalling in that order. Just removing/reinstalling SQL did not work. Took around 5 hours all up.

     

    Pretty soul destroying stuff but thems the breaks I guess.

    Tuesday, October 02, 2007 8:24 AM
  • You could try first checking if the following protocols are enabled from the SQL Server Configuration Manager:

     

    1. Named Pipes

    2. TCP/IP

     

    Also, check from the Surface Area Configuration Manager to find out if your SQL Express Instance is configured to accept remote connections.

     

    Please refer the following link for more help:

    http://msdn2.microsoft.com/en-us/library/bb326280.aspx

     

    HTH

    Tuesday, October 02, 2007 10:28 AM
  • OUCH! Thanks for posting your resolution. I would have hoped you could have found a less drastic measure.

    Joe

    Tuesday, October 02, 2007 11:30 AM
  • I meet , restart your database. To restart your databse at "SQL Server Configuration Manager.

     

    Wednesday, October 08, 2008 5:47 PM
  • hie.. all the solutions are right..
    after trying all.. see your sql server agent[ sql Server configuration manager] also start your server from run-->services.msc]
    it might be stopped.. if it is so.. make it connected from both way i mentioned..

    me too getting same error...

    • Proposed as answer by Dlang Tuesday, August 11, 2009 2:11 PM
    Friday, June 05, 2009 10:03 AM
  • After several frustrating attempts to get this resolved, I completed the following steps to resolve the "Microsoft SQL Server, Errorf:233.  

    1. Log into an administrative account that has access to both the machine and sql server 2005 database
    2. Open up SQL Server Management studio with "Windows Authentication" 
    3. Click on the security folder
    4. Click on "logins"
    5. Then click on the account that is not working 
    6. Answer - Make sure there is a database within the "Database Default"  specified "I placed the admin account to master"

    In my case there was no database specified within the default which put the login into limbo causing the Error:233

    • Proposed as answer by Dlang Tuesday, August 11, 2009 2:23 PM
    Tuesday, August 11, 2009 2:22 PM
  • After restarting the SQL server, i'm able to connect to the Database from my application.
    Tuesday, August 11, 2009 3:53 PM
  • I had similar issue.

    Scenario

    I had an user on SQl as abc(name changed), I deleted the user and without rebooting I created a user with same name as "abc", and tried login to SQL with abc credentials.
    -----
    Error:
    A connection was succesfulyl established with the server, but then an error occured during the login process.

    (provider: Shared Memeory Provoder, error: 0 - No Process is on the other end of the pipe.)Microsoft SQL server error:233

    ---
    I created another user xyz and tried login with same xyz and I was able to login.
    Then I rebooted the machine and tested with abc account and I was able to login.

    Now I deleted xyz and created xyz again, now I was not able to login with xyz with same error.

    It seems when we deleted a user SQL Server requires a reboot, if we want to create user with same name again.
    Wednesday, November 18, 2009 5:53 PM
  • Make sure the user is not disabled

    1. Login as an Administrator into the SqL Server
    2. Expand Security/ Logins folder
    3. Right Click on the particular user and go to properties
    4. Click Status Permission: Granted
     Login : Enabled

    It worked for me after it is enabled

    Monday, December 14, 2009 9:55 PM

  • 1. Login as Administartor
    2. Right click on the Instance name - Server Properties
    3. Security page
    4. Set the Server Authentication - 'SQL Server and Windows Authentication mode'
    5. Restart the SQL Service
    • Proposed as answer by Dynamic Monday, November 29, 2010 6:41 PM
    Monday, January 04, 2010 12:25 PM
  • I have suddenly this same problem with an express 2005 running on XP for years. I've tried evrything you suggested to no avail! the sa login is now useless. Any new suggestion?

     

    Thanks

    Monday, March 29, 2010 4:04 PM
  • Hiiii

     

    Thanks Guys its worked for me.Especially Thanks 2 Moshez

    Friday, May 28, 2010 6:10 AM
  • Thanks for the answers ,i tried everything from the start of the post ,my sql server had everything mentioned here like allow remote connections,tcp/ip,in security in login the user allowed,default db set.finally the one that worked for me was a simple step go to the services and click sql server and stop it and then start it again there,it worked :-) cant believe this simple thing kept me wondering for hours how to fix it

     

    Tuesday, August 31, 2010 7:25 PM
  • Goto Services.msc and start "SQL Server Browser" Service. It will work.

    Kulbhushan

    Thursday, September 02, 2010 5:51 AM
  • Thanks MosheZ :)
    Monday, November 29, 2010 6:42 PM
  • Hi guys... Here are a few things to check out...

    Make sure that the server is setup to accept both windows and SQL authentication. Right click on the server name in your manement studio and go to properties then security.

    Once you change this setting you will have to restart SQL services.

    Make sure that SA account is enabled and a default database assigned. Also , reset the password just to make sure you know the correct password.

    test logging in to SQL Management Studio using the SA account with the new password after you have restarted the services. Other wise it will not work.

    • Proposed as answer by eamadhavan Wednesday, October 19, 2011 1:59 AM
    Tuesday, November 30, 2010 4:26 PM
  • Make sure your firewall (Windows Firewall/Internet Connection Sharing (ICS)) on the computer is turned off.
    It worked for me, hope same is for you !!
    Tuesday, December 14, 2010 9:16 AM
  • Thanks....I had a similar problem today and resolved by applying above solution.

    Rgds,

    Naresh Pathak

     

    Tuesday, February 01, 2011 8:42 AM
  • Thanks Amit Benerjee, i had similar problem connecting to SQL Server 2008 R2 and now it is resolved by applying your solution.

    Regards,

    Shravankumar Durbha

     

    Monday, February 07, 2011 8:46 AM
  • this worked. although i had the database default selected but not master. once i set it to master, no error.
    Thursday, April 28, 2011 11:11 AM
  • 1. Log into an administrative account that has access to both the machine and sql server 2005 database
    2. Open up SQL Server Management studio with "Windows Authentication"
    3. Click on the security folder
    4. Click on "logins"
    5. Then click on the account that is not working
    6. Answer - Make sure there is a database within the "Database Default" specified "I placed the admin account to master"

    7. Uncheck "Enforce password policy"

    Wednesday, June 22, 2011 11:46 PM
  • Thank you Moshez, it worked for me by adding SQL authentication.
    Thursday, September 08, 2011 1:50 PM
  • Thanks Jesus N, this worked for me.
    Saturday, November 12, 2011 11:16 AM
  •              Plz first login Windows Authentication and when connect database. Right click the SQL Server and select properties and select security tab. and choose second opation SQL Server and Windows Authentication mode. And restart sql service.

    please connect and enjoy.

    Muhammad Imran

    • Proposed as answer by HansWald Wednesday, July 16, 2014 6:35 PM
    Friday, February 24, 2012 11:34 AM
  • Make sure the login is mapped to existing SQL user:

    1. Login as an Administrator into the SqL Server
    2. Expand Security/ Logins folder
    3. Right Click on the particular user and go to properties
    4. Tick the box next to the SQL profile that you want to map this user to.


    It worked for me after it was mapped correctly. Must to have become unmapped when truncating DB logs had to unmapp the DB etc.
    Sunday, April 29, 2012 10:22 PM
  • Just to add another solution...

    Another possible cause of this error is that the maximum number of connections has been exceeded. When I checked the event log, this is the error I found.

    Here's the KB for how to deal with that issue: http://support.microsoft.com/kb/320728

    Shut down the SQL services and run SQL in single user mode from the command line, login as an admin and then change the connection setting.


    - cawood

     blog |  twitter

    Wednesday, August 08, 2012 8:33 PM
  • thanks

    Thursday, December 13, 2012 1:44 PM
  • After several frustrating attempts to get this resolved, I completed the following steps to resolve the "Microsoft SQL Server, Errorf:233.  

    1. Log into an administrative account that has access to both the machine and sql server 2005 database
    2. Open up SQL Server Management studio with "Windows Authentication" 
    3. Click on the security folder
    4. Click on "logins"
    5. Then click on the account that is not working 
    6. Answer - Make sure there is a database within the "Database Default"  specified "I placed the admin account to master"

    In my case there was no database specified within the default which put the login into limbo causing the Error:233


    That worked for me too! Thanks a lot.
    Saturday, December 22, 2012 6:02 PM
  • works for me. :)
    Sunday, December 23, 2012 7:07 PM
  • This is due to password policy . login with window authentication and goto security - > Logins -> select Login user id - >Properties(on mouse right click) ->and check the password and change the policy check box (here password expired after a certain period)  
    Friday, June 21, 2013 11:50 AM
  • In SQL 2008, I needed to log on under Windows Authentication using my Windows Credentials then right click on the Security list item, select Mixed Authentication, then Ok, then I closed SQL Server.  After that I needed to go to Services (Under Control Panel / Administrative Tools) and Stop both the SQL Server Agent and the SQL Server services.  Once both were stopped I Started them both again and then opened SQL Server and was able to login using the SA account.  For me the problem was solved.

    • Proposed as answer by JayDLL Wednesday, September 18, 2013 11:33 AM
    Wednesday, September 18, 2013 11:33 AM
  • You should not propose your own posts as answers - especially when the same information has already been posted and marked.  In addition, your terminology will only confuse the inexperienced.  You "close SQL Server" and "opened SQL Server" - what does that mean?  Perhaps you meant that you closed / opened SSMS - an application that is used to access / manage sql server instances. 
    Wednesday, September 18, 2013 12:53 PM
  • In my situation I had limited the active connections to 2, and some processes were hogging the connection. Setting to 0 worked. Also would only connect to Database first time after opening Sql Server Management Studio, had to close and reopen each time to connect, and because of concurrent connections wouldn't have much time to interact with database.
    Friday, January 03, 2014 2:00 PM