none
Urgent: Prevent Orphaned Header in the page in SSRS report

    Question

  • I have a situation where there is a orphaned tablix header in first page and the rows are in the next page. I have set the Repeat Header rows on each page and Repeat header columns on each page property to true.

    Any help please.


    Birendra Gaihre

    Thursday, October 18, 2012 11:28 PM

Answers

  • Hi Birendra,

    If you are using matrix, your settings is right. However, if you use a table, please refer to the steps below to set it.

    1. Click the coin on the group and select “Advanced Mode”.
    2. Select the first static group on the row groups.
    3. Set the “RepeatOnNewPage” to true in the Properties window.

    If this is an urgent issue, you could contact Microsoft Customer Support Services (CSS) via telephone so that a dedicated Support Professional can assist you in a more efficient manner. Please understand that contacting phone support will be a charged call, but it will be free if this is a product issue. To obtain the phone numbers for specific technology request please take a look at the web site listed below:
    http://support.microsoft.com/default.aspx?scid=fh;EN-US;PHONENUMBERS

    Regards,
    Charlie Liao

    TechNet Subscriber Support
    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.

    • Marked as answer by CRM101 Monday, October 22, 2012 1:41 AM
    Friday, October 19, 2012 3:04 AM
    Moderator
  • Yes, “RepeatOnNewPage”=true works. I had some leftovers from my earlier deletion of group (not sure why not all items were deleted) and that was causing the issue. Thanks Charlie.


    Birendra Gaihre

    • Marked as answer by CRM101 Monday, October 22, 2012 1:41 AM
    Monday, October 22, 2012 1:41 AM

All replies

  • Hi Birendra,

    If you are using matrix, your settings is right. However, if you use a table, please refer to the steps below to set it.

    1. Click the coin on the group and select “Advanced Mode”.
    2. Select the first static group on the row groups.
    3. Set the “RepeatOnNewPage” to true in the Properties window.

    If this is an urgent issue, you could contact Microsoft Customer Support Services (CSS) via telephone so that a dedicated Support Professional can assist you in a more efficient manner. Please understand that contacting phone support will be a charged call, but it will be free if this is a product issue. To obtain the phone numbers for specific technology request please take a look at the web site listed below:
    http://support.microsoft.com/default.aspx?scid=fh;EN-US;PHONENUMBERS

    Regards,
    Charlie Liao

    TechNet Subscriber Support
    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.

    • Marked as answer by CRM101 Monday, October 22, 2012 1:41 AM
    Friday, October 19, 2012 3:04 AM
    Moderator
  • Thanks Charlie. Yes I am using table. I did set the “RepeatOnNewPage”=true and it's not happening. I am looking at pdf exported from the ssrs report.

    Any futher suggestion. 


    Birendra Gaihre

    Friday, October 19, 2012 4:36 AM
  • Hi Birendra,

    It hard to say the root reason cause this issue base on your description. Please describe the report design in more details. If possible, provide us a screenshot and some text data to us so that we can make further analysis and help you out.

    Regards,
    Charlie Liao

    Friday, October 19, 2012 5:38 AM
    Moderator
  • Yes, “RepeatOnNewPage”=true works. I had some leftovers from my earlier deletion of group (not sure why not all items were deleted) and that was causing the issue. Thanks Charlie.


    Birendra Gaihre

    • Marked as answer by CRM101 Monday, October 22, 2012 1:41 AM
    Monday, October 22, 2012 1:41 AM