none
SQL Native Connection Error

    Question

  • My machine cannot connect to any of our SQL Server 2005 boxes using SQL Native client.  The Microsoft OLE DB Provider for SQL Server works fine.  I can also use other machines to connect to the same servers without issues, so I'm sure the problem is specific to my machine.  Here's the error I get:

    Could not retrieve table list.

    Login timeout expired
    An error has occurred while establishing a connection to the server. When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. SQL Network Interfaces: Error getting enabled protocols list from the registry [xFFFFFFFF]. (Microsoft SQL Native Client)

     

    I'm running Vista SP1.  My SQL Native Client is SP2 CU8.  So are the servers.  I have Visual Studio 2008 Pro installed.

     

    Here's the other info from the MSSMS About page:

     

    Microsoft SQL Server Management Studio      9.00.3042.00
    Microsoft Analysis Services Client Tools      2005.090.3042.00
    Microsoft Data Access Components (MDAC)      6.0.6001.18000 (longhorn_rtm.080118-1840)
    Microsoft MSXML      3.0 5.0 6.0
    Microsoft Internet Explorer      7.0.6001.18000
    Microsoft .NET Framework      2.0.50727.3053
    Operating System      6.0.6001

     

    Any ideas on how to fix this?

     

    Thanks!

    Brian

     

     

    Thursday, September 18, 2008 7:05 PM

Answers

  • This looks like a registry is corrupted.

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\Client\SNI9.0

    ProtocolOrder should be REG_MULTI_SZ with default

    "sm
    tcp
    np
    "

    ProtocolsSupported should be REG_MULTI_SZ with default

    "sm

    tcp

    np

    via"

    (make sure each protocol uses one line)

     

    Or, you can try uninstall/reinstall SNAC.

     

    Thanks.

    Friday, September 19, 2008 4:56 PM
    Moderator

All replies

  • This looks like a registry is corrupted.

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\Client\SNI9.0

    ProtocolOrder should be REG_MULTI_SZ with default

    "sm
    tcp
    np
    "

    ProtocolsSupported should be REG_MULTI_SZ with default

    "sm

    tcp

    np

    via"

    (make sure each protocol uses one line)

     

    Or, you can try uninstall/reinstall SNAC.

     

    Thanks.

    Friday, September 19, 2008 4:56 PM
    Moderator
  •  

    That fixed it!

     

    Thanks,

    Brian

    Friday, September 19, 2008 5:03 PM
  • I had an issue that was fixed by your posted solution.  Thank you so much! 

     

    Tuesday, December 09, 2008 4:23 AM