none
HTTP Error 500.23 - Internal Server Error. An ASP.NET setting has been detected that does not apply in Integrated managed pipeline mode.

    General discussion

  • When i upload my website using Filezilla and run login page, i get the following error:

    HTTP Error 500.23 - Internal Server Error

    An ASP.NET setting has been detected that does not apply in Integrated managed pipeline mode.

     

    <fieldset><legend>Detailed Error Information</legend>
    Module ConfigurationValidationModule
    Notification BeginRequest
    Handler StaticFile
    Error Code 0x80070032
    Requested URL http://www.onkarelearnings.com:80/PM
    Physical Path f:\inetpub\vhosts\onkarelearnings.com\httpdocs\PM
    Logon Method Not yet determined
    Logon User Not yet determined
    </fieldset>
    <fieldset><legend>Most likely causes:</legend>
    • This application defines configuration in the system.web/httpHandlers section.
    </fieldset>
    <fieldset><legend>Things you can try:</legend>
    • Migrate the configuration to the system.webServer/handlers section. You can do so manually or by using AppCmd from the command line - for example, %SystemRoot%\system32\inetsrv\appcmd migrate config "Default Web Site/". Using appcmd to migrate your application will enable it to work in Integrated mode, and continue to work in Classic mode and on previous versions of IIS.
    • If you are certain that it is OK to ignore this error, it can be disabled by setting system.webServer/validation@validateIntegratedModeConfiguration to false.
    • Alternatively, switch the application to a Classic mode application pool - for example, appcmd set app "Default Web Site/" /applicationPool:"Classic .NET AppPool". Only do this if you are unable to migrate your application.
    (Set "Default Web Site" and "Classic .NET AppPool" to your application path and application pool name) </fieldset>

     

    i am using IIS 6. I am not able to find IIS Manager. I saw the forums on this topic,  but i could not solve my problem yet. pls help.

     

    Thursday, December 23, 2010 5:36 AM

All replies

  • You may need to put the follow entry in your Web.config
    <system.webServer>
    <validation validateIntegratedModeConfiguration="false" />
    </system.webServer>

    for more info

    https://help.maximumasp.com/KB/a666/troubleshooting-integrated-pipeline-issues.aspx?KBSearchID=1752

    Thursday, February 09, 2012 6:22 AM
  • That fixed my problem. Thanks

    Monday, November 12, 2012 5:57 AM
  • Yea that fixed me up too!  I'm using VS 2012 Express for Web and added Twitter Bootstrap from NuGet and got this error.

    Thank you balajikcp

    --Ozone :)

    • Edited by ozone702 Sunday, February 10, 2013 2:25 AM
    Sunday, February 10, 2013 2:24 AM