none
migración oracle-sql

    Question

  • buenas, cuando intento conecta con la base de datos se produce el error:

    Error occurred while collecting data.

    ¿A que puede ser debido?

    gracias

    Tuesday, November 16, 2010 9:35 AM

Answers

  • Hi sunshine1117,

     

    What version of Oracle is supported? 32 bit or 64bit or both

    What version of SQL Server 2005 is supported? 32 bit or 64bit or both

    SQL Server Migration Assistant (SSMA) for Oracle doesn’t care about which bit version of Oracle or SQL Server 2005 you are using.

     

    What Windows operating system does it support? Windows 2003 or 2008 or both? 32 bit or 64bit or both?

    SSMA for Oracle support Windows Server 2003 and 2008. It doesn’t care about which bit version of Windows Server you are using.

     

    For more information about SSMA for Oracle, please refer to this link: http://www.microsoft.com/downloads/en/details.aspx?FamilyID=9dfb1773-5594-44a9-869f-a891629f80a5&displaylang=en

     

    If anything is unclear, please let me know.


    Regards,
    Tom Li
    Thursday, November 18, 2010 8:20 AM
  • Adding on to the excellent answer provided by Tom:

    On a 64-bit platform, SSMA installs both 32-bit and 64-bit SSMA applications. Depending on the platform (32 or 64-bit) of the Oracle connectivity layer make sure to run the corresponding SSMA (32 or 64-bit) application. Otherwise, both 32 and 64 bit platforms are supported on source (Oracle), client (SSMA machine) and target (SQL Server).

    Thursday, November 18, 2010 9:16 PM

All replies

  • good, when I try to connect to the database the error:

    Error collecting data.

    What can be?

    thanks

    Hello,

    Please take in consideration the following steps:

    - Make sure the Oracle client is installed and configured properly on the SQL Server computer. Make sure the ORACLE_HOME variable is set to the appropriate path.
    - Make sure you install the SSMA for Oracle Extension Pack.
    http://www.microsoft.com/downloads/en/details.aspx?FamilyID=3E8722AE-77F3-4288-906D-F421E24D322F&displaylang=en

    Hope this helps.   
     
    Regards,

    Alberto Morillo
    SQLCoffee.com

    Tuesday, November 16, 2010 11:54 AM
  • Sorry to ask this question in the topic. I tried to create a new topic but failed to put it in the right forum.

    Basically, my question is about support platform for SSMA.

    - What version of Oracle is supported? 32 bit or 64bit or both
    - What version of SQL Server 2005 is supported? 32 bit or 64bit or both
    - What Windows operating system does it support? Windows 2003 or 2008 or both? 32 bit or 64bit or both?

    Is Windows Server 2008 64bit supported?
    Wednesday, November 17, 2010 6:57 AM
  • Hi sunshine1117,

     

    What version of Oracle is supported? 32 bit or 64bit or both

    What version of SQL Server 2005 is supported? 32 bit or 64bit or both

    SQL Server Migration Assistant (SSMA) for Oracle doesn’t care about which bit version of Oracle or SQL Server 2005 you are using.

     

    What Windows operating system does it support? Windows 2003 or 2008 or both? 32 bit or 64bit or both?

    SSMA for Oracle support Windows Server 2003 and 2008. It doesn’t care about which bit version of Windows Server you are using.

     

    For more information about SSMA for Oracle, please refer to this link: http://www.microsoft.com/downloads/en/details.aspx?FamilyID=9dfb1773-5594-44a9-869f-a891629f80a5&displaylang=en

     

    If anything is unclear, please let me know.


    Regards,
    Tom Li
    Thursday, November 18, 2010 8:20 AM
  • Adding on to the excellent answer provided by Tom:

    On a 64-bit platform, SSMA installs both 32-bit and 64-bit SSMA applications. Depending on the platform (32 or 64-bit) of the Oracle connectivity layer make sure to run the corresponding SSMA (32 or 64-bit) application. Otherwise, both 32 and 64 bit platforms are supported on source (Oracle), client (SSMA machine) and target (SQL Server).

    Thursday, November 18, 2010 9:16 PM