none
Unable to add the Node to SQL 2008 fail-over Cluster.(Service account error)

    Question

  • Hi,

    we had Two Node SQL 2008 fail-over cluster.last week one node was crashed,so we decided to re-build the passive Node(crashed Node),we reinstalled the OS and added to windows cluster successfully.but when we are trying to add the node to SQL fail-over cluster.we are getting below error

    TITLE: Message Details
    ------------------------------
    The credentials you provided for the SQL Server Agent service are invalid. To continue, provide a valid account and password for the SQL Server Agent service.

    TITLE: Message Details
    ------------------------------

    The specified credentials for the SQL Server service are not valid. To continue, provide a valid account and password for the SQL Server service.

    we have tried below steps.

    1.resetted the password in Ad and change in active node (SQL & Agent)

    2.same password we have tried in password ,but no use.

    3.Created New account for SQL services and updated in active node & then tried in passive node.but same error

    4.service account having domain admins & local admins privileges

    due to the i am unable to add the node to SQL cluster.please help us to resolve the issue

    Thanks


    Uthanda

    Tuesday, July 31, 2012 3:49 AM

Answers

  • Hi Mohamed,

    issue got fixed,from services.msc i am picking the account name from domain.

     eg : Account@domainname

    which is not working in passive node.so i have added the account name in services.msc domainname\account

    after that i can able to add the node to sql cluster

    Thanks


    Uthanda

    • Marked as answer by uthandaa Wednesday, August 01, 2012 5:48 AM
    Wednesday, August 01, 2012 5:48 AM

All replies

  • Hi,

    Can you create a new service account and verify whether you are able to login to both the nodes or not.

    If you are not able to login to both the nodes with the same login, then there might be a problem with second node with respect to AD.

    Note: give the service account to locally logon to the servers for testing purpose.

    Regards,

    Mohammed.

    Tuesday, July 31, 2012 6:05 AM
  • Hi Mohamed,

    issue got fixed,from services.msc i am picking the account name from domain.

     eg : Account@domainname

    which is not working in passive node.so i have added the account name in services.msc domainname\account

    after that i can able to add the node to sql cluster

    Thanks


    Uthanda

    • Marked as answer by uthandaa Wednesday, August 01, 2012 5:48 AM
    Wednesday, August 01, 2012 5:48 AM
  • Uthanda: what is the name of the service you added your domain account to?

    thanks

    Regards,

    Wednesday, November 07, 2012 2:41 PM
  • Hi Anas,

    The service account he is referring to is might be SQL Server Service account in services.msc.

    Thanks,

    Mohammed

    Saturday, November 24, 2012 5:03 PM
  • Hi uthanda,

    i recently added two nodes one for "SQL add node to cluster"(node3) and one for standard alone node(node4).

    i did not face any issues. you need to take casre of few things:

    1) make sure cluster account have local admin privs on your participent node.(in my case node3)

    2) when you install use the same accounts that you have used in the first place. means your sql fail over cluster

    3) important on your new node make sure iscsci targets are pointed to right disks and connections are running.

    i am sure you face no further issues.

    cheers

    kumar

    Sunday, November 25, 2012 2:04 AM