none
con't connecting to my server

    Question

  • TITLE: Connect to Server
    ------------------------------

    Cannot connect to SQLEXPRESS.

    ------------------------------
    ADDITIONAL INFORMATION:

    A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) (Microsoft SQL Server, Error: 2)



    ------------------------------
    BUTTONS:

    OK
    ------------------------------
    Sunday, March 17, 2013 5:22 AM

Answers

  • This is a message that you will see many times when you work with SQL Server, as this is the standard message when you cannot connect to the instance you have specified. The reason for this messages could be many: typos, SQL server not running, firewall issues etc.

    This time it seems be a typo. You have specified SQLEXPRESS, which means that your client API starts to look around at your network for a machine called SQLEXPRESS and came back empty-handed. Supposedly you meant your local SQL Express instance, why a good bet would be .\SQLEXPRESS.


    Erland Sommarskog, SQL Server MVP, esquel@sommarskog.se
    Sunday, March 17, 2013 10:04 AM
  • There are many reasons of SQL server connectivity issue. Refer checklist to find out the real cause of connectivity issue.

    1. Check SQL services are running

    2. Check SQL Browser service is running

    3. Check remote connections are enabled

    4. Network connectivity between database & application servers by TRACERT command

    5. Check TCP/IP protocol enabled at SQL server

    6. Check talent connectivity – telnet <IP address> <port no on SQL server running>

    7. Check UDP port 1434 is open or not on SQL Server

    8. Check firewall is running or not Check

    9. If firewall running, SQL Server & UDP port must be added in exception in firewall

    10. Run SQL Discovery report on machine SQL server installed, to check you are using correct instance name to connect( default \named) -http://mssqlfun.com/2013/02/26/sql-server-discovery-report/

    http://mssqlfun.com/2012/09/28/check-list-for-sql-server-connectivity-issue/


    Regards,
    Rohit Garg
    (My Blog)
    This posting is provided with no warranties and confers no rights.
    Please remember to click Mark as Answer and Vote as Helpful on posts that help you. This can be beneficial to other community members reading the thread.

    Monday, March 18, 2013 8:01 PM
  • Hello,

    It seems that you want to connect to the SQL Server express edition instance on local server. Just as Erland post above, if you install the instance with default name(SQLEXPRESS), you should connect  with server name as follows: localservername\SQLEXPRESS or .\SQLEXPRESS

    Regards,
    Fanny Liu


    Fanny Liu
    TechNet Community Support

    Tuesday, March 19, 2013 8:58 AM
    Moderator

All replies