none
The configuration of the AdminConnection\TCP protocol in the SQL instance SQLEXPRESS is not valid

    Question

  • Hello,

    I am getting the following warning in the Application Event Log:

    The configuration of the AdminConnection\TCP protocol in the SQL instance SQLEXPRESS is not valid.

    The warning is logged by the SQLBrowser service.

    This is happening on Windows 2003 server with SQL Server Express 2005. On the same machine SQL Server 2000 is installed.

    I am currently unable to connect from remote clients to the instance of SQL Express and I believe it has to do with this warning (I've tried all the usual remote connection troubleshooting without success - enabled protocols, SQL Browser Service running, there is no firewall on the server, I disabled firewall on the client when trying to connect).

    Does anyone know how to resolve this issue?

    If you need additional information please let me know.

    Saturday, March 04, 2006 5:41 PM

Answers

  • I solved this problem, and this is what I did to make message(s) stop. I first when into SQL Manager and for both Client and Server Connections I enable TCP. After that I uninsatlled SQL Server 2000. (I had SQL Server2000 and SQL Server2005 installed.) After uninstall I rebooted, no more messages.
    Thursday, November 09, 2006 1:38 PM

All replies

  • I guess you have configured these two instances to use the same port. Thats nor possible, so better change the port with the configuration utilities to a different than the SQL Server 2k (which is by default 1433)

     

    HTH, Jens Suessmeyer.

    Sunday, March 05, 2006 4:11 PM
  • We are getting the same error on an SBS 2003 server with SQLExpress 2005 in stalled but it does not have SQL Server 2000 installed.

    We are also having performance problems with SQL Express 2005 but I have looked at the  performance monitoring and there isn't anything obvious taking up too much ram or CPU time etc..

    Any troubleshooting ideas would be great, Thanks

    Thursday, March 30, 2006 10:30 AM
  • I am seeing same warning in the Application event log on my Windows XP Professional machine.  I have only one instance of SQL Server on my machine:  SQL Server 2005 Express Edition and I have never had any instance of SQL Server 2000.

    Here's a recap of the details:

    Event Type: Warning
    Event Source: SQLBrowser
    Event Category: None
    Event ID: 3
    Date:  03/04/2006
    Time:  20:58:29
    User:  N/A
    Computer: xxxxxx
    Description:
    The configuration of the AdminConnection\TCP protocol in the SQL instance SQLEXPRESS is not valid.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    At the current time, there is no additional information at the Help & Support Centre (click the referenced link "For more information...").

    Tuesday, April 04, 2006 3:16 AM
  • Hi,

    look at this blog entry for more information, basically this means that the brwoser service cannoz open a connection to the instance of SQL Server though the specified protocols (in this case TCP).

    http://blogs.msdn.com/sqlexpress/archive/2004/07/23/192044.aspx

    Make sure that you firewall isn´t blocking the ports on the server.

    HTH, Jens Suessmeyer.

    ---
    http://www.sqlserver2005.de
    ---

    Tuesday, April 04, 2006 6:54 AM
  • Thank you Jens for pointing me to some useful information.  Based on your comments and the explanation given in that blog I went back & reviewed the configuration on my machine.

    Summary:  I did find/correct some misconfiguration, but it DID NOT prove to be the culprit.

    Details as follows:

    Going into SQL Server Configuration Manager, and looking at the Protocols for SQLEXPRESS under SQL Server 2005 Network Configuration, I did remind myself that I had disabled Named Pipes recently, leaving the following protocols enabled/disabled as follows:

    • Shared Memory:  Enabled
    • Named Pipes:  Disabled
    • TCP/IP:  Enabled
    • VIA:  Disabled

    Looking then at the Client Protocols under SQL Native Client Configuration heading, I did find what I thought was the culprit - that Named Pipes was enabled here (client-side), where it was not enabled on the server-side.  So I disabled Named Pipes here, leaving the protocols enabled/disabled as follows:

    Protocol Name | Order | Enabled/Disabled

    • Shared Memory | 1 | Enabled
    • TCP/IP | 2 | Enabled
    • Named Pipes | - | Disabled
    • VIA | - | Disabled

    After making this change, I shutdown/restart SQL Server 2005 Express and the SQL Server Browser in the following order:

    1. Stop SQL Server Express (service name "MSSQL$SQLEXPRESS")
    2. Stop SQL Server Browser (service name "SQLBrowser")
    3. Restart SQL Server Express
    4. Restart SQL Server Browser

    Having done all this I looked in the Application event log.  The warning message was still there (and yes, I was looking at the events associated with the just-completed restart).

    Questions:

    Maybe I got off on the wrong track here - I was thinking that SQL Server Browser connected to SQL Server using the SQL Native Client / SQL Native Client's protocol.  Is this not the case?  Does SQL Browser have its own configuration settings (configured somewhere else?)

    Tuesday, April 04, 2006 3:14 PM
  • Did you get your problem fixed. I am getting the same error and am curious to find a solution.

    Any input will be highly appreciated.

    Thanks

    Thursday, August 03, 2006 9:06 PM
  • Hello,

    We are having the same issue with a Windows 2003 SBS SP1 server with SQL Express. Has anyone found a resolution as of yet?

    Thanks

    Tuesday, August 29, 2006 5:41 PM
  • I have the same issue on XP Pro SP2. I saw this error in the logs this morning after some trouble making a remote connection from our production SQL 2005 server when installing on the client yesterday.

    Here was our connection issue.
    Our standard remote install is still running MSDE with the instance named store1, store2, etc.
    As we proceed in moving to SQL 2005 we have been using rather default installs of SQL express at the store level. After install we config to accept local and remote connections on TCP/IP.
    We couldn't connect to this one and found that it had come up named rather oddly. Rather than the instance being storexxx it was showing as storexxx\sqlexpress.
    After goofing about a bit we enabled the browser service on the client (disabled by default). management studio THEN connected and after that it didn't seem to require the browser service to be running.
    In management studio it lists as "storexxx(storexxx\sqlexpress)" instead of the standard "storexxx".
    Anyone ideas?
    Thursday, August 31, 2006 1:26 PM
  • SQL Server can be installed multiple times on the same machine -- these are called "instances".  The only time SQL Server shows up without an instance name and just a server name (ie. storexxx vs. storexxx\instancename) is when you install SQL Server as a default instance.  This is, by the way, the default installation option.  -- Brian

     

    Friday, September 01, 2006 11:11 PM
  • Oh, I forgot to mention I have the same "AdminConnection\TCP protocol..." warning in my EventLog.  It's driving me nuts.  If anyone solves this, please post.  I reinstalled SQL Server SP1 but that didn't fix the issue.  Is Microsoft monitoring this post?  MS, can you guys please explain because the ports are configured properly and there is no port overlap between instances.  Thanks! -- Brian
    Friday, September 01, 2006 11:16 PM
  • Hmmm...what it seems to be doing in a default instance install is naming it "storexxx\sqlexpress". This isn't a problem in itself but is inconsistant with existing MSDE locations which show up as "storexxx". I'm only concerned about consistancy for scripting, maintenance, etc...
    Is there an easy way of changing the instance name?




    Wednesday, September 20, 2006 1:42 PM
  • We found this in the SQL Server Logs...

    2006-10-19 09:39:00.59 Server      Dedicated administrator connection support was not started because it is not available on this edition of SQL Server. This is an informational message only. No user action is required.

    ... which implies that the SQL Browser service is picking up that a particular feature is deliberately disabled in SQL Express.  Hence it looks as if it's not a problem, but we won't be able to make the eventlog messages go away.

    David.

    http://web.coop

     

    Thursday, October 19, 2006 9:24 AM
  • Has anyone figured this out yet?  I just rebuilt my PC and I too have this issue.  I have enabled TCP/IP and done what I can per the articles I've read but this issue still plagues me.  Please advise!!
    Thursday, October 19, 2006 10:46 PM
  • I solved this problem, and this is what I did to make message(s) stop. I first when into SQL Manager and for both Client and Server Connections I enable TCP. After that I uninsatlled SQL Server 2000. (I had SQL Server2000 and SQL Server2005 installed.) After uninstall I rebooted, no more messages.
    Thursday, November 09, 2006 1:38 PM
  • I am getting this warning after a reboot. I can see from my logfiles that the SQLEXPRESS instance is not fully initialized until the warning is produced.
    For instance there is a message saying "SQL Server is now ready for client connections. This is an informational message; no user action is required." about 2 seconds after the warning.

    I think it is another timing issue.

    Best regards
    Andreas Warberg
    Wednesday, November 29, 2006 4:41 PM
  • Getting the same error here. Why hasn't MSFT responded with a fix?

    Ivan

    Tuesday, January 16, 2007 3:29 AM
  • After I installed SQL 2005 Express I started getting the same AdminConnection\TCP protocol errors.  I changed the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL.1\MSSQLServer\SuperSocketNetLib\AdminConnection\Tcp

    from

    Value 0
      Name:            TcpDynamicPorts
      Type:            REG_SZ
      Data:            0

    Value 1
      Name:            DisplayName
      Type:            REG_SZ
      Data:            TCP/IP

    TO

    Value 0
      Name:            TcpDynamicPorts
      Type:            REG_SZ
      Data:            1433

    Value 1
      Name:            DisplayName
      Type:            REG_SZ
      Data:            TCP/IP

    and rebooted.  I have not received the errors since.  Pure speculation on my part, but I think that in the full version of SQL the SQL Server Network Utility configures this key, but this tool does not exist in SQL 2005 Express.

      Good luck all - no guarantees this won't screw up your installation.

    • Proposed as answer by BajaDiver Friday, June 25, 2010 6:27 PM
    Friday, March 09, 2007 7:47 PM
  • I have the same problem.

    I have windows 2000 server, slq 2000 server and another istance with sql server 2005 installed.

    If I restard sql browser I encounter the same error, but when I restart the Server I find sql browser started with non errors.

     

    Maybe it's something concernd with the port, because the error says that is invalid, if so what setting should I use?

     

    I tried the solution posted before but for me didn't work, did anybody enconunter this problem and resolved? some advise?

     

    Thanks in advance.

    Riccardo

     

     

    Tuesday, April 10, 2007 11:49 AM
  • Just writing to say that I edited the registry key mentioned above by Straight No Chaser (March 9, 2007) about 4 weeks ago and have not seen the message in my event log since.  I just went back to confirm.  I would however like to see confirmation of this from one more person before I declare this solved.

     

    All you have to do is change the value of the key TcpDynamicPorts from 0 to 1433 at the following location:

     

    HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Microsoft SQL Server \ MSSQL.1 \ MSSQLServer \ SuperSocketNetLib \ AdminConnection \ Tcp

    Hope this helps everybody.

    • Proposed as answer by ITPro4Life Sunday, August 15, 2010 5:42 AM
    Wednesday, April 11, 2007 1:14 AM
  • Start SQLServer Configuration Management 

    Expand SQL 2005 Network Configuration

    Right Click Protocols for SQLEXPRESS

    Click Properties

    Force Protocol Encryption = NO

     

    Right Click Native Client Configuration

    Click Properties

    Force Protocol Encrytion = NO

    Trust Server Certificate = NO

     

    Don't know about the security but it stops the error log.

    But I have no clients nor am I connected to a network.

    I use local only in the Surface Area Configuration.

    Hope this helps.

    Saturday, April 14, 2007 3:10 AM
  • Start SQL Server Configuration Manager

    Expand SQL Server 2005 Network Configuration

    Right Click Protocols for SQLEXPRESS

    Click Properties

    Set Force Protocol Encryption to NO

     

    Right Click SQL Native Client Configuration

    Click Properties

    Set Force Protocol Encrytion to NO

    Set Trust Server Certificate to NO

     

       This worked for me don't know about the security of it all, but I set SQL Server Surface area Connections to Local Only. No Remote TCP. I have a standalone workstation so I'm not connected to a network. If there are security implications to these settings please post.

     

        I hope this might help.

    Saturday, April 14, 2007 3:23 AM
  • Each SQL instance needs a unique port.  1434 should work if 1433 is in use by another SQL instance.  They are both standard SQL admin ports.  TCP port 0 is a reserved port and nobody is supposed to be listening on it - although finding out what it is reserved for has been fruitless.  Odd that SQL express 2005 configures port 0 as the admin connection port by default.

     

     

    Friday, April 27, 2007 7:36 PM
  • Given that the name of the key is TcpDynamicPorts, I would assume that this is a flag to enable a feature.  0 would indicate disabled, non-zero being enabled.  The value is probably not used as an actual port.
    Wednesday, May 23, 2007 4:27 PM
  • Well, I'll be the third to confirm the registry hack to resolve the warning issue.  SQL Browser no longer reports a misconfiguration after changing the DynamicPorts value.

     

     

    Tuesday, June 19, 2007 10:55 AM
  • I agree that it looks like an Enabled = True/False key. It also acts like it. I set the value to 1 (the univ. ENABLE = True) value and it looks to have taken care of the issue. Here anyway, others milage may vary.

     

    All you have to do is change the value of the key TcpDynamicPorts from 0 to 1 at the following location:

     

    HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Microsoft SQL Server \ MSSQL.1 \ MSSQLServer \ SuperSocketNetLib \ AdminConnection \ Tcp

     

    -bill
    Tuesday, August 28, 2007 7:15 PM
  •  

    Try the following:

    * In SQL Server Configuration Manager

    ** SQL Server 2005 Network Configuration

    *** Protocols for SQLEXPRESS

    ---- TCP/IP (double-click)

    ----- Tab IP-Adresses

    -----> Check that all IP-adresses named in the configuration are valid. If not, correct the invalid adress or Enabled:NO.

     

    It worked for me.

    The error-message disapeared.

     

    Good hunting!

    //Hoffe

    • Proposed as answer by BartDC Wednesday, April 18, 2012 1:06 PM
    • Unproposed as answer by BartDC Wednesday, April 18, 2012 1:06 PM
    Thursday, January 03, 2008 12:12 PM
  • Per event ID 17199:  Dedicated administrator connection support was not started because it is not available on this edition of SQL Server. This is an informational message only. No user action is required.

     

    It would seem that event ID 3: The configuration of the AdminConnection\TCP protocol in the SQL instance SQLEXPRESS is not valid. - Is a false warning.

     

    It would be nice to disable that warning, but it's minor. Always a pain in the butt though when you find out you've been chasing your tail on something that could have very easily been documented...

     

     

    Wednesday, June 11, 2008 2:08 AM
  • Thanks Ian_E, your solution worked for me.

    Friday, August 29, 2008 4:48 AM
  • Only to confirm that any value different from 0 works! (XP SP3 + SQL2005Express)
    Thursday, January 08, 2009 4:21 PM
  • Above Reg edit worked for me. Thank you :)
    Wednesday, April 08, 2009 4:26 PM
  • I have 2 computers running the same version of SQL.  Based on the configuration of the one that does NOT have any errors, I adjusted the settings on the one that does (One at a time and tested in between).  Now I am getting no error messages from SQL at all.  Here is my solution. 

    Just a quick note for anyone using Vista 64 bit :

    ** 64bit ** HKLM\SOFTWARE\ Wow6432Node \ Microsoft \ Microsoft SQL Server \ MSSQL.1 \ MSSQLServer \ SuperSocketNetLib \ AdminConnection \ Tcp
    ** 32bit ** HKLM\SOFTWARE \ Microsoft \ Microsoft SQL Server \ MSSQL.1 \ MSSQLServer \ SuperSocketNetLib \ AdminConnection \ Tcp

    These registry edit works BEST as the following:
         Name: DisplayName
         Type: REG_SZ
         Data: TCP/IP   (if you have to key this in, make sure your slash is going the right way)

         Name: TcpDynamicPorts
         Type: REG_SZ
         Data: 1434  (although 1 is valid, I ended up with future errors that appeared unrelated.)

    But also, the following seem to need to be changed as well:
    ** 64bit ** HKLM\SOFTWARE\ Wow6432Node \ Microsoft \ Microsoft SQL Server \ MSSQL.1 \ MSSQLServer \ SuperSocketNetLib \ Tcp \
    ** 32bit ** HKLM\SOFTWARE\ Microsoft \ Microsoft SQL Server \ MSSQL.1 \ MSSQLServer \ SuperSocketNetLib \ Tcp \

      Each "IP"# folder up to and including IPAll:
         Name: TcpDynamicPorts
         Type: REG_SZ
         Data: (should be empty)

         Name: TcpPort
         Type: REG_SZ
         Data: 1433

    Hope this is helpful.

    Friday, April 24, 2009 4:40 PM
  • Hi.

    * In SQL Server Configuration Manager

    ** SQL Server 2005 Network Configuration

    *** Protocols for SQLEXPRESS

    ---- TCP/IP (double-click)

    ----- Tab IP-Adresses

    One of my ip addresses was pointing to an old DHCP assigned address. We changed our office router recently and it looks like we are now getting ip addresses from a different dhcp ip range.

    I did Start->Run
    cmd

    then in the command line I typed
    ipconfig /all

    found my new ipaddress, and corrected the old IP address in SQL Server 2005 Network Configuration -> protocols -> TCPIP -> Ip-addresses
    Problem solved and the message goes away.

    Thanks hoffe1
    Tuesday, July 07, 2009 10:27 AM
  • I have SQL Server 2005 installed on a 2003 Server with 2 instances running (one for my Enterprise Antivirus software and another for BackupExec.)

    That can come up when the MSSQLServerActiveDirectoryHelper service is set to automatic or disabled. The MSSQLServerADHelper service should be set to manual. SQL Server will start and stop the service itself when needed.

    Mine was set as "Disabled."  I changed it to "Manual" and this fixed my problem.

    Hope this helps someone else.
    Friday, March 19, 2010 1:10 PM
  • Hi,

    The registry value for TCPDynamicPorts isn't a true/false value.  If you have an instance configured to use dynamic ports, i.e. named instances, when you first start the instance, the port is set to zero.  This value tells SQL Server to request a free port from the OS, which SQL Server starts listening on.  The new port is written to the registry.  If this port is subsequently used by another program following a sql server restart, the TCPDynamicPorts registry is again set to zero, and another free port is requested.

    This link explains it all:

    http://support.microsoft.com/kb/823938

    The default install for SQL Server express is a named instance, so it would appear all be symptoms of the same problem.

    Cheers,

    Andy

    Friday, March 19, 2010 4:19 PM
  • After I installed SQL 2005 Express I started getting the same AdminConnection\TCP protocol errors.  I changed the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL.1\MSSQLServer\SuperSocketNetLib\AdminConnection\Tcp

    from

    Value 0
      Name:            TcpDynamicPorts
      Type:            REG_SZ
      Data:            0

    Value 1
      Name:            DisplayName
      Type:            REG_SZ
      Data:            TCP/IP

    TO

    Value 0
      Name:            TcpDynamicPorts
      Type:            REG_SZ
      Data:            1433

    Value 1
      Name:            DisplayName
      Type:            REG_SZ
      Data:            TCP/IP

    and rebooted.  I have not received the errors since.  Pure speculation on my part, but I think that in the full version of SQL the SQL Server Network Utility configures this key, but this tool does not exist in SQL 2005 Express.

      Good luck all - no guarantees this won't screw up your installation.


    Thank you for this information.  I had tried all the steps suggested starting at the top of this thread.  This solution is the one what worked flawlessly for me!

    I'm not sure what caused this error to start happening. I'm using an add-in for my Windows Home Server and it's been online for months. This morning, we were unable to use the application from the clients.  I found this error message regarding the database used by the add-in this morning. 

    Again, once I made this one simple registry change & rebooted, the error disappeared and all of my clients were able to connect to the server & it's database.

    This method should be researched & validated by Microsoft as the solution.  Better yet, the cause of the error to suddenly appear would be nice as well.

    Thanks again!
    Claire

    Friday, June 25, 2010 6:32 PM
  • My environment is Windows 7 Pro running in VMware Fusion on a macbook pro

    I have two instances of sql server installed SQL server developers edition and SQL server express. I'm experiencing the same warning:

    The configuration of the AdminConnection\TCP protocol in the SQL instance SQLEXPRESS is not valid.

    I have tried the suggestions listed above and have had no luck. What should I do next?


    Thursday, June 23, 2011 3:04 PM
  • This are the settings in the  SQL Server Configuration Manager:

    SQL Server Configuration Manager
    Default settings:

    SQLEXPRESS:
     IP1
      Enabled: No
    IPAll 
     TCP Dynamic ports 2796

    BLACKBERRY:
     IP1
      Enabled: No
    IPAll 
     TCP Dynamic ports 3879


     
    For me with these changes in the registry there are no messages anymore in the event log:

    Windows Registry Editor Version 5.00
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL.1\MSSQLServer\SuperSocketNetLib\AdminConnection\Tcp]
    "TcpDynamicPorts"="3879"
    "DisplayName"="TCP/IP"

    Windows Registry Editor Version 5.00
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL.2\MSSQLServer\SuperSocketNetLib\AdminConnection\Tcp]
    "TcpDynamicPorts"="2796"
    "DisplayName"="TCP/IP"

     


    Thursday, June 30, 2011 10:29 AM
  • In my case, I have Virtual Machine Manager 2008 R2 with Virtual Machine Manager Self-Service Portal running on Windows Server 2008 R2.  It has a mixed 32/64bit SQL component install running under SQL instance MSSQL$MICROSOFT$VMM$.  To alleviate the error, I had to go to the WOW6432Node registry key:

    HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Microsoft SQL Server\MSSQL.1\MSSQLServer\SuperSocketNetLib\AdminConnection\Tcp\TcpDynamicPorts

    I changed the default from 0 to 1433

    Hope this helps.

    Thursday, July 07, 2011 4:05 PM

  • Thanks! I've no longer get this error message on my Win 7 x64.
    Monday, October 29, 2012 9:08 PM
  • Thanks guys. Sorted my problem. Was little bit different on 2003. Registry location:

    HKEY_LOCAL_MACHINE/SOFTWARE/MICROSOFT/MICROSOFT SQL SERVER/{SERVERNAME}/SUPERSOCKETNETLIB/

    TCP: changed to 1433


    Tuesday, April 02, 2013 10:15 AM