none
invalid Permission to View the Report server

    Question

  • Dear Friends,

    I have facing a problem in one of my client regarding Reporting services project. We deployed Reporting Services projects (DB:SQL Server 2008,OS:Windows Server 2008) few months back, it worked that time fine they have no issues they are accessing the report by typing the Report manager url  (Http://[ipaddress]/Reportmanger). Every thing going fine up to this time. But today they are restarting the server after that we can't open the  the Report manger they said the following error.

    The repoert server cannot open a connection to the report server database.
    A connection to the database is required for all requests and processing.
    (rs Reportserver Database unavailabale) get online help

    I am trying to connect the Report Server by management studio i got the following Error:

     TITLE: Microsoft SQL Server Report Designer
    ------------------------------
    Could not connect to the report server
    http://localhost/ReportServer.
    Verify that the TargetServerURL is valid and that you have the correct permissions to connect to the report server.
    ------------------------------
    ADDITIONAL INFORMATION:
    System.Web.Services.Protocols.SoapException: The report server cannot open a connection to the report server database. A connection to the database is required for all requests and processing. ---> Microsoft.ReportingServices.Library.ReportServerDatabaseUnavailableException: The report server cannot open a connection to the report server database. A connection to the database is required for all requests and processing.
       at Microsoft.ReportingServices.WebServer.WebServiceHelper.EnsureModeFromCatalog()
       at Microsoft.ReportingServices.WebServer.RsSoapBase.Init(String itemPath, Boolean checkAccessToSharePoint)
       at Microsoft.ReportingServices.WebServer.ReportingService2010.Initialize(String itemPath, Boolean checkAccessToSharePoint)
       at Microsoft.ReportingServices.WebServer.ReportingService2010.IsSSLRequired() (Microsoft.ReportingServices.Designer)
    ------------------------------
    BUTTONS:
    OK
    ------------------------------

    I am verified the following things:

    1.Report server services running
    2.Report configurations are all checked.
    3.IIS Not configured (it works fine with out IIS components last time)

    Please kindly help any one regarding this,

    Thanks,

    Prabakaran Thavasumuthu.

    Saturday, February 05, 2011 5:55 AM

Answers

  • I Just got the solution after few day's, now i want to share the solution with all

    1.Delete the all Encryption keys in RsConfig 

    2.Reconfig the Reporting Services

    Now It's work fine!!!

     


    Thanks, Vasantha Prabakaran
    • Marked as answer by Vasantha Praba Monday, November 28, 2011 9:59 AM
    Monday, November 28, 2011 9:59 AM

All replies

  • Hi,

     

    The error message clearly says that the account dont have access to the ReportServer dbs.

    Can you pls confirm whether you are able to access the report server dbs with this account( pls query some table in this DBs).

    Also pls ensure that the account has both "Public & RSExecRole" for these databases. You can check this in the server --> security--> Logins --> <LoginId>-->User mapping.

     

    The report server cannot open a connection to the report server database. A connection to the database is required for all requests and processing. (rsReportServerDatabaseUnavailable).


    This error occurs when the report server cannot connect to the SQL Server relational database that provides internal storage to the server. The connection to the report server database is managed through the Reporting Services Configuration tool. You can run the tool, go to the Database Setup page, and correct the connection information. Using the tool to update connection information is a best practice; the tool ensures that dependent settings are updated and that services are restarted. For more information, see Configuring a Report Server Database Connection and Configuring the Report Server Service Account.

    This error can also occur if the Database Engine instance that hosts the report server database is not configured for remote connections. Remote connection is enabled by default in some editions of SQL Server. To verify whether it is enabled on the SQL Server Database Engine instance you are using, run the SQL Server Configuration Manager tool. You must enable both TCP/IP and named pipes. A report server uses both protocols. For instructions on how to enable remote connections, see the section "How to Configure Remote Connections to the Report Server Database" in How to: Configure a Report Server for Remote Administration.

    If the error includes the following additional text, the password expired on the account used to run the Database Engine instance: "An error has occurred while establishing a connection to the server. When connecting to SQL Server, this failure may be caused by the fact that under the default settings SQL Server does not permit remote connections. (provider: SQL Server Network Interfaces, error: 26 - Error Locating Server/Instance Specified)." To resolve this error, reset the password.

     

    Regards,

    PS

    Saturday, February 05, 2011 8:34 AM
  • Thanks for your valuable reply mr.Shetty,

    1.I can able to access the Reportserver database with my account.

    2.I checked the Public "Public & RSExecRole" for my service Account (RSconfig) is "NT Authority\NetworkService"

     NT AUTHORITY\NETWORK SERVICE user all are checkesd as per your  instruction.

    But still i am getting the same error by connecting Report manager.

     

    I am trying to connect different service Account (RS config)

    but that time i got some different errors:

    Report Server connection Error(BY SSMS) 1:


    TITLE: Connect to Server
    ------------------------------

    Cannot connect to [MyServer]------------------------------
    ADDITIONAL INFORMATION:

    Unable to connect to the server at [My server]. The specified URL might not be valid or there might be a problem with the report server version or configuration. Specify a different URL, or contact your server administrator to verify that the report server runs SQL Server 2008 or later. Additionally, if you are trying to connect to a SharePoint-integrated report server, verify that SharePoint is installed on the server and that the report server uses SharePoint integrated mode. (Microsoft.SqlServer.Management.UI.RSClient)

    ------------------------------
    BUTTONS:

    OK

     

    Report Server connection Error(BY SSMS-report server can be connect but give the following error) 2:

    TITLE: Microsoft SQL Server Management Studio
    ------------------------------

    Add member failed for DatabaseRole 'RSExecRole'.  (Microsoft.SqlServer.Smo)

    For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&ProdVer=10.50.1600.1+((KJ_RTM).100402-1539+)&EvtSrc=Microsoft.SqlServer.Management.Smo.ExceptionTemplates.FailedOperationExceptionText&EvtID=Add+member+DatabaseRole&LinkId=20476

    ------------------------------
    ADDITIONAL INFORMATION:

    An exception occurred while executing a Transact-SQL statement or batch. (Microsoft.SqlServer.ConnectionInfo)

    ------------------------------

    Cannot use the special principal 'dbo'. (Microsoft SQL Server, Error: 15405)

    For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&ProdVer=10.50.1600&EvtSrc=MSSQLServer&EvtID=15405&LinkId=20476

    ------------------------------
    BUTTONS:

    OK
    ------------------------------

    Now what i should do!

    Thanks,

    Prabakaran.T


    Saturday, February 05, 2011 12:36 PM
  • Hi,

    Because you are conected as a sysadmin, you are also the dbo of the database. You cannot add dbo as a member of any fixed role. dbo already has the permissions of RSExecRole 

    Also check the below link which says How to: Configure a Service Account for Reporting Services

    http://msdn.microsoft.com/en-us/library/bb522727.aspx

    Hope it works.

    Regards,

    PS

     

     

     

    Saturday, February 05, 2011 1:39 PM
  • Dear  Ps,

    I have got the following error while configuraing  the database in resconfiguration

    rsconfig-->Database -->Change datbase-->chooose exixsting db-->Database server -->connection sucess-->db:rerportserver-->

    credential:Localsystem ...Local System-->Progress...(Not completing here i found the following error at applying connecion )

    System.Data.SqlClient.SqlException: User does not have permission to perform this action.
       at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection)
       at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection)
       at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj)
       at System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream,
     BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj)
       at System.Data.SqlClient.SqlCommand.RunExecuteNonQueryTds(String methodName, Boolean async)
       at System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(DbAsyncResult result, String methodName, Boolean sendToPipe)
       at System.Data.SqlClient.SqlCommand.ExecuteNonQuery()
       at Microsoft.ReportingServices.Common.DBUtils.ApplyScript(SqlConnection conn, String script, ICommandWrapperFactory commandWrapper)
       at Microsoft.ReportingServices.Common.DBUtils.ApplyScript(String connectionString, String script)
       at ReportServicesConfigUI.SqlClientTools.SqlTools.ApplyScript(String connectionString, String script)

     

    thanks give some valuable feedback,

    Thanks,

    Prabakaran.

    Wednesday, February 09, 2011 10:09 AM
  • I Just got the solution after few day's, now i want to share the solution with all

    1.Delete the all Encryption keys in RsConfig 

    2.Reconfig the Reporting Services

    Now It's work fine!!!

     


    Thanks, Vasantha Prabakaran
    • Marked as answer by Vasantha Praba Monday, November 28, 2011 9:59 AM
    Monday, November 28, 2011 9:59 AM