none
Service Pack installation fails on passive node : sql server 2008

    Question

  • Hi All,

    I am facing an issue while installing Service Pack on sql server 2008 cluster node. Assuming Node A --> Active and node B --> Passive.

    Initially i am installing the service pack on passive node(B) which goes through all steps and at the end I get a message stating the Service Pack installation Failed.

    When I fail-over the sql services from node A to node B and check the version I see that the service pack patch level has been applied on the passive node(node B).

    Later when I install the service pack on node A it installs successfully.

    I have come across the same issue for couple of clusters.

    Any help would be appreciated.

    Thanks,

    PraveenDesi

    Monday, April 01, 2013 5:47 AM

All replies

  • Starting SQL 2008, service pack needs to be applied on all the cluster nodes where SQL is installed. So, if it failed on the passive node, even though it is successful on one of the nodes, still you need to make sure that the service pack also completes successfully on the failed node, as there may be some components which may not have got upgraded to the service pack. You may not see any issues now, but may end up hitting some issue later.

    You may want to try apply the Service pack on the failed node and if it fails, you will have to fix that error and run the service pack again.

    Monday, April 01, 2013 5:51 AM
  • Thanks Keerthi Deep..

    I have tried uninstalling and re-installing the Service Pack on passive node(B) but it still fails.

    I have restarted the node and followed the same process again still no go..

    Monday, April 01, 2013 5:54 AM
  • Please share the error which you receive while installing SP.
    Monday, April 01, 2013 5:56 AM
  • I can see these are the error messages listed in Detail.txt file :

    2013-03-19 02:27:53 Slp: Error: Action "ConfigEvent_MPT_AGENT_CORE_CNI_sql_engine_core_inst_Cpu64_Patch_ConfigRC_postmsi" failed during execution.

    2013-03-19 02:27:53 Slp: Error: Action "AgentConfigAction_patch_RC_Cpu64" failed during execution.

    2013-03-19 02:27:53 Slp: Error: Action "ConfigEvent_SQL_Replication_Core_Inst_sql_engine_core_inst_Cpu64_Patch_ConfigRC_postmsi" failed during execution.

    2013-03-19 02:27:53 Slp: Error: Action "ConfigEvent_SQL_FullText_Adv_sql_fulltext_Cpu64_Patch_ConfigRC_postmsi" failed during execution.

    2013-03-19 02:27:53 Slp: Error: Action "FulltextConfigAction_patch_configrc_Cpu64" failed during execution.

    2013-03-19 02:27:53 Slp: Error: Action "ConfigEvent_SQL_Engine_Core_Inst_sql_engine_core_inst_Cpu64_Patch_Startup_postmsi" failed during execution.

    2013-03-19 02:27:53 Slp: Error: Action "cluster_group_cluster_patch_startup_Cpu64" failed during execution.

    2013-03-19 02:27:54 Slp: Error: Action "ConfigEvent_MPT_AGENT_CORE_CNI_sql_engine_core_inst_Cpu64_Patch_Startup_postmsi" failed during execution.

    2013-03-19 02:27:54 Slp: Error: Action "ConfigEvent_SQL_Replication_Core_Inst_sql_engine_core_inst_Cpu64_Patch_Startup_postmsi" failed during execution.

    2013-03-19 02:27:54 Slp: Error: Action "ConfigEvent_SQL_FullText_Adv_sql_fulltext_Cpu64_Patch_Startup_postmsi" failed during execution.

    2013-03-19 02:27:54 Slp: Error: Action "FulltextConfigAction_patch_startup_Cpu64" failed during execution.

    2013-03-19 02:27:54 Slp: Error: Action "ConfigEvent_SQL_Engine_Core_Inst_sql_engine_core_inst_Cpu64_Patch_StartupFinalize_postmsi" failed during execution.

    etc..

    2013-03-19 02:27:57 Slp: Error result: -2068643839
    2013-03-19 02:27:57 Slp: Result facility code: 1203
    2013-03-19 02:27:57 Slp: Result error code: 1

    Monday, April 01, 2013 6:19 AM