none
Management Studio and SQL Server 2000

    Question

  • Hello,

    I just installed SQL 2005 and Management Studio that came with VS2005 professional. I was able to successfully attach a SQL 2000 database to my SQL 2005 installation.

    Now I would like to connect to the SQL 2000 database on my hosting ISP and copy some data via SQL Server Import and Export Wizard. Is it possible to use management studio to connect to a SQL 2000 database on the internet ? If so, is there any settings that need to be changed in Management Studio inorder to accomplish this?

    I have enabled TCP/IP SQL Native Client Configuration --> Client Protocols.

    I also tried assigning a Alias for my remote server.

    I keep getting connection failed messages and the following message:

    TITLE: Connect to Server
    ------------------------------

    Cannot connect to 207.36.18.145.

    ------------------------------
    ADDITIONAL INFORMATION:

    An error has occurred while establishing a connection to the server.  When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: TCP Provider, error: 0 - No connection could be made because the target machine actively refused it.) (Microsoft SQL Server, Error: 10061)

    For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&EvtSrc=MSSQLServer&EvtID=10061&LinkId=20476

    ------------------------------
    BUTTONS:

    OK
    ------------------------------
    When I try to connect with Enterprise Manager from a differnet machine in the same network, I get a successful connection.

    Any help would be greatly appreciated.

    Thanks,

    Mike

    Tuesday, January 10, 2006 6:34 AM

Answers

  • Never mind. I found a problem with my setup. After correcting the setup and explicitly selecting TCP/IP as the connection protocol, I was able to connect to my remote SQL server 2000 via management studio.

     

    Mike

    Wednesday, January 11, 2006 6:50 PM