none
SQL Server Agent gives- Remote procedure call failed (0x800706be)

    Question

  • I can't access SQL Server 2008 R2 remotely on Windows 2008

    1.  TCP/IP Enabled for SQL Server Network Configuration Protocols, SQL Native Client 10.0 configuration clients, and SQL Native Client 10.0 configuration clients(32 bit)

    2.  Firewall disabled to make sure its not interferring with things.

    I noticed the SQL Server Agent is Stopped.  Not sure if this is the issue.  When I try and turn this from disabled to Automatic or Manual, I get this error:

    Remote procedure call failed (0x800706be)

    It shouldn't be this difficult.

     

     


    Thank you for your help in advance!
    Monday, June 20, 2011 4:38 PM

Answers

  • Hello,

    About the error message>> The remote procedure call failed.[0x800706be], in my case, the solution was to install SQL 2008 R2 SP1.

    Regards,

    Robert.

    • Proposed as answer by Zephan Monday, June 25, 2012 11:06 PM
    • Marked as answer by Kalman TothEditor Tuesday, June 26, 2012 6:51 AM
    Sunday, June 10, 2012 11:55 PM
  • Have you tried to start SQL Server Agent from the command prompt using:
    SQLAGENT90 -C -V>C:\SQLAGENT.OUT
    Best Regards,
    Peja

    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Peja Tao Wednesday, July 13, 2011 6:59 AM
    Wednesday, June 22, 2011 9:12 AM

All replies

  • Hi 

    Have you enabled "Allow Remote Connections" in server properties.  If Not, then open SSMS and connect to Server and right click on Server Name, click Properties -> Connections -> Check "Allow remote connections to this server"

    Hope you enabled the TCP\IP on "SQL Server Network Configuration) as well.

    After making the changes, restart the SQL Server service.


    Arunraj Chandrasekaran, MCTS, Author: SQLXpertise.com
    If you found this post useful, Please "Mark as Answer" or "Vote as Helpful"
    Monday, June 20, 2011 4:45 PM
  • Yes both of those things have been enabled before the problem.

    Allow Remote Connections and Mixed Mode Authentication.  However, all I'm trying to do is TURN on a service WITHIN the Server....so the login account should be the local Network account thats part of the install.


    Thank you for your help in advance!
    Monday, June 20, 2011 8:02 PM
  • Try opening the SQL server configuration manager with RUN AS ADMIN option and see if that makes any difference


    Thanks, Leks
    • Proposed as answer by Peja Tao Wednesday, June 22, 2011 9:03 AM
    • Marked as answer by Peja Tao Wednesday, July 13, 2011 6:59 AM
    • Unmarked as answer by Kalman TothEditor Saturday, September 22, 2012 11:34 AM
    Monday, June 20, 2011 9:00 PM
  • Have you tried to start SQL Server Agent from the command prompt using:
    SQLAGENT90 -C -V>C:\SQLAGENT.OUT
    Best Regards,
    Peja

    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Peja Tao Wednesday, July 13, 2011 6:59 AM
    Wednesday, June 22, 2011 9:12 AM
  • Unfortunately I have exactly the same problem, i've tried all the suggestions from this post and still have the error when I try to change the Start Mode, it shows me:

     

    WMI Provider Error

    The remote procedure call failed.[0x800706be]

    Thursday, June 23, 2011 3:04 PM
  • same here. Somebody?
    Leo Tohill
    Friday, November 25, 2011 3:05 AM
  • Installed SQL Server Express 2010, but I am not able to start the SQL Server Agent. (RPC error 0x00706be). Ran the SQL Server Configuration Manager both for the local user and as Administrator (Windows 7), but does have the same effect. I tried to run:

    sqlagent.exe -c -v >c:\sqlagent.out

    This runs normal, see the output in sqlagent.out:

    Microsoft (R) SQLServerAgent 10.50.2500.0
    Copyright (C) Microsoft Corporation.
    
    2012-02-27 19:12:36 - ? [098] SQLServerAgent terminated (normally)

    So the mystery deepens.

    Monday, February 27, 2012 6:21 PM
  • +1. SQL Server Configuration Manager (run as administrator) shows SQL Server Services as "The remote procedure call failed. [0x800706be]

    SQL Server 10.0 exess error. Note I've installed VS2012 Beta1 (default install) and never needed SQL on this box before that install (so unsure if VS2012 is related).


    Thanks! -Zephan

    Tuesday, May 15, 2012 5:59 PM
  • Does Anyone have short or Long solution for this? 

    Friday, June 08, 2012 6:20 AM
  • Hello,

    About the error message>> The remote procedure call failed.[0x800706be], in my case, the solution was to install SQL 2008 R2 SP1.

    Regards,

    Robert.

    • Proposed as answer by Zephan Monday, June 25, 2012 11:06 PM
    • Marked as answer by Kalman TothEditor Tuesday, June 26, 2012 6:51 AM
    Sunday, June 10, 2012 11:55 PM
  • Yeah! I just confirmed installing SQL 2008 R2 SP1 fixed RPC error 0x800706be. Thank you Robert Ancajima for posting your observation!

    For the record Opening SSCM As Administrator did not help solve this problem for me. 


    Thanks! -Zephan

    Monday, June 25, 2012 11:10 PM
  • I also had this problem after installing VS2012. Previously I had SQL Server 2008 R2 installed. I am now downloading the service pack and hopefully this will cure the problem.
    Friday, August 17, 2012 7:36 AM
  • Yes .. Probably should be VS2012 related.. Getting RPC Error right after the installation .. 

    Updating to SQL Service Service Pack 2 .. Hopefully it should solve the issue


    Manoj N Shenoy

    Monday, November 12, 2012 2:41 PM
  • I have the same problem after i installed sql 2008 and sql 2012. While the default configuration manager is the 2008 version and i could not see anything from it. But, when I use the 2012 configuration manager under "\Microsoft SQL Server 2012\Configuration Tools" folder, everything is fine. 
    Saturday, August 03, 2013 8:36 PM
  • Remove all the sql server component which was installed with Visual Studio 2013
    • Edited by Md Kasif Friday, March 21, 2014 6:29 AM
    Friday, March 21, 2014 6:29 AM
  • We had this error showing up in SQL 2008 R2 server when we migrated a server from one DC to another DC. So when we brought down the SQL Services, another DBA disabled the services from Services.msc rather than doing it from Config Manager. so when we were bringing it up from Config mgr this error poped up.

    It was resolved, when we changed the mode in services.msc from disabled to enabled and then brought the services up from there rather than brining it up directly from Config manager.

    We did test this after correcting it trying to replicate the message..and yes it was the issue.

    Please give a try and see, if this resolves your issue as mine did.


    Sunday, June 01, 2014 3:01 AM