none
does not have required permissions

    Question

  • Hello,

    I am running vista home + sql express 2008 + reporting services.  I installed everything using window authetication.

    Everything was working fine.  However, now when I try to go to RS http://bvp-pc/Reports_SQLEXPRESS/Pages/Folder.aspx I get an error:

    User 'bvp-PC\bvp' does not have required permissions. Verify that sufficient permissions have been granted and Windows User Account Control (UAC) restrictions have been addressed.

    Can someone point me in the right direction to fix this?  thanks

     

    does not have required permissions

     

     

     

     

     

    Monday, June 07, 2010 6:44 PM

Answers

  • UAC is causing the error, from http://support.microsoft.com/kb/934164.

    1. Configure the report server for local administration. To access the report server and Report Manager locally, follow these steps:
    2. Start Windows Internet Explorer.
    3. On the Tools menu, click Internet Options.
    4. Click Security.
    5. Click Trusted Sites.
    6. Click Sites.
    7. Under Add this Web site to the zone, type http://<var>ServerName</var>. If you are not using HTTPS for the default site, click to clear the Require server certification (https:) for all sites in this zone check box.
    8. Click Add.
    9. Repeat step 7f and step 7g to add the http://localhost URL, and then click Close.
    10. Note This step enables you to start Internet Explorer and open either the localhost or the network computer name of the server for both the Report Server application and the Report Manager application.
    11. Create role assignments that explicitly grant you access together with full permissions. To do this, follow these steps:
    12. Start Internet Explorer together with the Run as administrator option. To do this, click Start, click All Programs, right-click Internet Explorer, and then click Run as administrator.
    13. Open Report Manager. By default, the Report Manager URL is http://<var>ServerName</var>/reports.

      If you use SQL Server Express with Advanced Services SP2, the Report Manager URL is http://<var>ServerName</var>/reports$sqlexpress. If you use a named instance of Reporting Services, the Report Manager URL is http://<var>ServerName</var>/reports$<var>InstanceName</var>
    14. In the Home dialog box, click Properties.
    15. Click New Role Assignment.
    16. Type a Windows user account name by using the following format:
      <var>Domain</var>\<var>User</var>
    17. Click to select the Content Manager check box.
    18. Click OK.
    19. In the Home dialog box, click Site Settings.
    20. Click Configure site-wide security.
    21. Click New Role Assignment.
    22. Type a Windows user account by using the following format:
      <var>Domain</var>\<var>User</var>
    23. Click System Administrator.
    24. Click OK.
    25. Close Report Manager.
    26. Use Internet Explorer without the Run as administrator option to reopen Report Manager.

    Also, see the following thread (look for post that was marked as answer)

    http://social.msdn.microsoft.com/Forums/en-US/sqlreportingservices/thread/e8da121a-c0ac-4d0b-8774-abd5128d88fe

    • Proposed as answer by Janos Berke Monday, June 07, 2010 7:10 PM
    • Marked as answer by bvp07 Monday, June 07, 2010 8:21 PM
    Monday, June 07, 2010 7:02 PM

All replies

  • UAC is causing the error, from http://support.microsoft.com/kb/934164.

    1. Configure the report server for local administration. To access the report server and Report Manager locally, follow these steps:
    2. Start Windows Internet Explorer.
    3. On the Tools menu, click Internet Options.
    4. Click Security.
    5. Click Trusted Sites.
    6. Click Sites.
    7. Under Add this Web site to the zone, type http://<var>ServerName</var>. If you are not using HTTPS for the default site, click to clear the Require server certification (https:) for all sites in this zone check box.
    8. Click Add.
    9. Repeat step 7f and step 7g to add the http://localhost URL, and then click Close.
    10. Note This step enables you to start Internet Explorer and open either the localhost or the network computer name of the server for both the Report Server application and the Report Manager application.
    11. Create role assignments that explicitly grant you access together with full permissions. To do this, follow these steps:
    12. Start Internet Explorer together with the Run as administrator option. To do this, click Start, click All Programs, right-click Internet Explorer, and then click Run as administrator.
    13. Open Report Manager. By default, the Report Manager URL is http://<var>ServerName</var>/reports.

      If you use SQL Server Express with Advanced Services SP2, the Report Manager URL is http://<var>ServerName</var>/reports$sqlexpress. If you use a named instance of Reporting Services, the Report Manager URL is http://<var>ServerName</var>/reports$<var>InstanceName</var>
    14. In the Home dialog box, click Properties.
    15. Click New Role Assignment.
    16. Type a Windows user account name by using the following format:
      <var>Domain</var>\<var>User</var>
    17. Click to select the Content Manager check box.
    18. Click OK.
    19. In the Home dialog box, click Site Settings.
    20. Click Configure site-wide security.
    21. Click New Role Assignment.
    22. Type a Windows user account by using the following format:
      <var>Domain</var>\<var>User</var>
    23. Click System Administrator.
    24. Click OK.
    25. Close Report Manager.
    26. Use Internet Explorer without the Run as administrator option to reopen Report Manager.

    Also, see the following thread (look for post that was marked as answer)

    http://social.msdn.microsoft.com/Forums/en-US/sqlreportingservices/thread/e8da121a-c0ac-4d0b-8774-abd5128d88fe

    • Proposed as answer by Janos Berke Monday, June 07, 2010 7:10 PM
    • Marked as answer by bvp07 Monday, June 07, 2010 8:21 PM
    Monday, June 07, 2010 7:02 PM
  • thanks
    Monday, June 07, 2010 8:21 PM
  • Thanks Chirag, great instructions - worked like a charm for me.

    -Michal

    Tuesday, September 28, 2010 8:11 PM
  • Thanks !!!!!
    Monday, November 15, 2010 11:12 AM
  • Worked for me too. Thanks!


    Tatyana Yakushev [PredixionSoftware.com]
    Wednesday, December 15, 2010 1:37 AM
  • Thanks Chirag.

    Works like a charm.Some how, configuraing SSRS has always been a tricky thing for me. Was never able to do it first-time-right, but thanks to people like you, got it configured successfully in the end.

    - RK

    Thursday, February 24, 2011 9:09 AM
  • Thank you very much!  Perfect instructions
    Tuesday, March 01, 2011 6:09 PM
  • Thank you so much. Your instructions are great.
    Monday, March 21, 2011 4:46 PM
  • Thank you very much, this worked for me.
    Thursday, March 24, 2011 9:48 AM
  • I can't get this far. As soon as I perform all of the operations in the security zones I still get the same error.  I have applied all service packs.  I can get this to work on other computers, just not my own.  Are there any other issues regarding this error message?

    Verify that sufficient permissions have been granted and Windows User Account Control (UAC) restrictions have been addressed.

     

    Thanks

    Saturday, May 21, 2011 4:03 PM
  • This also worked perfectly for me, thank you Chirag.
    Tuesday, May 31, 2011 2:06 PM
  • Does not work for me too...after providing all the permissions, when I http://<var>ServerName</var>/reports, either way by providing the server name or localhost, it throws up the same message

    User 'xxxxxxx\Babu' does not have required permissions. Verify that sufficient permissions have been granted and Windows User Account Control (UAC) restrictions have been addressed.

    Home

     

    Badly in need of help, please help...

    Monday, June 13, 2011 8:56 AM
  • Chirag,

    Your instructions were crystal clear and worked like a charm! Thanks a lot for this.

    -Subbu

    Tuesday, June 14, 2011 1:28 AM
  • Thank you. Very helpful indeed. 
    Friday, June 24, 2011 8:53 AM
  • Spot on, worked on my windows 7 64 bits with SQL 2008R2.

    Many thanks


    Eric Mamet _ MCDBA, SQL Server 2005 MCTS, MCAD .Net
    Wednesday, September 28, 2011 10:44 AM
  • I also had to change the security level on my trusted sites to Low to get this to work
    • Proposed as answer by VincentKool Wednesday, February 08, 2012 8:19 AM
    Wednesday, September 28, 2011 3:09 PM
  • Having the issue still after adding the report server (reports) to the trusted sites, also dropped my secuirty level to Low for trusted sites, no luck. Able to get to report server and add my local account to the System Administrator role by bypassing UAC. Otherwise I can not get the report server through IE. Would appreciate a follow up if anyone has found a solution, thanks.

    Tuesday, December 27, 2011 10:16 PM
  • well I went in and added myself under Home>Folder Settings, and gave my account all permissions there, and it worked.
    Tuesday, December 27, 2011 10:38 PM
  • The main problem is the message is simply too generic, any access or login error will display this error and you really sick having no idea what the underlying problem.

    I had the same error message but the underlying problem is totally different. The reporting service web server actually check your web url, i browse to http://report.mydomain.com/Reports which does not match with the url in the reporting services configuration manager which is http://RPTSERVER/Reports and this produce the same error message.

    Please check the url in reporting services configuration manager. Just sharing my solution with everyone. :)

    Thursday, January 05, 2012 7:13 AM
  • This wasn't working for me using the Trusted Site suggestion. I got it to work by starting Internet Explorer in Administrator mode and then visiting the site. To do this right click on the Internet Explorer icon and chose Run as Administrator from the menu that appears.
    • Edited by Liberty_RP Tuesday, January 10, 2012 3:55 PM
    Tuesday, January 10, 2012 3:54 PM
  • Me too, the only way I can get it to not display the message is to logon with IE with while running with administrative privileges.   I can log right on from another windows box on the same domain with no issue.

    I am running SQL 2008 R2 Express Adv on Windows 7 sp1. 

    I get the same thing with fire fox too.

    Wednesday, January 11, 2012 3:28 PM
  • I am having roughly the same problems as the previous post.

    I placed:

    http://localhost and http://myusername

    in trusted sites and am able to connect to Report Manager if I run IE as administrator, but wouldn't mind not having to log on as administrator each time.

    I don't quite understand the second part of your post, however, this is a good step in the right direction!

    I am running SQL Server 2008R2 Developer on W7SP1.

     

     

     

     

     

    Tuesday, January 31, 2012 9:32 AM
  • Yes, this is an issue where lots of people are facing. So, I have created this post to help you resolve step-by-step:

    http://www.soheib.com/technical-knowledge/sql-server-2012-reporting-services-uac-user-access-control/

    Hope you resolve it


    Friday, March 23, 2012 12:17 PM
  • Thanks - this has been resolved.
    • Edited by meridius10 Friday, March 23, 2012 1:05 PM
    Friday, March 23, 2012 1:05 PM
  • I found that disabling IE ESC (Enhanced Security Configuration) for Administrators and Users stopped this error occurring along with the Folder & Site Settings for that user, e.g. domain\domainuser.  I haven't seen this anywhere on the web so thought i would put it up here as it is first thing that comes up in a google search.
    Friday, April 06, 2012 3:37 PM
  • Worked well for me..Thanks
    Saturday, April 07, 2012 4:35 PM
  • Thanks! worked for me
    Thursday, May 10, 2012 8:30 PM
    1. Click Start, and then click Control Panel.

    2. In Control Panel, click User Accounts.

    3. In the User Accounts window, click User Accounts.

    4. In the User Accounts tasks window, click Turn User Account Control on or off.

    5. If UAC is currently configured in Admin Approval Mode, the User Account Control message appears. Click Continue.

    6. Clear the Use User Account Control (UAC) to help protect your computer check box, and then click OK.

    7. Click Restart Now to apply the change right away, or click Restart Later, and then close the User Accounts tasks window.

    The above mentioned steps fixed my issue

    Friday, June 08, 2012 8:20 PM
  • Check this Youtube Video ...

    http://www.youtube.com/watch?v=nItx9xaJJi4

    and it worked for me

    Tuesday, July 31, 2012 3:53 AM
  • Try in a different browser. I still get the error in IE after trying the steps suggested in the replies but it's ok in Google Chrome. 
    Saturday, September 08, 2012 9:42 AM
  • It works like a charm :) Thank you janos...
    Tuesday, September 11, 2012 3:09 PM
  • Found my answer after hours of searching ... 

    As other users suggest, you need to right-click and choose Run As Administrator.  However, on Windows 7 it seems that Internet Explorer by default does not provide current (e.g., Administrator) user credentials to Reporting Services. What happens then is that you get a login prompt when you try to access Reporting Services. If you get a login prompt, you need to adjust security settings.

    Choose Intenet Options and go to the Security tab. Click on Trusted sites. Either drag the security slider to low security or click on Custom level. If you click on Custom level, go to the User Authentication/Logon option and choose "Automatic logon with current name and password".

    Lifesaving blog post found here
    Thursday, October 04, 2012 5:15 PM
  • I LOVE U ;)
    Sunday, May 12, 2013 1:53 AM
  • thank you sooooo much chirag you salvaged me....
    Monday, November 25, 2013 2:30 PM
  • Thanks for this
    Monday, February 03, 2014 12:50 PM